Results 1 to 6 of 6
Discuss iPhone 3G, plan to upgrade from 3.1.2 to 4.2.1, will I be losing Internet Tethering? at the iOS 4.x (iPhone OS 4.x) - Hackint0sh.org; Hi guys, due to some iOS4 Apps and Features I'm planning to do an upgrade ...
  1. #1
    Rookie Array

    Join Date
    Nov 2007
    Posts
    15
    Post Thanks / Like
    Downloads
    1
    Uploads
    0
    Rep Power
    0

    Default iPhone 3G, plan to upgrade from 3.1.2 to 4.2.1, will I be losing Internet Tethering?

    Hi guys,
    due to some iOS4 Apps and Features I'm planning to do an upgrade from 3.1.2 to 4.2.1. BB 04.26.08, unlock by ultrasn0w. SHSH saved from 4.0 on.

    Question is: Am I gonna lose my well working Internet Tethering once being on 4.2.1? That would be a huge drawback. I'm not on an official carrier data plan (with extra charge for that). Instead I've an APN profile hack which used to circulate back in 2010.

    Thanks in advance,
    bj



  2. #2
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Internet tethering is still possible, but a bit harder to implement.

    You can't use your APN profile hack any more. Now you need to jailbreak and apply this patch http://www.hackint0sh.org/f127/191761.htm then either create an IPCC bundle or edit the generic bundle.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  3. Thanks beingjan thanked for this post.
  4. #3
    Rookie Array

    Join Date
    Nov 2007
    Posts
    15
    Post Thanks / Like
    Downloads
    1
    Uploads
    0
    Rep Power
    0

    Default

    Hi Olethros, hi everybody,
    thanks a lot for replying so speedy. Feeling confident I gave the upgrade a shot. Unfortunately, it failed. Twice. At Error 1600. With and without TinyUmbrella's TSS on. I didn't include the iPad fw. I did answer the question whether I did use PT before YES since it's true: did the upgrade to 3.1.2 a year or so back. Altogether I followed the iClarified 13000 thread.

    After the 1600s I did some research on the forum here but couldn't find any helping thread. So I'd like to ask for a hint to go on.

    Here some details on my situation:
    From iOS: 3.1.2
    To iOS: 4.2.1
    Mac OS X 10.6.5
    iTunes 10.1.1
    PwnageTool 4.1.3 unlock edition
    TinyUmbrella 4.21.07
    the iPhone Updater Log File

    Thanks a lot for giving or pointing me to a thread with help. Luckily I got the Phone out of DFU by doing a long reset (both buttons for 10 Secs).
    Have a nice day, bj.

  5. #4
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Answer no when it asks if you have used PT before..
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  6. #5
    Rookie Array

    Join Date
    Nov 2007
    Posts
    15
    Post Thanks / Like
    Downloads
    1
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by Olethros View Post
    Answer no when it asks if you have used PT before..
    Ok, will give that a try.

    Do I need to use TinyUmbrella in my situation? Or is it rather for newer devices (with hardware-based SHSHs)?

    Thanks a lot! bj.


  7. #6
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    As Apple is still signing 4.2.1 (and you don't have the iPhone 4 where the baseband also has a SHSH), you don't need TinyUmbrella.
    As you said, the 3G has only software-based SHSH, in other words, it's only iTunes that cares about the SHSH for the iPhone 3G (on iOS 4.x).
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

 

 

Similar Threads

  1. Replies: 0
    Last Post: 11-29-2011, 06:10 AM
  2. Replies: 0
    Last Post: 01-26-2011, 04:00 AM
  3. Replies: 0
    Last Post: 05-19-2010, 04:10 AM
  4. Replies: 0
    Last Post: 08-29-2008, 04:20 PM
  5. tmobile internet plan for iphone
    By SOLE_Fresh in forum General
    Replies: 1
    Last Post: 11-12-2007, 02:59 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 01:28 PM.
twitter, follow us!