Page 1 of 2 12 LastLast
Results 1 to 10 of 11
Discuss I want to upgrade to 4.1 not 4.2 at the iOS 4.x (iPhone OS 4.x) - Hackint0sh.org; There are apps in the Cydia store I want to use that do not work ...
  1. #1
    Newbie Array

    Join Date
    Jan 2011
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default I want to upgrade to 4.1 not 4.2

    There are apps in the Cydia store I want to use that do not work with 4.2 therefore I want to upgrade to 4.1
    That being said I know 4.1 is not being signed anymore by Apple.
    Is there a way to upgrade to 4.1?
    When I jailbroke and installed Cydia I did allow for the ECID backup. I have used Tiny Umbrella to get my SHSH but i get the error
    "CYDIA DOES NOT HAVE YOUR SHSH FOR iPhone4 4.0.1 (8A306) THERE IS NO WAY FOR YOU TO GET THEM. SORRY. YOU ARE JUST TOO LATE."
    My iphone 4 is still jailbroken...is there anything I can do?

  2. Thanks kkanuck thanked for this post.


  3. #2
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by tvslave View Post
    There are apps in the Cydia store I want to use that do not work with 4.2 therefore I want to upgrade to 4.1
    That being said I know 4.1 is not being signed anymore by Apple.
    Is there a way to upgrade to 4.1?
    When I jailbroke and installed Cydia I did allow for the ECID backup. I have used Tiny Umbrella to get my SHSH but i get the error
    "CYDIA DOES NOT HAVE YOUR SHSH FOR iPhone4 4.0.1 (8A306) THERE IS NO WAY FOR YOU TO GET THEM. SORRY. YOU ARE JUST TOO LATE."
    My iphone 4 is still jailbroken...is there anything I can do?
    What version of TinyUmbrella are you using? Just because it says that you don't have a 4.0.1 SHSH doesn't guarantee that you have a 4.1 SHSH - check your TinyUmbrella log again

    Without a SHSH there is ABSOLUTELY nothing that you can do to get to 4.1
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  4. #3
    Senior Professional Array

    Join Date
    Sep 2007
    Location
    Atlanta, GA
    Posts
    144
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    I am in the same position....or close anyway, I am factory, no unlock, no jailbreak, but ready for both when safe to do so!

    I am currently on 4.0.2 (8A400) with BB 01.59.00. I have refrained from updating due to the unknown.

    I have used tiny umbrella to save what SHSH blob I can, which is: 4.2.1 (8C148)

    My phone is locked, and not jailbroken...in the US on ATT with ATT iphone sim card

    Can I get to 4.1, jailbroken, and unlocked with no tether, or better to keep waiting?


    Cheers
    Last edited by kkanuck; 01-23-2011 at 09:14 PM.

  5. #4
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by kkanuck View Post
    I am in the same position....or close anyway, I am factory, no unlock, no jailbreak, but ready for both when safe to do so!

    I am currently on 4.0.2 (8A400) with BB 01.59.00. I have refrained from updating due to the unknown.

    I have used tiny umbrella to save what SHSH blob I can, which is: 4.2.1 (8C148)

    My phone is locked, and not jailbroken...in the US on ATT with ATT iphone sim card

    Can I get to 4.1, jailbroken, and unlocked with no tether, or better to keep waiting?
    No you cannot. For 3GS new bootrom, Ipod touch 3rd gen, 4th gen, iPhone 4, iPad and AppleTV 2, it is IMPOSSIBLE to restore to a iOS version unless you have a SHSH saved for that version or Apple is still signing restores to that version.

    As of today. Your only options are:
    Restore to 4.2.1 (and update baseband) - then jailbreak tethered with redsn0w
    Use an unofficial 4.2.1 pwnagetool bundle that prevents baseband update (and restore to 4.2.1 with BB 01.59.00), then jailbreak tethered with redsn0w.

    There are two techniques in development to untether 4.2.1 (one requires a saved SHSH for iOS 4.1 or 4.2b3) the other uses a new kernel exploit and if they are smart, it will not be made public until iOS 4.3 (at the earliest)

    Keep on waiting (and tell your friends to save their SHSH - just in case - even if they don't need jailbreak or unlock now - it is SO important to save your SHSH)
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  6. #5
    Senior Professional Array

    Join Date
    Sep 2007
    Location
    Atlanta, GA
    Posts
    144
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    Quote Originally Posted by Olethros View Post
    No you cannot. For 3GS new bootrom, Ipod touch 3rd gen, 4th gen, iPhone 4, iPad and AppleTV 2, it is IMPOSSIBLE to restore to a iOS version unless you have a SHSH saved for that version or Apple is still signing restores to that version.

    As of today. Your only options are:
    Restore to 4.2.1 (and update baseband) - then jailbreak tethered with redsn0w
    Use an unofficial 4.2.1 pwnagetool bundle that prevents baseband update (and restore to 4.2.1 with BB 01.59.00), then jailbreak tethered with redsn0w.

    There are two techniques in development to untether 4.2.1 (one requires a saved SHSH for iOS 4.1 or 4.2b3) the other uses a new kernel exploit and if they are smart, it will not be made public until iOS 4.3 (at the earliest)

    Keep on waiting (and tell your friends to save their SHSH - just in case - even if they don't need jailbreak or unlock now - it is SO important to save your SHSH)

    Thank you for that...


    So I think I will just wait then, I am in no rush, and I do not have a 4.1 SHSH blob saved (4.2b3) only the 4.0.2 SHSH blob saved!

    When you say it is so important to save SHSH blobs, I wish I could have save mine (4.2b3), but because I did not update to 4.1 while Apple was still signing it, not I have no options correct? I am only able to save the older SHSH blob?

    Thanks again


  7. #6
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    saving SHSH blobs is independent of the firmware you are running on your phone.
    Use tinyUmbrella, connect your phone and click on save SHSH.
    It will attempt to save/retrieve to save all possible SHSH for you.
    You have 4.0.2 blob saved so there is a possibility that you have 4.1 ... Just give tinyumbrella a shot.
    ** If you just want to support hackint0sh.org with a donation click here **

  8. #7
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by kkanuck View Post
    Thank you for that...


    So I think I will just wait then, I am in no rush, and I do not have a 4.1 SHSH blob saved (4.2b3) only the 4.0.2 SHSH blob saved!

    When you say it is so important to save SHSH blobs, I wish I could have save mine (4.2b3), but because I did not update to 4.1 while Apple was still signing it, not I have no options correct? I am only able to save the older SHSH blob?
    That is a common misconception.

    You don't need to update to an iOS version to save your SHSH for that version.

    Just because you are running 4.0.2 doesn't mean you have saved a 4.0.2 SHSH.

    What you do need to do is download and run tinyumbrella with your phone connected to computer via USB. Then click save SHSH. This will query Cydia and Apple to see what SHSH you have saved.

    Once you register your iPhone with Cydia's make my life easier then your request will go into a queue. A few days later (depending in the load) - your request will be processed. Cydia will try and grab the SHSH blobs unique to your device for the iOS versions that Apple is signing at that time and save them for you.

    Once you are registered with Cydia, it will try and request new SHSH for your device as Apple releases new iOS versions. (it doesn't normally request beta versions but 4.2b3 was an exception). Again this is a batch process and your device is one of millions that have signed up for 'make my life easier'. That means that it can take a week or two after a new iOS version is released before a SHSH is requested and saved by Cydia unique to your device and the new iOS version.

    This means that if Apple releases many small iOS updates quickly and stops signing the previous ones cydia might not have had time to save shsh for every device in the queue.

    Do NOT trust what Cydia shows at the top when you open it. This information is not updated very often (it updates once a month or so ). This is because updating this information more often slows Cydia's servers down too much. So often you have more SHSH saved than is displayed on the Cydia home screen.

    As long as you let TinyUmbrella finish the save my SHSH request it is accurate.

    I think it is very strange that you have a 4.2b3 and 4.0.2 SHSH but not 4.1. That doesn't make sense.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  9. #8
    Senior Professional Array

    Join Date
    Sep 2007
    Location
    Atlanta, GA
    Posts
    144
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    Thanks to both of you for responses...much appreciate it!


    I have connected my device, an iphone 4 original, on FW 4.0.2 (from the factory, never updated as of yet), no jailbreak or unlock, on ATT in the US, to the last version of TINY Umbrella and ran the "save SHSH Blob"

    After performing this, the only SHSH blob it would save is: 4.2.1 (8C148)

    This is what shows up in Tiny Umbrella now when I connect my phone even now.

    I am wanting to jailbreak, and unlock, and update to a newer firmware, as it seems like many apps are already not running on my older FW.

    So this is my predicament. I do not have an SHSH blob created by Tiny Umbrella that is the 4.2.1B, only the 4.2.1 and it seems like from what I have read, I need the 4.2.1B to go forward with the current tools available and not take my baseband forward from its current of 00.1.59?

    Sorry for all the confusion, but hopefully this will help others like me too!


    Cheers,

  10. #9
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by kkanuck View Post
    I am wanting to jailbreak, and unlock, and update to a newer firmware, as it seems like many apps are already not running on my older FW.

    So this is my predicament. I do not have an SHSH blob created by Tiny Umbrella that is the 4.2.1B, only the 4.2.1 and it seems like from what I have read, I need the 4.2.1B to go forward with the current tools available and not take my baseband forward from its current of 00.1.59?

    Sorry for all the confusion, but hopefully this will help others like me too!
    As of today you need a 4.2beta3 SHSH to achieve an untethered jailbreak on 4.2.1. (via the jb monte technique from the iPhone dev team) This will change - a new kernel exploit that can untether 4.2.1 (and hopefully 4.3) has been demonstrated by chronic dev team.

    If you *just* want to keep 01.59 baseband (to keep the option to unlock at some point in the future) There is a special pwnagetool bundle (unofficial - not from the iPhone dev team) that does not jailbreak your iPhone 4 but only prevents baseband update when restoring to 4.2.1 using this special custom IPSW.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  11. #10
    Senior Professional Array

    Join Date
    Sep 2007
    Location
    Atlanta, GA
    Posts
    144
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    Thanks for all your efforts to explain Olethros.

    I think I will do nothing and wait until there is a better easier method as it seems it is a little tricky presently....if I want to remain on 01.59 baseband, as I would like the phone to be unlocked, and I also want to jailbreak.

    With my lack of a correct SHSH Blob saved, aside from the only SHSH Blob tiny Umbrella would make for my iphone 4 on my 4.0.2 which is: (4.2.1(8C148)-2172549942638)

    I think I should rather just be patient rather and hope the Dev Team will find a way for me to get to the latest FW of 4.2.1, or later, and jailbreak and carrier unlock using one type of program like Pwnage etc...


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 2
    Last Post: 07-20-2008, 05:20 PM
  2. [Upgrade]OTB 1.1.2 Upgrade to 1.1.4 W/O Unlock/Activate/Jailbreak
    By Allingby in forum iPhone "2G" (Rev. 1)
    Replies: 2
    Last Post: 05-13-2008, 10:36 AM
  3. Replies: 8
    Last Post: 03-18-2008, 04:37 AM
  4. Replies: 0
    Last Post: 01-25-2008, 08:37 PM
  5. [1.1.3] Jailbreak/Upgrade, does 1.1.2u unlock Survive upgrade?
    By mdfreeman in forum iPhone "2G" (Rev. 1)
    Replies: 5
    Last Post: 01-25-2008, 04:27 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 01:29 PM.
twitter, follow us!