Hi Hackint0sh iPhone community. I am requesting help to get my iPhone out of recovery mode.

A iPhone was recently given to me and it is stuck in recovery mode. The owner said it was originally Jailbroke, but he did not know what with. I have tried the following to get it out of Recovery, but all have failed.

1) iRecovery
- setenv boot-args "rd=md0 nand-enable-reformat=1 -progress=1"
- setenv auto-boot false
- saveenv
- reboot
-> Recover with iTunes

2) Redsn0w - tried all combination of options
-->Mounting rootfs as read-only...
-->ERROR!

3) Sn0wbreeze

4)iREB

5)iTunes recovery
-Recovery mode
-DFU Mode

6) Different computer

7) Different USB slots

iTunes always hangs at one of the following positions

operation 13 progress 6
--> ASR progress: Sending payload

or sometimes

operation 13 progress 7
--> ASR progress: Sending payload

The firmware is 4.2.1

Here is the log.
2011-09-16 20:25:47.195 [1008:d84]: restore library built Feb 7 2011 at 06:28:5 - Pastebin.com

Any help would be greatly appreciated.