Page 1 of 2 12 LastLast
Results 1 to 10 of 11
Discuss error code 9 restoring iphone4 at the iOS 4.x (iPhone OS 4.x) - Hackint0sh.org; I have a factory unlocked iphone 4 coming with ios 4.2.1 each time I tried ...
  1. #1
    Newbie Array

    Join Date
    Dec 2010
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Angry error code 9 restoring iphone4

    I have a factory unlocked iphone 4 coming with ios 4.2.1
    each time I tried to restor it to 4.2.1 or now to 4.3.1, every thing goes ok but in restoring firmware, errror code 9 is appeared and iphone goes to recovery mode. I should use tiny umrella or fix recovery preserving my BB. I checked different cables and pcs as apple says but the problem has not fixed. also I restored 2 other factory unlocked iphone4 with my pc and there was no problem.

    I used redsnow for tethered jailbreak first time. could any one help me to find the problem? is the problem related to iphone or jailbreak process?



  2. #2
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Have you replaced the battery with a non official one? Did you use an original IPSW or a custom IPSW?
    Please publish your restore log file (see the link in my signature)
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  3. #3
    Newbie Array

    Join Date
    Dec 2010
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I've not changed battery and IPSW is the original one.
    here is the restore log: 4.3.1 restore log - Pastebin.com

  4. #4
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Olethros is better at this than I, but it looks like it is failing while updating the baseband. What baseband are you on? Were you having radio/bluetooth/wifi problems before the restore?


    Sent from my iPhone using Tapatalk
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  5. #5
    Newbie Array

    Join Date
    Dec 2010
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    it's 03.10.01 and I didnt have any radio/bluetooth/wifi problems before the restore.


  6. #6
    Newbie Array

    Join Date
    Dec 2010
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    still wait for help...

  7. #7
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    I've not seen this specific combination of errors before, it looks like you are getting a correctly signed SHSH (including the signing of the baseband) but then the later stage of the restore is assuming you don't need this signed baseband and throwing it away, which is causing the restore error.

    I was not expecting this message to appear
    device software does not support nonce generation
    It could be that something is screwed in your baseband - I don't think this message shouldn't come up
    AppleBCMWLAN::handleIOKitBusyWatchdogTimeout(): Error, no successful firmware download after 60000 ms!! Giving up...
    I don't have so much experience in troubleshooting iPhone 4 restore logs, so take what I have written with a grain of salt. I'd recommend comparing with a known good log.

    What puzzles me is that error 9 usually represents a kernel crash, but there is no sign of that happening in your log.

    I wish I had more answers for you, right now I can only say that it looks to either be a confused/corrupt baseband or an out of date apple mobile device service (part of the iTunes install) on your computer.

    Suggestions: restore with a 4.3.1 custom IPSW with baseband update disabled. Then try a reset network settings
    Or completely remove and reinstall iTunes on your machine (rebooting after uninstall and again after install) - Apple has support documents explaining how to properly remove iTunes on Windows or Mac. and confirm that you have no entries to gs.apple.com in your hosts file.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  8. #8
    Newbie Array

    Join Date
    Dec 2010
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    as I told before when I bought my iphone 4 there wasnt any untethered jailbreak available for 4.2.1 so I used redsn0w for tethered jailbreak. could be any relation between redsn0w and my problem? thanks for reply. because of my problem I used tiny umbrella each time for restore so it may change my host file and couse the error9!!?

  9. #9
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by alireza.kashani View Post
    as I told before when I bought my iphone 4 there wasnt any untethered jailbreak available for 4.2.1 so I used redsn0w for tethered jailbreak. could be any relation between redsn0w and my problem? thanks for reply. because of my problem I used tiny umbrella each time for restore so it may change my host file and couse the error9!!?
    Well now you *must* use tiny umbrella for any restore aside from 4.3.1 as Apple no longer signs older restores.

    The log looks similar to the logs people get when the restore fails with a 101x error (baseband can't be updated) - the weird thing is that you get an error 9.

    The only way redsn0w could *maybe* have an impact is if you have used the wrong version of redsn0w/IPSW
    Last edited by Olethros; 04-07-2011 at 09:45 PM.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  10. #10
    Senior Professional Array

    Join Date
    Dec 2007
    Posts
    143
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    did you try dfu mode as well
    iPhone 4 iOS 4.2.1
    Jailbroken and unlocked
    My website:
    -websites removed, does not comply with site rules related to signatures: see http://www.hackint0sh.org/f18/69493.htm for more details-
    Call In/Out - Yes/Yes
    SMS In/Out - Yes/Yes
    EDGE/WIFI - Yes/Yes
    YouTube - Yes
    Jailbreak-Yes


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. iphone4 not on after restoring
    By x-tra in forum iOS 4.x (iPhone OS 4.x)
    Replies: 1
    Last Post: 09-07-2011, 09:00 AM
  2. Replies: 3
    Last Post: 08-24-2011, 06:47 AM
  3. Replies: 18
    Last Post: 02-18-2010, 06:19 PM
  4. Ultrasn0w Error-sub process usr bin dpkg returned an error code 1
    By ilavu in forum Ultrasn0w (3G(S)/iPhone 4 unlock)
    Replies: 5
    Last Post: 06-25-2009, 05:07 PM
  5. Error Code (21) while restoring with custom .ipsw
    By aerohunter in forum PwnageTool
    Replies: 2
    Last Post: 03-03-2009, 10:34 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 01:21 AM.
twitter, follow us!