Results 1 to 8 of 8
Discuss Error Code 21 at the iOS 4.x (iPhone OS 4.x) - Hackint0sh.org; Say a thread bellow about this, but know one answered it. My iPhone 4 is ...
  1. #1
    Professional Array caboboy702's Avatar

    Join Date
    Dec 2007
    Location
    Las Vegas, NV.
    Posts
    92
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Unhappy Error Code 21

    Say a thread bellow about this, but know one answered it.

    My iPhone 4 is on iso 5.0.1 and has been jailbroken with Redsn0w's tethered jailbreak.

    So all I wanted to do is do a CLEAN restore to 5.0.1 and then re-jailbreak with Redsn0w's un-tethered jailbreak, and all I get is error 21 everytime I try to restore. No matter what computer or USB cord I use I get the same error code 21.

    Both iTunes and Redsn0w are the most resent.

    Any HELP would be Greatly Appericated.....
    Now the iPhone 4
    The ulitmate iPhone...... :-)



  2. #2
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Several solutions were provided in the forum post below that should apply to you as well.

    Either you're restoring a custom firmware and not a stock one (are you shift restoring? If so, where'd you get the .IPSW? Is it custom? Are you attempting to block a baseband update?) and you're not in Pwned DFU mode, or you have a line in your hosts file pointing to gs.apple.com, or you're having intermittent network issues.

    In any case, more info would be helpful. Specifically, what iOS revision file you downloaded, where you got it, whether you're making a custom .IPSW to block the baseband, etc. If you've downloaded a stock .IPSW from Apple and haven't customized it, you'll want to check for network issues as well as they can prevent you from being able to receive the TSS response from iTunes.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  3. #3
    Professional Array caboboy702's Avatar

    Join Date
    Dec 2007
    Location
    Las Vegas, NV.
    Posts
    92
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    Quote Originally Posted by n1ckn4m3 View Post
    Several solutions were provided in the forum post below that should apply to you as well.

    Either you're restoring a custom firmware and not a stock one (are you shift restoring? If so, where'd you get the .IPSW? Is it custom? Are you attempting to block a baseband update?) and you're not in Pwned DFU mode, or you have a line in your hosts file pointing to gs.apple.com, or you're having intermittent network issues.

    In any case, more info would be helpful. Specifically, what iOS revision file you downloaded, where you got it, whether you're making a custom .IPSW to block the baseband, etc. If you've downloaded a stock .IPSW from Apple and haven't customized it, you'll want to check for network issues as well as they can prevent you from being able to receive the TSS response from iTunes.
    First off I'm not using or trying to use a custom firmware. I'm just tring to do CLEAN restore to 5.0.1 after jailbeaking with Redsn0w's tethered jailbreak. And then jailbreak again with Redsn0w's UN-tethered jailbreak.

    I used iTunes to try to restore with there own ipsw. and also have downloaded iso 5.0.1 from iClarified and pointed iTunes to the ipsw with shift restore that I downloaded from iClarified and I get the same thing everytime error code 21.
    Now the iPhone 4
    The ulitmate iPhone...... :-)

  4. #4
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Did you check your hosts file for any lines that point to gs.apple.com? Beyond that, I hate to say I don't know what to tell you. If you're using an OEM apple cable, you've tried other cables and other computers, other usb ports, etc., you don't have anything in your hosts file pointing to gs.apple.com, you're using a standard firmware and your iTunes passes all network and software diagnostic tests, I'm stumped...
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  5. #5
    Professional Array caboboy702's Avatar

    Join Date
    Dec 2007
    Location
    Las Vegas, NV.
    Posts
    92
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    Quote Originally Posted by n1ckn4m3 View Post
    Did you check your hosts file for any lines that point to gs.apple.com? Beyond that, I hate to say I don't know what to tell you. If you're using an OEM apple cable, you've tried other cables and other computers, other usb ports, etc., you don't have anything in your hosts file pointing to gs.apple.com, you're using a standard firmware and your iTunes passes all network and software diagnostic tests, I'm stumped...
    How do I check if my host file is pointing to gs.apple.com?

    Checked iTunes software diagnostic and it says NO iPhone found, but everthing else is working.
    Now the iPhone 4
    The ulitmate iPhone...... :-)


  6. #6
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    If you're on a PC, open C:\windows\system32\drivers\etc\hosts in a text editor and review the contents. If any line exists with gs.apple.com that doesn't start with "#", remove it.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  7. #7
    Professional Array caboboy702's Avatar

    Join Date
    Dec 2007
    Location
    Las Vegas, NV.
    Posts
    92
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    Quote Originally Posted by n1ckn4m3 View Post
    If you're on a PC, open C:\windows\system32\drivers\etc\hosts in a text editor and review the contents. If any line exists with gs.apple.com that doesn't start with "#", remove it.
    Found out what it was. Tinyunbrella was causing the problem. Un checked Set Host to Cydia on Exit and I was able to restore to iso 5.0.1.

    Thanks for your help.
    Now the iPhone 4
    The ulitmate iPhone...... :-)

  8. #8
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    No problem, glad to hear it's taken care of!
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


 

 

Similar Threads

  1. error code 9 restoring iphone4
    By alireza.kashani in forum iOS 4.x (iPhone OS 4.x)
    Replies: 10
    Last Post: 04-08-2011, 01:05 PM
  2. Error Code 1611?
    By nevz in forum iOS 3.x (iPhone OS 3.x)
    Replies: 0
    Last Post: 08-08-2010, 12:06 AM
  3. Replies: 18
    Last Post: 02-18-2010, 06:19 PM
  4. Getting Error Code (10)
    By lonesome in forum Redsn0w
    Replies: 2
    Last Post: 09-18-2009, 06:54 AM
  5. Ultrasn0w Error-sub process usr bin dpkg returned an error code 1
    By ilavu in forum Ultrasn0w (3G(S)/iPhone 4 unlock)
    Replies: 5
    Last Post: 06-25-2009, 05:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 12:18 PM.
twitter, follow us!