Results 1 to 5 of 5
Discuss Is this doable Downgrade iPhone 4 ios 4.2 to 4.0.1 to JB/Unlock? at the iOS 4.x (iPhone OS 4.x) - Hackint0sh.org; Hi yo'll. i am new here and also new to iphones. i hope this is ...
  1. #1
    i4n
    i4n is offline
    Newbie Array

    Join Date
    Oct 2010
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Is this doable Downgrade iPhone 4 ios 4.2 to 4.0.1 to JB/Unlock?

    Hi yo'll. i am new here and also new to iphones. i hope this is the right place to post my question.

    1-My very basic question is i just got an iphone 4 this week with ios 4.02. i just want to be able to use it on Tmobile.
    my theory is to downgrade to ios 4.1 or 4.01 (Q? which should i go for?);
    then JB and unlock it.
    Q? will this work?
    to be safe i have already saved my SHSH files on saurik's server.
    i was thinking i can get it activated at an att store, or borrow a friends att sim card. Q? once the phone gets connected to itunes 9.2+ will this harm the phone as far as JB/unlocking it? i.e. will apple block the phone somehow or...i should not have any worry on that.
    Q? will any att sim card work to activate the phone?

    if my theory is not workable then is there another way?



  2. #2
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Quote Originally Posted by i4n View Post
    1-My very basic question is i just got an iphone 4 this week with ios 4.02. i just want to be able to use it on Tmobile.
    my theory is to downgrade to ios 4.1 or 4.01 (Q? which should i go for?);
    then JB and unlock it.
    Q? will this work?
    iPhone 4 with iOS 4.0.2 means that the jailbreakme.com website patch (PDF exploit fix) has been applied (so the jailbreakme.com jailbreak will not work on the device), but the baseband itself is the same as 4.0.1, so it can still be unlocked with ultrasn0w.

    My recommendation is that you do NOT attempt to downgrade (there's really no benefit to running 4.0 or 4.0.1 over 4.0.2), and just run greenpoison (or limera1n if you really want to, though I recommend greenpoison) to jailbreak your device running 4.0.2. After that is done, you can install ultrasn0w to unlock the baseband from Cydia. Greenpoison and limera1n will hacktivate the device, so you will NOT need an official AT&T SIM in order to bypass the 'Activation Required' screen, the jailbreak will take care of that and hacktivate for you.

    Great job getting the SHSH for 4.0.1 and 4.0.2 on file -- this will make sure that if you have any problems, you can revert back to your original iOS and do not threaten the ability to unlock.

    EDIT: I misspoke above, greenpoison does not currently jailbreak 4.0/4.0.1/4.0.2, it only jailbreaks 4.1. If you're on 4.0.2, it's recommended to use TinyUmbrella to upgrade to 4.1 (if you are still on a 4.0/4.0.1/4.0.2 baseband), so that your unlock isn't threatened. If you cannot, limera1n will work for 4.0/4.0.1/4.0.2.

    Good luck!
    Last edited by n1ckn4m3; 10-14-2010 at 07:30 PM.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  3. #3
    i4n
    i4n is offline
    Newbie Array

    Join Date
    Oct 2010
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    thanx!
    i understand only itunes 9.2 and above will recognise iphone 4. will this have any negative effect on my phone before or after i use poison on it?

  4. #4
    i4n
    i4n is offline
    Newbie Array

    Join Date
    Oct 2010
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    BTW what version of itunes is safe to do this with?

  5. #5
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by i4n View Post
    BTW what version of itunes is safe to do this with?
    Except Spirit (which only worked with iTunes 9.1.x) all known versions of iTunes are generally safe for jailbreaking.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!


 

 

Similar Threads

  1. Is it doable?
    By tfphoenix in forum Hardware
    Replies: 9
    Last Post: 08-28-2009, 04:18 AM
  2. Replies: 0
    Last Post: 07-18-2008, 06:35 AM
  3. iPhone + Prepaid, still doable?
    By Cybbe in forum General
    Replies: 0
    Last Post: 01-17-2008, 05:21 AM
  4. Unlock a downgrade iPhone ??
    By FerdinandC in forum iPhone "2G" (Rev. 1)
    Replies: 1
    Last Post: 10-07-2007, 05:20 AM
  5. Want to unlock/downgrade your iPhone?? PLEASE READ
    By nutdhanai in forum iPhone "2G" (Rev. 1)
    Replies: 0
    Last Post: 10-02-2007, 09:23 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 12:53 AM.
twitter, follow us!