Results 1 to 4 of 4
Discuss 3GS on version 3.0 upgrade to 4.x at the iOS 4.x (iPhone OS 4.x) - Hackint0sh.org; I have a 3GS on version 3.0, no SIM card. I would like to upgrade ...
  1. #1
    Newbie Array

    Join Date
    Sep 2010
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default 3GS on version 3.0 upgrade to 4.x

    I have a 3GS on version 3.0, no SIM card. I would like to upgrade to 4.x and jailbreak/unlock, but right now I can only upgrade to 4.0.2, for which the jailbreak is not available yet. Trying to Restore to version 4.0.1 gives the message "invalid image". Should I jailbreak now on 3.0 with redsn0w, and wait to upgrade to 4.x later? Anyway for me to get to 4.0.1?
    Thanks,
    Moshe



  2. #2
    Professional Array

    Join Date
    Feb 2008
    Posts
    75
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    I would like to see an answer to this as well!
    I currently have a jailbroken 3gs on 3.1.3
    I have tried to upgrade to 4.0 with itunes 10 and am receiving an error also:

    2010-09-04 18:23:57.363 [3872:e04]: [tss] error from server=94 (This device isn't eligible for the requested build.)
    2010-09-04 18:23:57.364 [3872:e04]: server error (94): This device isn't eligible for the requested build.
    2010-09-04 18:23:57.364 [3872:e04]: _AMRAuthInstallCopyPreflightOptions: failed to personalize bundle (3194)
    2010-09-04 18:23:57.514 [3872:f24]: iTunes: Restore error 3194

    Have apple stopped signing 4.0?
    Because I would really like to update to 4.x and jailbreak.
    ---------Update---------

    Since I have 4.0 and 4.0.1 SHSH backed up on cydia's server, I was able to edit my HOSTS file, and I am now able to install 4.0 onto my 3GS.

    mlinzer: It looks like apple have stopped signing 4.0, and you will only be able to install that version if you have you phones SHSH on file.
    Last edited by bigkev81; 09-04-2010 at 10:49 AM.

  3. #3
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Yep, you're correct. Apple has stopped signing 4.0, 4.0.1, and is only signing 4.0.2 and 4.1 right now. I expect 4.0.2 will stop being signed in the next week or so, so get your 4.0.2 SHSH's on file ASAP! You won't have the opportunity to do so for much longer. Since 4.1 contains a new baseband, it's recommended not to upgrade as you will lock the phone again (if it's not factory unlocked), and it may be a long time before the baseband in 4.1 is unlocked (if ever).
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  4. #4
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by n1ckn4m3 View Post
    Yep, you're correct. Apple has stopped signing 4.0, 4.0.1, and is only signing 4.0.2 and 4.1 right now. I expect 4.0.2 will stop being signed in the next week or so, so get your 4.0.2 SHSH's on file ASAP! You won't have the opportunity to do so for much longer. Since 4.1 contains a new baseband, it's recommended not to upgrade as you will lock the phone again (if it's not factory unlocked), and it may be a long time before the baseband in 4.1 is unlocked (if ever).
    Just checked, 4.0.2 is still being signed. 4.0.1 is NOT being signed by Apple

    Now 4.1 is out, we are talking days before 4.0.2 is no longer signed
    I reiterate what n1ckn4m3 said - get your 4.0.2 SHSH's on file ASAP

    This is especially important to 3G and 3GS owners who have not yet upgraded to iOS 4.x
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

 

 

Similar Threads

  1. KP after upgrade... Mac OS version: Not Set Yet
    By itsjared in forum Installation
    Replies: 0
    Last Post: 01-11-2010, 06:29 AM
  2. Upgrade from 1.0.2 to version 3.0
    By wanderlustsoul in forum iPhone "2G" (Rev. 1)
    Replies: 30
    Last Post: 09-12-2009, 08:30 PM
  3. Upgrade of 3G on version 2.0
    By ijd in forum Quickpwn 3G
    Replies: 1
    Last Post: 10-28-2008, 09:10 AM
  4. i have version 1.1.1 unlocked. can i upgrade?
    By lav10 in forum iPhone "2G" (Rev. 1)
    Replies: 1
    Last Post: 02-15-2008, 11:01 AM
  5. Unlocked version 1.0.0, how to upgrade
    By robewilliams in forum iPhone "2G" (Rev. 1)
    Replies: 3
    Last Post: 11-13-2007, 01:54 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 11:57 AM.
twitter, follow us!