Page 1 of 2 12 LastLast
Results 1 to 10 of 17
Discuss YouTube on 3.0 is driving me crazy! at the iOS 3.x (iPhone OS 3.x) - Hackint0sh.org; Hey there, I own an iPhone 2G. Since beta 2, I had every version of ...
  1. #1
    Professional Array Horstbert's Avatar

    Join Date
    Nov 2007
    Location
    Germany
    Posts
    79
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default YouTube on 3.0 is driving me crazy!

    Hey there,

    I own an iPhone 2G. Since beta 2, I had every version of 3.0 installed, including the recent 4th release. Everything is working like a charm, except YouTube. It didn't work for many people in beta 2, but beta 3 obviously solved the problem for everyone except me, even when restored from a backup. Now, on beta 4, it still doesn't work for me! It always says "cant connect to YouTube". Yes, I restored from a backup, but I don't wanna lose all my texts and call log, which I cant copy manually due to the lack of a jailbreak.

    Anyone having the same problem? Any suggestions?

    Thanks!
    Last edited by Horstbert; 04-30-2009 at 02:45 PM.



  2. #2
    Amazingly Knowledgeable Array

    Join Date
    Oct 2007
    Posts
    790
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    54

    Default

    I couldn't get youtube to work either on Beta 3 but then I updated to Beta 4 and it works fine for me!
    iPhone US 8GB
    FW 1.0.2--> iUnlock--> iPhoneSIMfree--> 1.1.1 --> 1.1.2--> Soft upgrade 1.1.3 --> 1.1.4 using signal.app
    iPhone UK 16GB
    FW 1.1.3 OOB --> 1.1.4 --> iPlus 1.2 unlocked!

    <----If I helped you out, rep points are always nice (thanks for that idea!)

  3. #3
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Quote Originally Posted by Horstbert View Post
    Hey there,

    I own an iPhone 2G. Since beta 2, I had every version of 3.0 installed, including the recent 4th release. Everything is working like a charm, except YouTube. It didn't work for many people in beta 2, but beta 3 obviously solved the problem for everyone except me, even when restored from a backup. Now, on beta 4, it still doesn't work for me! It always says "cant connect to YouTube". Yes, I restored from a backup, but I don't wanna lose all my texts and call log, which I cant copy manually due to the lack of a jailbreak.

    Anyone having the same problem? Any suggestions?

    Thanks!
    3.0 B3 fixed it for me, but what you may want to do is downgrade your device to 3.0 B3, do a backup in iTunes, pull your SMS and Call Log .db files from the iTunes backup, shift-restore to 3.0 B3 (yes, 3), then set the phone up as a NEW iPhone, then jailbreak and use DiskAid to then copy the databases over to the device. Reboot the phone, allow it to sync, make it do a backup, your YouTube should work and you should have your SMS and Call Logs -- then upgrade to Beta 4...

    That *should* get rid of the YouTube issue for you.

  4. #4
    Professional Array Horstbert's Avatar

    Join Date
    Nov 2007
    Location
    Germany
    Posts
    79
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    Quote Originally Posted by n1ckn4m3 View Post
    3.0 B3 fixed it for me, but what you may want to do is downgrade your device to 3.0 B3, do a backup in iTunes, pull your SMS and Call Log .db files from the iTunes backup, shift-restore to 3.0 B3 (yes, 3), then set the phone up as a NEW iPhone, then jailbreak and use DiskAid to then copy the databases over to the device. Reboot the phone, allow it to sync, make it do a backup, your YouTube should work and you should have your SMS and Call Logs -- then upgrade to Beta 4...

    That *should* get rid of the YouTube issue for you.
    Whoa... thanks for your reply! I'm not sure if YouTube is important enough for me to go through this process... But I know myself, i will try it later when I have the time to do it. I figured out something like this by myself but considered it too extensive just to get YouTube working. On the other hand, it is bugging me when something doesn't work as it should!

    I'll wait for some other suggestions, shouldn't there be any, I'll give it a try!

  5. #5
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Hehehe. I definitely won't say it's an easy process -- I'm going to be doing similar when 3.0 finally comes out properly... Since I've got a lot of junk on my phone from many OS upgrades, etc., when the final version comes out I'm going to do the exact same to get a clean phone with all of my data. If you run through the steps, let the forum know whether it works

    Good luck!


  6. #6
    Newbie Array

    Join Date
    Apr 2007
    Posts
    8
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    There is a MUCH simpler solution! I've been using this method since I had the original iPhone. Most people don't know that you can selectivley delete parts from your backup and it will still be a valid backup which iTunes can restore from. NOTE BEFORE YOU DO THESE STEPS, MAKE A COPY OF YOUR BACKUP. I usually just right click my backup folder and create an archive so if anything goes wrong all I have to do is unzip the archive. So ... backups are made of a bunch of files which are paired. I think one is a .mdata and the other is a .minfo I may have the extensions wrong but you get the point. So all you have to do is figure out which files contain your SMS.db and your call log and keep those and delete the other files (there are also three plist files which define the backup and they should not be deleted.) so basically you'll end up with a backup that contains only your SMS.db and your call log. A simple way to find out which files contain your SMS and call info is to take only the .minfo files and rename them to .txt then do a file contents search for "SMS" and "call" , you'll be able to find out which files contain the info you want to keep. The great thing is that once you find out which files contain your sms and call log those will never change so you'll be able to use this method again without having to go through the step of finding which backup files contain the info you want to keep. I'm writing this from my iPhone and for some reason I can't do a return on this text field.

  7. #7
    Senior Professional Array

    Join Date
    Jul 2007
    Posts
    244
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    19

    Default

    Quote Originally Posted by Horstbert View Post
    Hey there,

    I own an iPhone 2G. Since beta 2, I had every version of 3.0 installed, including the recent 4th release. Everything is working like a charm, except YouTube. It didn't work for many people in beta 2, but beta 3 obviously solved the problem for everyone except me, even when restored from a backup. Now, on beta 4, it still doesn't work for me! It always says "cant connect to YouTube". Yes, I restored from a backup, but I don't wanna lose all my texts and call log, which I cant copy manually due to the lack of a jailbreak.

    Anyone having the same problem? Any suggestions?

    Thanks!
    Dude, you are not alone. Youtube in 3.0 beta 1 - 4 has never worked for me.

  8. #8
    Senior Professional Array

    Join Date
    Jul 2007
    Posts
    244
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    19

    Default

    Quote Originally Posted by n1ckn4m3 View Post
    3.0 B3 fixed it for me, but what you may want to do is downgrade your device to 3.0 B3, do a backup in iTunes, pull your SMS and Call Log .db files from the iTunes backup, shift-restore to 3.0 B3 (yes, 3), then set the phone up as a NEW iPhone, then jailbreak and use DiskAid to then copy the databases over to the device. Reboot the phone, allow it to sync, make it do a backup, your YouTube should work and you should have your SMS and Call Logs -- then upgrade to Beta 4...

    That *should* get rid of the YouTube issue for you.
    How was your iPhone updated from 2.X to 3.0 beta? Is your iPhone on official carrier? Mine was upgraded via the following way:

    - restored down to 2.0.2 and then Quickpwned with quickpwn RC 3 (on Windows)
    - updated to 3.0 beta 1 (Mac)
    - updated to 3.0 beta 2 (Mac)
    - updated to 3.0 beta 3 (Mac)
    - updated to 3.0 beta 4 (Mac)

  9. #9
    Senior Professional Array

    Join Date
    Jul 2007
    Posts
    244
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    19

    Default This only works if your carrier is official

    Quote Originally Posted by n1ckn4m3 View Post
    3.0 B3 fixed it for me, but what you may want to do is downgrade your device to 3.0 B3, do a backup in iTunes, pull your SMS and Call Log .db files from the iTunes backup, shift-restore to 3.0 B3 (yes, 3), then set the phone up as a NEW iPhone, then jailbreak and use DiskAid to then copy the databases over to the device. Reboot the phone, allow it to sync, make it do a backup, your YouTube should work and you should have your SMS and Call Logs -- then upgrade to Beta 4...

    That *should* get rid of the YouTube issue for you.
    There is a big catch in this. After restoring to 3.0 beta 3, iPhone is no longer activated. In order to get to the screen to set up the iPhone as a NEW iPhone, you must have an official carrier's SIM card in the iPhone. Fortunately, i have access to an official carrier's SIM card so i was able to set up my iPhone as a NEW iPhone. After activating and jailbreaking with quickpwn, iPhone recognized my T-Mobile (non-official carrier) SIM. Youtube worked. But when i updated to beta 4, my iPhone is unactivated. I see the purple screen on iPhone and the message "Different SIM detected - Please connect to iTunes". Since there is currently no quickpwn for beta 4 in iPhone 2G, there is no way to activate my iPhone.

  10. #10
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Quote Originally Posted by ktula View Post
    How was your iPhone updated from 2.X to 3.0 beta? Is your iPhone on official carrier? Mine was upgraded via the following way:

    - restored down to 2.0.2 and then Quickpwned with quickpwn RC 3 (on Windows)
    - updated to 3.0 beta 1 (Mac)
    - updated to 3.0 beta 2 (Mac)
    - updated to 3.0 beta 3 (Mac)
    - updated to 3.0 beta 4 (Mac)
    Official AT&T customer with standard legit SIM and iPhone 3G.

    Here goes:

    - 2.2.1 completely wiped and erased. DFU restore of 2.2.1 after as the wipe and erase caused ASOD. Set up as old iPhone. (PC) (YouTube)
    - updated to 3.0 beta 1 and set up as old iPhone (PC) (No YouTube)
    - downgraded to 2.2.1 and set up as old iPhone (PC) (YouTube)
    - updated to 3.0 beta 2 and set up as old iPhone (PC) (No YouTube)
    - QuickPWN'd 3.0 beta 2. (No YouTube)
    - updated to 3.0 beta 3 and set up as old iPhone (PC) (YouTube)
    - QuickPWN'd 3.0 beta 3. (YouTube)
    - updated to 3.0 beta 4 and set up as old iPhone (PC) (YouTube)

    Haven't messed with a jailbreak on beta 4 yet, frankly, I don't think I will until 3.0 proper releases, the jailbreaks have all been pretty buggy and Icy is a pile of poo at the moment...


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 0
    Last Post: 07-12-2011, 06:20 AM
  2. Intermittant Wifi is Driving Me Crazy
    By slevytam in forum General
    Replies: 4
    Last Post: 11-19-2007, 09:29 PM
  3. Please Help. Phone Is Driving Me Crazy!!
    By jay_designuk in forum General
    Replies: 4
    Last Post: 11-06-2007, 05:06 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 02:16 PM.
twitter, follow us!