i am a att customer, i recently rolled back to 3.0.1 using jaVoX's method. however i am carrier 4. how can i update to carrier 6 without updating to 3.1 i want to keep benm's tether method. thanks.