Page 1 of 2 12 LastLast
Results 1 to 10 of 15
Discuss Trying a custom FW 3.1 restore(win xp) at the iOS 3.x (iPhone OS 3.x) - Hackint0sh.org; iPhone 3G 16GB FW 3.1 (7C144) Modem FW: 05.11.07 (Not JB or unlocked) I'm one ...
  1. #1
    Advanced Array

    Join Date
    Sep 2009
    Location
    Germany
    Posts
    39
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Question Trying a custom FW 3.1 restore(win xp)

    iPhone 3G 16GB FW 3.1 (7C144) Modem FW: 05.11.07 (Not JB or unlocked)

    I'm one of those guys that accidentally updated and lost by JB. Unlock is unimportant to me..at the moment.

    I am a Windows XP (and Linux) OS only. I downloaded a custom firmware from a iphone fix site.

    File name: iPhone1,2_3.1_7C144_Custom_Restore_NonActivated.ip sw

    I put the phone into DFU mode (Hold Power + Home for 10 seconds.. then release power button and hold home for 10 seconds)..

    Opened iTunes it recognized the phone is in recovery mode and allowed me to shift + click on the restore button and select custom firmware.

    It extracted the software fine, then states that it is preparing the iphone for recovery.. The first time I got error # 1602. I tried all three USB ports on my machine. Sometimes I got error # 1602 sometimes error #1600.

    **********UPDATE**********

    I got a custom 3.1 FW loaded on the iPhone 3G. Here are the steps I used.

    1) Shift + Restore in iTunes and load firmware 3.0 (search for it)

    2) About ten minutes into the process error # 1015 will show up and the iphone will go back to recovery mode (itunes + usb cable). Leave the iphone plugged into the computer and leave it ON. Go ahead and close iTunes.

    3) use iRecovery and type the following commands in console. To open a connection to the iphone remember you need to type "iRecovery -s" in the console. here are the next commands you type:
    setenv auto-boot true
    saveenv
    /exit

    4) Reboot the iphone, you can hold the power button + home button for ten seconds to get this done.

    5) iPhone should boot normally into FW 3.0. Now use redsn0w and jailbreak the iphone.

    6) After the iphone is jailbroken go back into iTunes and shift + restore and load the custom 3.1 FW, should load without problems.

    Good Luck
    Last edited by spitphire; 09-17-2009 at 08:26 PM.



  2. #2
    Rookie Array

    Join Date
    Sep 2009
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Are you sure that you've put the iPhone into DFU Mode?

    You can verify this by looking at the screen of the iPhone. Only if the screen is black the iPhone really is in DFU mode. If it shows the iTunes Symbol its in recovery mode.

  3. #3
    Advanced Array

    Join Date
    Sep 2009
    Location
    Germany
    Posts
    39
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Yes, it is in DFU mode. All Black Screen.

  4. #4
    Rookie Array

    Join Date
    Sep 2009
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Strange...
    Go and try it in recovery mode (this sometimes worked for my 2G iPhone) or try to use an other firmware (I could provide one to you if you want) to see if the problem is caused by your computer or by the firmware file you downloaded

  5. #5
    Advanced Array

    Join Date
    Sep 2009
    Location
    Germany
    Posts
    39
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Well it was worth a shot, still didn't work in recovery mode (itunes + usb cable visible on screen).

    I tried a 2nd computer -- same error.

    If you have a different fw you can send a message/link to spitphire at akapost dot com.


  6. #6
    Advanced Array

    Join Date
    Sep 2009
    Location
    Germany
    Posts
    39
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Another thing to add, if I put the phone into recovery mode and just hit the restore button the phone updates/restores without any errors. Only when I select the custom fw does it produce errors..

  7. #7
    Rookie Array

    Join Date
    Sep 2009
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I sent you a link.

  8. #8
    Advanced Array

    Join Date
    Sep 2009
    Location
    Germany
    Posts
    39
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Thanks for the link, I'll give that one a try soon as the dl finishes.

    **EDIT** Tried the other FW, still didn't work. Same 1600 series errors.. I'm guessing it has something to do with this netbook <sigh>

    Another thing I just tried (which produced the same errors) was that I renamed the custom firmware file to the same exact name as the official apple version and copied it over the top of the firmware located in iPhone Software Updates folder. Then i just hit restore button without clicking shift... but I still ended up with the same error..

    I'll try this other firmware and see if maybe the problem was the custom firmware file.. if it doesn't work.. then i just don't know.. maybe i'll hunt down some more computers... Both computers I've tried have been netbooks..
    Last edited by spitphire; 09-16-2009 at 10:48 PM.

  9. #9
    Rookie Array

    Join Date
    Sep 2009
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Heres some advice of MuscleNerd, posted on twitter:
    a way past Windows 16xx errs is: stock 3.0, then redsn0w, then Shift-Restore to custom ipsw *without* dfu mode

  10. #10
    Advanced Array

    Join Date
    Sep 2009
    Location
    Germany
    Posts
    39
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Not sure if I can downgrade, my phone was not registered with the Cydia database...


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Can't restore to custom IPSW
    By anmh in forum iOS 4.x (iPhone OS 4.x)
    Replies: 2
    Last Post: 03-28-2011, 12:56 AM
  2. error 21, custom restore
    By b03r03 in forum PwnageTool
    Replies: 1
    Last Post: 03-16-2011, 06:05 PM
  3. Does not seem to restore custom firmware again
    By samsam71 in forum PwnageTool
    Replies: 0
    Last Post: 07-23-2008, 07:06 AM
  4. [PWNAGE + Custom 1.1.4] DFU restore custom firmware
    By nathulal in forum PwnageTool
    Replies: 1
    Last Post: 04-15-2008, 03:38 PM
  5. Custom Firmware Restore App for OS X
    By andrewkellymusic@gmail.co in forum iPhone "2G" (Rev. 1)
    Replies: 0
    Last Post: 09-25-2007, 07:47 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 07:01 PM.
twitter, follow us!