Results 1 to 5 of 5
Discuss SMS Missing / 2G updates to 3.0 at the iOS 3.x (iPhone OS 3.x) - Hackint0sh.org; Hi, I'm having trouble with a 2g updates to 3.0. All the messages from 1.1.x ...
  1. #1
    Newbie Array

    Join Date
    Jul 2009
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default SMS Missing / 2G updates to 3.0

    Hi,

    I'm having trouble with a 2g updates to 3.0. All the messages from 1.1.x are there. However, the messages are being received, but not being shown in the SMS app at first. The latest messages in the sms-main view are still the same as before my upgrade. I only see the new messages when I go into a contact, all the messages are there then.

    Messages from people who I did not have before my upgrade are being not shown at all.

    What can I do?

    Thanks!
    Last edited by diseasedworld; 07-05-2009 at 11:00 AM.



  2. #2
    Senior Professional Array unl0cker's Avatar

    Join Date
    Jul 2007
    Location
    In my Mind
    Posts
    128
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    It could be a permission/ownership related problem wrongly set on the sms db file.
    /User/Library/SMS/

    All files should belong to the mobile group and belong to the mobile user.
    And the perms should be 644 (-rw-r--r--)

    Anyway is always best to save ALL you stuff and do a clean install.

    I always do that when major versions are being introduced.
    Last edited by unl0cker; 07-06-2009 at 01:43 AM.
    .

  3. #3
    Newbie Array

    Join Date
    Jul 2009
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by unl0cker View Post
    It could be a permission/ownership related problem wrongly set on the sms db file.
    /User/Library/SMS/

    All files should belong to the mobile group and belong to the mobile user.
    And the perms should be 644 (-rw-r--r--)

    Anyway is always best to save ALL you stuff and do a clean install.

    I always do that when major versions are being introduced.
    Tried that too. Wasn't the permissions.

    However, I found out what the problem is. It looks like Apple f*cked up the sms data migration process. All the triggers from sms.db that are responsible to set the newest message for a contact were missing. I manually restored those triggers in SQlite Explorer and it worked.

  4. #4
    Amazingly Knowledgeable Array rugburn's Avatar

    Join Date
    Aug 2007
    Posts
    965
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    69

    Default

    Very nice ...and good to know thank you
    iPhone 1.0.2 OTB->Virginized->1.1.4 FW->Winpwn FW 2.0.1 Quickpwn 2.0.1 to FW 2.2.1->RedsnOw->3.0 FW itunes3.0.1FW->RedsnOw 8 to unlock->RedSnow 0.9.2 upgrade to 3.1.2->iPhone 2g 3.1.2 and as of July 30th,2010->iPhone 4-32GB & iPhone 4-16Gb->Unlocked

    Can someone give me a thumbs up click on Reputation ...thanks

    --------

  5. #5
    Senior Professional Array unl0cker's Avatar

    Join Date
    Jul 2007
    Location
    In my Mind
    Posts
    128
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    Yeah I nocided that before with the contacts db. When you put a < 3.0 contact db in the phone and reset SpringBoard, or reboot, the system will show the progress bar while works on the new db, probably migrating.

    One of my customers had some of its contacts ghosted. They appear when the missing contact was calling, with correct name etc, but the contact was not in the contact list.

    For sure there is room for improvement in the migration tool the new os is using.


 

 

Similar Threads

  1. Replies: 0
    Last Post: 06-22-2011, 08:00 PM
  2. APN Changer on 3G: I'm missing something
    By JaxBearsFan in forum iPhone 3G
    Replies: 2
    Last Post: 07-01-2009, 08:25 PM
  3. MacNN: Forums: missing OS X features, XP updates
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 06-28-2008, 01:00 AM
  4. Providername missing
    By stonefred in forum iPhone "2G" (Rev. 1)
    Replies: 10
    Last Post: 01-10-2008, 03:54 PM
  5. am I missing something?
    By benpottier in forum iPhone "2G" (Rev. 1)
    Replies: 2
    Last Post: 10-23-2007, 09:21 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 03:40 AM.
twitter, follow us!