Results 1 to 4 of 4
Discuss Please confirm what I need to do to fix iPhone3G at the iOS 3.x (iPhone OS 3.x) - Hackint0sh.org; Hi all, I've spent quite some time researching this issue and think I've worked out ...
  1. #1
    Newbie Array

    Join Date
    Feb 2011
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Lightbulb Please confirm what I need to do to fix iPhone3G

    Hi all,
    I've spent quite some time researching this issue and think I've worked out what I need to do to get my iPhone 3G working and was looking for some confirmation or new advice please!

    I got the phone from work as a project as it was stuck on the apple logo screen when booting. I restored the phone to 2.2.1 in iTunes and couldn't activate the phone because my SIM was reported as not compatiable. After this I accidentally updated to 4.1.2 via iTunes which, I think from what I've read means I've upgraded my baseband to 05.15.04?
    SO, following this, I used Pwnage Tool to create a custom restore file using 2.2.1 again. This worked fine but still didnt unlock my phone to any network so I installed redsn0w via Cydia which changed my carrier status to (null)(null) which I thought meant to was unlocked. When I inserted my SIM, I no longer received the incompatible SIM error in iTunes but couldn't get any signal. I installed BootNeuter which said 'iPhone cannot make or recieve calls, restore with iTunes'.
    Thinking this meant I needed to use the Apple release software, I tried restoring to 2.2.1 but without putting the phone into DFU mode first and the restore failed.
    The phone can now only enter recovery or DFU mode.
    I've tried restoring back to the 2.2.1 custom restore too.

    From what I've read, I think I need to upgrade the baseband to the iPad fw 06.15.00 which means I'll be able to make calls with my SIM. Is this correct? Will this also allow me to upgrade to 4.2.1 and then and unlock everything!?

    Until two weeks ago I had barely used an iPhone so this is all a bit new but I'd consider myself fairly technical so want to understand where I'm going wrong.

    Thanks for any responses!



  2. #2
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    iOS 2.2.1 is only compatible with baseband versions lower than (but not including 4.26.08) - You will never get 2.2.1 working with 05.15.04

    Do you have a SIM card that can activate the phone via iTunes when running iOS 4.2.1? Based on what you have said, it sounds like you don't.

    If that is the case (because you have blown all your other options by updating to 5.15.04), you have two and a half options:

    • contact the original carrier and request an unlock. This might be difficult if you don't know who originally took out the contract on the phone.
    • or identify if you have baseband bootloader 5.8 - this allows downgrade of baseband
    • or upgrade baseband to 06.15.00 and use ultrasn0w. This can cause GPS problems on 4.2.1 and issues restoring on all iOS versions see: http://www.hackint0sh.org/f204/196391.htm
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  3. Thanks kls78 thanked for this post.
  4. #3
    Newbie Array

    Join Date
    Feb 2011
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Cheers for this repsonse, Ill look later into what bootloader version I'm running to determine what to do next.

  5. #4
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    TinyUmbrella The Firmware Umbrella - TinyUmbrella can tell you the bootloader version.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

 

 

Similar Threads

  1. iPhone3G features on 1st gen?
    By cabex in forum iOS 3.x (iPhone OS 3.x)
    Replies: 1
    Last Post: 06-26-2009, 11:51 AM
  2. [iPhone3G] O2 payg
    By ako0o_ba in forum iPhone 3G
    Replies: 3
    Last Post: 01-05-2009, 10:16 PM
  3. iphone3g sim problem
    By Lilmaine426 in forum Turbo-, Supersim and Simcloning Solution
    Replies: 7
    Last Post: 12-10-2008, 03:12 AM
  4. [Speculation][iphone3g] Oh My!
    By kkankeshwar in forum iPhone 3G
    Replies: 5
    Last Post: 07-06-2008, 10:06 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 09:27 AM.
twitter, follow us!