Page 1 of 2 12 LastLast
Results 1 to 10 of 16
Discuss MMS on the 3.0 GM at the iOS 3.x (iPhone OS 3.x) - Hackint0sh.org; So according to the numerous threads and guides around the intarwebz, I have everything perfectly ...
  1. #1
    Rookie Array

    Join Date
    Apr 2009
    Posts
    16
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default MMS on the 3.0 GM

    So according to the numerous threads and guides around the intarwebz, I have everything perfectly set up on my end.

    I called AT&T and tricked them into switching a Blackberry on my account to my number, switching it with my iPhone. Except I'm still using the iPhone, obviously.

    So I thought I would get the Blackberry's MMS features now. But it's not working.

    Any ideas?

    Specifics:
    - Loaded a custom ATT_US.ipcc with entries for MMS included in the .plist
    - The camera button within the Messaging application showed up and worked for about 2 minutes. Sending or receiving MMS, however, was not successful.
    - Camera button then disappeared after a reboot and has not returned since.
    - Carrier is listed as 5.0



  2. #2
    Senior Professional Array

    Join Date
    Apr 2007
    Posts
    191
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    17

    Default

    While you have now told AT&T to convert your plan so that you have a Blackberry instead of an iPhone, the network will still identify you based on your IMEI, which will still be an iPhone and negotiate which services AT&T believes that you *should* have based on your device profile.

    AT&T added an opt-out code for MMS messages onto all iPhone accounts, which in turn is causing issues as AT&T can't figure out how to remove these opt-out codes without impacting other customers who explicitly opted out of MMS.

    While this could be easily accomplished in SQL with a left join, it's probably something that AT&T needs to do a full audit and investigation on before they "flip the switch", or more realistically press the enter key.

    So, one simple "f*** those jailbreakers!" moments for AT&T has now cost them a couple months of functionality for iPhone OS 3.0 users, and of course all the new iPhone 3Gs users that will be lining up come this Friday.

    ~Adrian

  3. #3
    Rookie Array

    Join Date
    Apr 2009
    Posts
    16
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Uncool, and thanks for the info =)

  4. #4
    Rookie Array

    Join Date
    Apr 2009
    Posts
    16
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Actually, I just had an afterthought.

    Since I have the ability to compose an MMS message on my iPhone, and I have the ability to enter MMS info (pictured below), can I enter some sort of proper settings here and all is well?



  5. #5
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    236
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    18

    Default

    I believe it is technically impossible to enable MMS on 3.0 until a jailbreak is released. Apple removed the mms settings from the carrier bundle around the third beta release. I have checked. I compared the beta 2 bundle with beta 5 (I cannot use the GM since I dont have the vfdecrypt key), and Apple remove the settings. Without the settings in the bundle the iPhone will not "unlock" the mms features. You used to be able to upload a modified carrier bundle to iTunes but Apple stopped that in 8.2 betas. So MMS is impossible (I believe Apple will release a updated carrier bundle when AT&T hurrys their ... up, lol. Like the did when MicroCell support was added.), unless Apple re-added the settings in the GM but I was unable to use MMS when I tried. I even tried using another AT&T sim (that doesnt have a iPhone account on it), with no luck


  6. #6
    Rookie Array

    Join Date
    Apr 2009
    Posts
    16
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    So I just had a very interesting conversation with an AT&T Technical Support Rep.

    I told him I was an Apple iPhone Developer and I needed him to remove the opt-out code from my account so I could use MMS. He went along with it and proceeded to check the account for any blocks.

    According to him, there were none. However, there was an "on/off" for MMS and he switched it on.

    So my current MMS settings in Cellular Data Network on the iPhone are like this:



    And this is what my text message window looks like:



    I thought maybe it could take a couple of hours for the change to take effect. We'll see.

    Any ideas in the meantime?

  7. #7
    Rookie Array

    Join Date
    Apr 2009
    Posts
    16
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quick update for anyone following this or having the same problem:

    I waited around to see if time would fix the MMS issue as it stands with me now. No luck.

    Fortunately, I decided to try swapping the SIM from my iPhone with the SIM from another phone on my account that has MMS (Blackberry Bold). I tried sending and receiving. I successfully sent a message from my iPhone to a friend.

    The only problem at this point was that I now had the Blackberry's phone number. FAIL!

    I switched the SIMs back to their original phones. Accepting defeat. Then, for sh*ts and giggles, I decided to try to send again from my iPhone. SUCCESS!

    I now have fully functional MMS, iPhone 3G, firmware 3.0 GM, custom ATT_US.ipcc. Huzzah!

  8. #8
    iPhone Moderator Array

    Join Date
    Aug 2007
    Posts
    3,620
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    220

    Default

    Quote Originally Posted by mfleigle View Post
    I believe it is technically impossible to enable MMS on 3.0 until a jailbreak is released. Apple removed the mms settings from the carrier bundle around the third beta release. I have checked. I compared the beta 2 bundle with beta 5 (I cannot use the GM since I dont have the vfdecrypt key), and Apple remove the settings. Without the settings in the bundle the iPhone will not "unlock" the mms features. You used to be able to upload a modified carrier bundle to iTunes but Apple stopped that in 8.2 betas. So MMS is impossible (I believe Apple will release a updated carrier bundle when AT&T hurrys their ... up, lol. Like the did when MicroCell support was added.), unless Apple re-added the settings in the GM but I was unable to use MMS when I tried. I even tried using another AT&T sim (that doesnt have a iPhone account on it), with no luck
    At least on a Mac you can re-enable injecting ipcc files even if the iPhone is not jailbroken, works on the GM. Fire up Terminal (Applications > Utilities) and type (one line)

    defaults write com.apple.iTunes carrier-testing -bool TRUE

    Works perfect on a Mac.
    I have tried it on my Vista box, no luck so far...
    Read the stickies and search the forum before posting!
    If you want to become a Hackint0sh supporter click here
    ----------
    iPhone 4 factory unlocked, iOS 4.3.1, jailbroken
    iPad Wi-Fi + 3G (1G), iOS 4.3.1, jailbroken
    iPad 2

  9. #9
    ac!
    ac! is offline
    Senior Professional Array

    Join Date
    Mar 2009
    Posts
    121
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    16

    Default

    carrier requirement: mac
    boosts sales a lil :-)

  10. #10
    iPhone Moderator Array

    Join Date
    Aug 2007
    Posts
    3,620
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    220

    Default

    Quote Originally Posted by ac! View Post
    carrier requirement: mac
    boosts sales a lil :-)
    that would be a nice one ;-)

    On Windows Apple installs the tool to add the setting, but the plist file to inject it seems to be missing. I've only spent half an hour looking for it, but...

    C:\Program Files\Common Files\Apple\Mobile Device Support\bin\defaults.exe write name_of_the_plist_without_suffix carrier-testing -bool TRUE

    If you use com.apple.iTunes for ame_of_the_plist_without_suffix it will create a new plist with the carrier-test setting but has no effect, at least on my Vista box. Maybe I just dont get the win logic, I am too much Mac focussed ;-)
    Read the stickies and search the forum before posting!
    If you want to become a Hackint0sh supporter click here
    ----------
    iPhone 4 factory unlocked, iOS 4.3.1, jailbroken
    iPad Wi-Fi + 3G (1G), iOS 4.3.1, jailbroken
    iPad 2


 

 
Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 10:50 PM.
twitter, follow us!