Results 1 to 6 of 6
Discuss iphone 2g at the iOS 3.x (iPhone OS 3.x) - Hackint0sh.org; I have iphone 2g with firmware 3.1.2 which is jailbroken and unlocked,but i could not ...
  1. #1
    Rookie Array

    Join Date
    Feb 2011
    Posts
    11
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default iphone 2g

    I have iphone 2g with firmware 3.1.2 which is jailbroken and unlocked,but i could not install applications which needs firmware version 4.X plus,so is there any idea to install those applications?



  2. #2
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by dman31 View Post
    I have iphone 2g with firmware 3.1.2 which is jailbroken and unlocked,but i could not install applications which needs firmware version 4.X plus,so is there any idea to install those applications?
    Generally, no this is not possible and it is very unlikely with a major iOS revision like iOS 4.0
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  3. #3
    Rookie Array

    Join Date
    Feb 2011
    Posts
    11
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    thanks olethros,

    I found on internet that there is one of the firmware 4.X for iphone 2g is developed?but as per my knowledge that only has compatible features of iphone firmware 4.X on iphone2g,right?. so,Is there any custom firmware upgrade for iphone 2g which can run those applications needed iphone 4.X plus?

  4. #4
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by dman31 View Post
    thanks olethros,

    I found on internet that there is one of the firmware 4.X for iphone 2g is developed?but as per my knowledge that only has compatible features of iphone firmware 4.X on iphone2g,right?. so,Is there any custom firmware upgrade for iphone 2g which can run those applications needed iphone 4.X plus?
    If I understand your question properly. The answer is no.

    The current 2G "4.0s custom IPSWs" add third party implementations of some of the 4.0 features to iOS 3.1.3

    Applications compiled against the Apple iOS SDK for 4.0 (or higher) can reference APIs and libraries that simply aren't in iOS 3.1.3 (and can't realistically be added/backported by hackers)

    Some lazy app developers might simply compile against the iOS SDK for 4.0 even though they don't actually use any new 4.0 APIs, this type of app could maybe be hacked to work - but the chance of this happening is very slim. This was much more common with apps that were compiled to against 3.1.3 or 3.1.x even though they actually worked on iOS 3.0 (with appropriate hacking).
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  5. Thanks dman31 thanked for this post.
  6. #5
    Rookie Array

    Join Date
    Feb 2011
    Posts
    11
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    many many thanks olethros,

    so I should to remain satisfy with what I have currently in my iphone and forget about running 4.0 compatible applications,is that right?


  7. #6
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by dman31 View Post
    many many thanks olethros,

    so I should to remain satisfy with what I have currently in my iphone and forget about running 4.0 compatible applications,is that right?
    Yes, your only way to run 4.0 apps is by purchasing newer hardware (iPhone 3G or more recent)
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 02:15 AM.
twitter, follow us!