Results 1 to 4 of 4
Discuss Hope someone can help at the iOS 3.x (iPhone OS 3.x) - Hackint0sh.org; OK so im hping someone can help me here... I bought a used 3g a ...
  1. #1
    Newbie Array

    Join Date
    Oct 2009
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Hope someone can help

    OK so im hping someone can help me here...

    I bought a used 3g a few weeks back, it wasnt jailbroken/unlocked, and was running v2.1, i reset the phone the day i got it and it said that it was activating and would take a while.. but i was leaving for my holiday that night so it never got activated on o2, when i arrived in malaysia for my holiday i switched the phone on and it picked up the local network and allowed me to roam with it..

    While i was there i got it jailbroken and unlocked and updated to v3.0..

    Now im back in the UK and the phone still wont seem to work on o2.. ive just got a load of ..... in the left corner...

    Any ideas where i go from here ?? Do i need to restore it, to get it to activate ??

    Im a bit lost...



  2. #2
    Senior Professional Array

    Join Date
    Jan 2009
    Location
    seattle, washington
    Posts
    135
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    Quote Originally Posted by blackhatter View Post
    OK so im hping someone can help me here...

    I bought a used 3g a few weeks back, it wasnt jailbroken/unlocked, and was running v2.1, i reset the phone the day i got it and it said that it was activating and would take a while.. but i was leaving for my holiday that night so it never got activated on o2, when i arrived in malaysia for my holiday i switched the phone on and it picked up the local network and allowed me to roam with it..

    While i was there i got it jailbroken and unlocked and updated to v3.0..

    Now im back in the UK and the phone still wont seem to work on o2.. ive just got a load of ..... in the left corner...

    Any ideas where i go from here ?? Do i need to restore it, to get it to activate ??

    Im a bit lost...
    you bought the phone in UK, then took it to malaysia, got it jailbroken and unlocked there and you were able to use it in malaysia? if so, your phone was unlocked because you were using a sim in malaysia.

    now you are back in uk and it does not work with o2? that is a bit strange indeed because you can use any sim card with an unlocked phone.

    does it say invalid sim card with your o2 sim? you weren't very clear about what you see in the left corner.

  3. #3
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    There is plenty you can try before you start talking about restoring your phone.

    You need to be very careful when you restore your iPhone. Do not ever restore to an official apple 3.1 or higher firmware. This may break you ability to unlock in the future.

    If you are running 3.0 unlocked, then you are running ultrasn0w

    However, if the phone was originally locked to o2 you shouldn't need to have ultrasn0w running when you are in the uk using o2 as your carrier. You just need hacktivation which was done during the jailbreak in Malaysia I guess.

    This is all speculation at this point. Firstly try toggling airplane mode off an on.

    Can you see if you have ultrasn0w installed in Cydia. If so, try installing the ultrasn0w sbsettings toggle (you may need to also install sbsettings first)

    Then you can swipe the status bar and get a dashboard that allows you to turn ultrasn0w on and off with a tap, you might find that you can get service back by either turning ultrasn0w off or by simply toggling it off and then back on again.

  4. #4
    Newbie Array

    Join Date
    Oct 2009
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    yes its running ultrasnow, ive now added the ultrasn0w sbsettings and tried turning on/off via that, airplane mode and 3g and still nothing.. Still getting the awaiting activation popup...

    Just to explain more about the malaysia stuff.. while i was there i was still using the o2 sim in the phone but roaming so it was using the malay provider (also the same in indonesia).. this was even before i got it unlocked/jailbroken..

    I ended up phoning up o2 earlier to see if they could help with this activation stuff.. Explained what was happening to the guy (didnt mention the unlocking/jailbreak) about the phone not activating here but working when roaming.. he said weird, put me on hot while he contacted apple to ask them, came back and said that the phone was a USA model and was locked to at&t, and suggested getting it unlocked.. then when it was mentioned that it was a 3G phone, he sounded a bit puzzled, put me on hold again, and another guy came on the phone (pressumed he was apple), he asked my my email address and he wanted me to update via itunes etc. So i crapped out and hung up...

    Now im starting to wondered if the phone is reported stolen or something in the USA? Even so it should work over here ?

    Really confused now, been messing with nearly allday..

    Reading up, it seems loads of people are having no service hassle etc with these 16gb 3G's..

    Any other ideas?




    Quote Originally Posted by Olethros View Post
    There is plenty you can try before you start talking about restoring your phone.

    You need to be very careful when you restore your iPhone. Do not ever restore to an official apple 3.1 or higher firmware. This may break you ability to unlock in the future.

    If you are running 3.0 unlocked, then you are running ultrasn0w

    However, if the phone was originally locked to o2 you shouldn't need to have ultrasn0w running when you are in the uk using o2 as your carrier. You just need hacktivation which was done during the jailbreak in Malaysia I guess.

    This is all speculation at this point. Firstly try toggling airplane mode off an on.

    Can you see if you have ultrasn0w installed in Cydia. If so, try installing the ultrasn0w sbsettings toggle (you may need to also install sbsettings first)

    Then you can swipe the status bar and get a dashboard that allows you to turn ultrasn0w on and off with a tap, you might find that you can get service back by either turning ultrasn0w off or by simply toggling it off and then back on again.

 

 

Similar Threads

  1. is there any hope?
    By tdisurfer in forum iOS 3.x (iPhone OS 3.x)
    Replies: 1
    Last Post: 10-25-2009, 11:37 AM
  2. Is there any hope?
    By tdisurfer in forum iOS 3.x (iPhone OS 3.x)
    Replies: 0
    Last Post: 10-24-2009, 07:28 PM
  3. New hope for 1.1.2 OTB?
    By Nickolaicho in forum iPhone "2G" (Rev. 1)
    Replies: 80
    Last Post: 12-27-2007, 06:39 AM
  4. My last hope!!! Please help!!!
    By JCMA90 in forum General
    Replies: 11
    Last Post: 11-13-2007, 04:52 AM
  5. Any hope for FW1.0.2?
    By wildpig in forum iPhone "2G" (Rev. 1)
    Replies: 14
    Last Post: 10-19-2007, 05:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 03:15 AM.
twitter, follow us!