Results 1 to 8 of 8
Discuss Downgrade 3G from 3.1.3 to 3.1.2? at the iOS 3.x (iPhone OS 3.x) - Hackint0sh.org; OK, so in a blink of an eye and one brain fart I pressed the ...
  1. #1
    Newbie Array

    Join Date
    Feb 2010
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Downgrade 3G from 3.1.3 to 3.1.2?

    OK, so in a blink of an eye and one brain fart I pressed the upgrade my software button when I knew better. So my unlocked/jailbroken iphone 3G is now running 3.1.3 and I need to get it back to 3.1.2 or earlier.

    I've tried DFU mode to restore but keep getting an error at the end of the restore. Any ideas? I've tried using iTunes 9.x and 8.2.x without any luck. I also tried 3.1.0 firmware.



  2. #2
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default Re: Downgrade from 3.1.3 to 3.1.2?

    You can't downgrade baseband so if you rely on software unlock you are out of luck.

    The rest you can downgrade with dfu mode but you will likely get an error due to inability to downgrade baseband. That error can be ignored. However you will probably need to use irecovery to force the iPhone out of recovery mode.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  3. #3
    Rookie Array

    Join Date
    Jan 2010
    Posts
    13
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    It doesn't matter. Your phone has been updated to 05.12.01 baseband which means you can't unlock it.
    However, you can jailbreak it with redsn0w though.

  4. #4
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by phooka View Post
    It doesn't matter. Your phone has been updated to 05.12.01 baseband which means you can't unlock it.
    However, you can jailbreak it with redsn0w though.
    They have a maybe 1% chance of being able to downgrade if they have baseband bootloader version 5.8 they can use fuzzyband.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  5. #5
    Rookie Array

    Join Date
    Jan 2010
    Posts
    13
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    That is true, but how would someone have upgraded to 3.1.3 without getting their baseband updated too?

    Quote Originally Posted by Olethros View Post
    They have a maybe 1% chance of being able to downgrade if they have baseband bootloader version 5.8 they can use fuzzyband.


  6. #6
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default Re: Downgrade from 3.1.3 to 3.1.2?

    Quote Originally Posted by phooka
    That is true, but how would someone have upgraded to 3.1.3 without getting their baseband updated too?
    Think you are confusing baseband and baseband bootloader.

    Of course they got upgraded to 3.1.3 baseband and on 3G that is generally a one way process (upgrade only). Except if you have baseband bootloader 5.8 and then you can also downgrade.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  7. #7
    Rookie Array

    Join Date
    Sep 2009
    Posts
    23
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    sorry to interrupt but does this mean that iphone with baseband 5.11.07 and bootloader 5.09 cant get an unlock on 3.1.3 FW and are doomed???
    Can there be a bootloader downgrade from 5.09 to 5.08 in near future or will there be a new unlock "blackra1n" for 3.1.3 FW?

  8. #8
    Newbie Array

    Join Date
    Dec 2007
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Download a 'custom' ispw where the baseband bootloader is excluded.

    This way, you can use redsnow or quickpwn to upgrade to FW3.1.3 without upgrading the bootloader.

    Google for the custom file.

 

 

Similar Threads

  1. Replies: 0
    Last Post: 07-18-2008, 06:35 AM
  2. Replies: 2
    Last Post: 02-02-2008, 12:47 PM
  3. Replies: 27
    Last Post: 11-20-2007, 10:41 AM
  4. Replies: 4
    Last Post: 11-11-2007, 09:34 AM
  5. Downgrade fails again :-( - Downgrade fuktioniert nicht
    By Sticki in forum iPhone "2G" (Rev. 1)
    Replies: 7
    Last Post: 10-27-2007, 07:58 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 04:10 AM.
twitter, follow us!