Results 1 to 7 of 7
Discuss Bootneuter - Stuck on "Determining current settings" at the iOS 3.x (iPhone OS 3.x) - Hackint0sh.org; Hi All, I'm having a problem trying to unlock my iPhone 2G with 3.1.3 FW. ...
  1. #1
    Newbie Array

    Join Date
    Aug 2010
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Bootneuter - Stuck on "Determining current settings"

    Hi All,

    I'm having a problem trying to unlock my iPhone 2G with 3.1.3 FW. Basically, whenever I open up Bootneuter, I get stuck at the "Determining current settings" screen. This happens no matter tool I use to jailbreak (I've tried all the tools compatible with 3.1.2 and 3.1.3) - so it's either a problem with Bootneuter, my iPhone, or a combination of both.

    This issue has been brought up here a couple of times before, i.e.:

    http://www.hackint0sh.org/f207/84345.htm

    But to my knowledge, no one has found a solution. Just a bunch of "shot in the dark" type suggestions to downgrade to version x.xx, jailbreak, upgrade to version y.yy, etc - which ultimately don't really seem to do anything.

    I'd like to try to get to the bottom of this issue in this thread. To start with, some questions:

    1. Has *anyone* successfully unlocked (for the first time) an iPhone 2G with 3.1.3 FW? I.e. is it just a compatibility issue with 3.1.3 FW and bootneuter that needs to be addressed (after all, I have not seen any new updates to bootneuter in quite some time)?

    2. What exactly is bootneuter doing at the "Determining current settings screen" that could cause it to hang indefinitely?

    3. Who wrote bootneuter? Is it possible for me to get in contact with the dev(s) directly?

    4. Is bootneuter open source? Is it possible for me to take a look through the source code?

    5. Any other thoughts, anyone?



    Thanks,
    l0lcat



  2. #2
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by l0lcat View Post
    Hi All,

    I'm having a problem trying to unlock my iPhone 2G with 3.1.3 FW. Basically, whenever I open up Bootneuter, I get stuck at the "Determining current settings" screen. This happens no matter tool I use to jailbreak (I've tried all the tools compatible with 3.1.2 and 3.1.3) - so it's either a problem with Bootneuter, my iPhone, or a combination of both.

    This issue has been brought up here a couple of times before, i.e.:

    http://www.hackint0sh.org/f207/84345.htm

    But to my knowledge, no one has found a solution. Just a bunch of "shot in the dark" type suggestions to downgrade to version x.xx, jailbreak, upgrade to version y.yy, etc - which ultimately don't really seem to do anything.

    I'd like to try to get to the bottom of this issue in this thread. To start with, some questions:

    1. Has *anyone* successfully unlocked (for the first time) an iPhone 2G with 3.1.3 FW? I.e. is it just a compatibility issue with 3.1.3 FW and bootneuter that needs to be addressed (after all, I have not seen any new updates to bootneuter in quite some time)?

    2. What exactly is bootneuter doing at the "Determining current settings screen" that could cause it to hang indefinitely?

    3. Who wrote bootneuter? Is it possible for me to get in contact with the dev(s) directly?

    4. Is bootneuter open source? Is it possible for me to take a look through the source code?

    5. Any other thoughts, anyone?
    Have you used redsn0w or pwnagetool to run bootneuter automatically?
    The hang at determining current settings can be because CommCenter is getting in the way. Or it could be because your baseband bootloader or baseband are empty/corrupt.
    What does your iPhone report in Settings - General - About?

    Musclenerd was the main person behind bootneuter. The 2G iPhone is 3 years old now - unlock stable and permanent with bootneuter - not much need to update something if it works.

    I seem to recall I tested redsn0w/bootneuter against 3.1.2 on my iPhone when beta testing for redsn0w 0.9.2 - don't think 3.1.3 was out then. So try 3.1.2

    If you suspect that 3.1.3 is causing the problem - downgrade to an older iOS version. Most of the manual baseband tools work best on iOS 1.1.x for the 2G
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  3. #3
    Newbie Array

    Join Date
    Aug 2010
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by Olethros View Post
    Have you used redsn0w or pwnagetool to run bootneuter automatically?
    Yup. When I use those apps it also freezes on determining current settings - and since I need to power off in the middle of jailbreaking it also ends up requiring a restore from iTunes.

    Quote Originally Posted by Olethros View Post
    The hang at determining current settings can be because CommCenter is getting in the way. Or it could be because your baseband bootloader or baseband are empty/corrupt.
    What does your iPhone report in Settings - General - About?
    Version 3.1.2 (I guess I had wound up reverting to 3.1.2 at some point)
    Modem Firmware 04.05.04_G

    I was given this phone by a friend and I believe they had previously mucked around with jailbreak/unlock tools - so it's possible they corrupted something important. By the time I got the phone it had been restored to normal 3.1.3 FW and was running on AT&T.

    Any tips as to how I might figure out whether CommCenter is getting in the way or the baseband/baseband bootloader is corrupted?


    Quote Originally Posted by Olethros View Post
    Musclenerd was the main person behind bootneuter. The 2G iPhone is 3 years old now - unlock stable and permanent with bootneuter - not much need to update something if it works.
    Good to know, thanks.

    Quote Originally Posted by Olethros View Post
    I seem to recall I tested redsn0w/bootneuter against 3.1.2 on my iPhone when beta testing for redsn0w 0.9.2 - don't think 3.1.3 was out then. So try 3.1.2

    If you suspect that 3.1.3 is causing the problem - downgrade to an older iOS version. Most of the manual baseband tools work best on iOS 1.1.x for the 2G
    I've been trying to avoid downgrading to 1.1.x - mainly because it is such a hassle and I have no idea whether it would actually fix anything. I suppose I've got to give it a try though just to rule it out.


    Thanks very much for all of the work you put into these forums.
    -lc

  4. #4
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    If bootneuter freezes during redsn0w/pwnagetool then you can rule out CommCenter as culprit.

    Is the iPhone actually unlocked now? Can you use any SIM card with it? (even though the bootneuter fails)

    Do you have valid wifi and bluetooth mac addresses?

    You may need to try and reflash your baseband and baseband bootloader. Be careful - you can screw things up more.

    I recommend iLiberty Plus on iOS 1.1.4 for all such operations.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  5. #5
    Newbie Array

    Join Date
    Aug 2010
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Bluetooth and Wifi MAC addresses are valid - and I can confirm that wifi works on my home network.

    Interesting thought about it already being unlocked and me just not knowing about it. I've got T-Mobile and AT&T prepaid sims that I'd like to use. When I drop in the T-Mobile SIM, the phone seems to recognize from the SIM that I have a voicemail. But the "Carrier" field in the "About" section shows as "Not Available" on both SIMs - and no calls of course.

    Is that enough info to make a decision as to whether or not the phone might already be unlocked?


  6. #6
    Newbie Array

    Join Date
    Aug 2010
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Also - this is kind of weird...

    Just now after playing around with bootneuter and the AT&T SIM, I went back to the About section and there was a new section labeled "ttou" listed directly under the Modem Firmware field.

    When I expanded that that section, it popped up a couple of new fields that said "Bad system call" and "Invalid serial".

    I have no idea what that's all about. When I restarted, the "ttou" section was gone.

  7. #7
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Stange - but your're not the first to see this - no i don't know what it means

    Strange tab under "About" section "ttou"? - Mac Forums
    iPhone: WTF is “ttou”? – Stephen Foskett, Pack Rat

    Both users reported that a restart fixed it.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

 

 

Similar Threads

  1. BootNeuter stuck at "determining current settings"
    By BigChippah in forum iOS 3.x (iPhone OS 3.x)
    Replies: 13
    Last Post: 01-06-2011, 12:36 PM
  2. Replies: 109
    Last Post: 01-04-2010, 06:23 PM
  3. Bootneuter freezes at determining settings
    By boi2gangster in forum Quickpwn
    Replies: 0
    Last Post: 06-12-2009, 10:27 AM
  4. Replies: 8
    Last Post: 10-20-2008, 02:48 PM
  5. Replies: 6
    Last Post: 04-03-2008, 12:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 05:57 AM.
twitter, follow us!