Results 1 to 6 of 6
Discuss 2G unlocked iphone upgraded to os3.1 now can't activate at the iOS 3.x (iPhone OS 3.x) - Hackint0sh.org; Can anyone help. I have a 2G unlocked iphone upgraded to os3.1 with a restore ...
  1. #1
    Newbie Array

    Join Date
    Sep 2007
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default 2G unlocked iphone upgraded to os3.1 now can't activate

    Can anyone help. I have a 2G unlocked iphone upgraded to os3.1 with a restore in itunes 8.2 and now can't activate as it requires a pin number to get into. It still seems to be unlocked as it still rings when called with an orange UK sim in it. I also tried restoring to an ipsw built in pwnage 0.3 but itunes keeps coming up with error messages. Help would be much appreciated.

    cheers



  2. #2
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Put the phone into DFU mode and restore back to 3.0 or 3.0.1

    You will get an error at the end of restore, this can be ignored.

    Run redsn0w to jailbreak and hacktivate again.

    You are lucky you did this on a 2G phone, the way back is not so easy on later phones.

  3. #3
    Newbie Array

    Join Date
    Sep 2007
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Thanks, i've been trying various methods of what you suggest but the only firmware that seems to work in itunes is 3.1 and redsnow just hangs up at the reboot stage. Is this to do with use of itunes 8.2 or maybe that i'm running OSX10.6 on a new macbook pro?

  4. #4
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    10.6 is of course not fully supported or tested by the dev team yet because it has not been released and the dev team never provide solutions for beta or pre-release software. This is also true for iPhone OS 3.1 which is still in beta.

    There exists a jailbreak for 3.1 betas but it is not from the dev-team and is not guaranteed to have all the required patches to make a complete jailbreak.

    Are you sure you are actually running 3.1 and not 3.0.1?

    The procedure you need is documented here:
    You may need to downgrade to Leopard to make it work, you did keep a bootable backup before upgrading to a pre-release OS I hope?
    Downgrade iPhone 3GS 3.1 to 3.0 (iPhone OS 3.1 to 3.0 Firmware)

  5. #5
    Newbie Array

    Join Date
    Sep 2007
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    oops. think you are correct there and i'm on 3.01. will try booting from a leopard disc and running this tonight.

    thanks very much for the help.


  6. #6
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Now it has been clarified you are running 3.0.1 you can definitely still try again with 10.6 it might work and definitely won't make things worse.

    Do the following:

    1. Put phone in DFU mode
    2. Restore to official apple 3.0.1 ipsw with iTunes (8.2 or 8.2.1 will be fine)
    3. Run redsn0w to jailbreak but when it asks for an ipsw, point it at the 3.0 ipsw for your phone. This will still leave you with 3.0.1 on your phone.

    Your phone will be running the latest iPhone OS and be jailbroken and hacktivated.

 

 

Similar Threads

  1. Upgraded 3.0 with tmobile sim inserted, wont activate
    By raycorado in forum iOS 3.x (iPhone OS 3.x)
    Replies: 2
    Last Post: 07-07-2009, 02:56 PM
  2. Replies: 6
    Last Post: 01-01-2009, 10:57 AM
  3. Replies: 10
    Last Post: 09-13-2008, 11:26 PM
  4. Replies: 2
    Last Post: 01-29-2008, 07:31 AM
  5. Replies: 1
    Last Post: 01-03-2008, 11:55 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 02:31 PM.
twitter, follow us!