Page 4 of 9 FirstFirst 123456789 LastLast
Results 31 to 40 of 81
Discuss Studio 1557 + snow leopard at the Installation - Hackint0sh.org; Oh lol, I just realized if I extract a new dsdt with a different method, ...
  1. #31
    Advanced Array

    Join Date
    Nov 2009
    Posts
    42
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Oh lol, I just realized if I extract a new dsdt with a different method, and it makes the audio not work, I could just compare the two sections under the device "HDEF" and add in the ssdt tables and everything but quartz extreme should be working. If turbo boost works, that should compensate a little for the performance decrease you get with using quartz gl and placing the burden of graphics on your cpu/ram.


  2. #32
    Rookie Array

    Join Date
    Feb 2010
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    quartz extreme is the only thing i need to get working now, which i think would come once the gpu gets figured out to work with hackintoshes. is it possible that theres a driver for a video card out there that is very similar to the 4570? also it seems in my system informtion it's says...
    Display:

    Type: Display
    Bus: PCIe
    PCIe Lane Width: x16
    VRAM (Total): 256 MB
    Vendor: ATI (0x1002)
    Device ID: 0x9553
    Revision ID: 0x0000
    Kernel Extension Info: No Kext Loaded
    Displays:
    Display:
    Resolution: 1024 x 768
    Depth: 32-Bit Color
    Core Image: Software
    Main Display: Yes
    Mirror: Off
    Online: Yes
    Quartz Extreme: Not Supported
    QuartzGL: Supported

  3. #33
    Advanced Array

    Join Date
    Nov 2009
    Posts
    42
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    You could look into what has the same gpu. The people I saw working on it said they were going to give up and wait until the 10.6.3 update. I don't think its going to magically work when that update comes out though. Its going to take work. It might be easier when that update comes out, but I'm not holding my breath. I'm going to keep seeing what I can try to tweak. I might have to get my hands dirty and modify my dsdt to get it working.

  4. #34
    Rookie Array

    Join Date
    Feb 2010
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    if you get qe up and running, please post a guide as to how you did it. i'm not too knowledged in dsdt tweaking and all never really had to do it before. but i really wish ati wasn't such a pain in the ass for this crap

  5. #35
    Advanced Array

    Join Date
    Nov 2009
    Posts
    42
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Honestly, I only have a vauge idea how to modify a dsdt. I'm just going to hack and / until it works. I might also look at the plists for the kexts that are for the graphics cards in the imac and compare them to the 4500controller.kext and see whats different. That might give some insight into why the kext isn't working properly even with the screen detected.


  6. #36
    Advanced Array

    Join Date
    Nov 2009
    Posts
    42
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    What I was thinking was because people were having issues with 512mb cards and the 256mb versions were working is I could use the dsdt to trick it into only using 256mb of the vram. Thats what system profiler picks it up under graphics with either radeonhd.kext or vesa mode. I did try making atisupport.kext load by itself to see what it show up in system profiler like. It doesn't seem to make QE work but it does detect the proper amount of vram. It oddly enough gets listed in pci instead of graphics with the normal vesa information under graphics.

  7. #37
    Rookie Array

    Join Date
    Feb 2010
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    i don't know if you've come across this before, i happened to stumble across it yesterday but don't know what much of it means. maybe it could help you fix the problem and you could dumb it down for me a bit so that i could fix my problem as well =D

    Information Database About Ati - Project OS X Forums

    theres the link

  8. #38
    Newbie Array

    Join Date
    Mar 2010
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    hey guys,
    I own a Studio 15 with the ATI Mobility Radeon 4570 and I have been looking everywhere and finding bits and pieces of info regarding its compatibility. I understand the whole Quartzextereme etc not working but I know people are able to get native resolution but I have been confused out of my head as to what kext to download beacause there have been so many kexts assiociated with getting native res working. So I would be ever so grateful if someone could find time to help me out, directing me what to download etc .

    Also, I've been away from the scene for ages so I haven't kept up with what's the hottest/most successful distro. [the last distro i used with me old desktop was like one of uphucks first first distros lol] Bare in mind its the dell studio 15 with the ati 4570 graphics card.

    Thanks in advance!!

  9. #39
    Rookie Array

    Join Date
    Feb 2010
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    i haven't tried getting native res cuz all i need is qe to work so i can run final cut pro. but i used ideneb 1.6 lite and it worked, just had to the cd using the flags "busratio=20 cpus=4 -v" without the quotes. i forget exactly which options i checked off for the customization part but i'm pretty sure i chose the ati one which did nothing so i dont think its necessary, as well as the kernel that starts with a q, the ahci fix or whatever, and a few others. it worked well for me considering i needed at least 10.5.6 and its 10.5.8. i haven't tried updating from it to sl i was debating but i'd rather not lose everything that i already tried getting if i don't absolutely need it. if you dont care what version you have though kalyway 10.5.2 works perfectly. also if you use ideneb 1.6 once you install it all you have to load into safe mode (-x) and get rid of the ati kexts i believe it is atix2000.kext. once you get rid of that you can boot into normal mode but you still need to use the flags "busratio=20 cpus=4" i still need to figure out a way to make it do that automatically but yeah, that's about all i've gotten on my laptop so far. really wish i had qe working though for our stupid gpu =(

  10. #40
    Advanced Array

    Join Date
    Nov 2009
    Posts
    42
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I think I recently saw that and it looks like the atidnrv kext isn't in snow leopard. I've been trying to load the x2000 kext with the ati4500controller kext as a framebuffer/accelerator combo. I might be selling my laptop soon here so I can build a desktop, but I'll try and work on it some more. I think the easiest thing for me to start with would be speedstep. It looks like in 10.6.3 they will have a kext for the specific desktop version of this card. We might see some progress with this next update. I honestly don't think I can get QE running by myself. I will post a better dsdt if I make one, that enables speedstep so the fan isn't constantly running. As for sleep I have no idea why its not working.


 

 

LinkBacks (?)

  1. 03-12-2010, 02:13 AM

Similar Threads

  1. Support for Dell Studio 1557?
    By MadCookie in forum Installation
    Replies: 5
    Last Post: 05-06-2011, 02:54 AM
  2. Snow Leopard on a Dell Studio 17
    By webdevbrian in forum Installation
    Replies: 3
    Last Post: 07-29-2010, 12:28 AM
  3. [Help]Snow Leopard on Dell Studio XPS 16
    By superboysahil in forum Installation
    Replies: 8
    Last Post: 06-28-2010, 05:45 PM
  4. How to install Snow Leopard on Dell 1557?
    By leomayleomay in forum Installation
    Replies: 0
    Last Post: 04-10-2010, 05:14 PM
  5. snow leopard on dell studio 1535
    By nahi_sonu in forum Installation
    Replies: 3
    Last Post: 11-26-2009, 04:06 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 02:38 PM.
twitter, follow us!