Hi guys!

I've recently installed Mac Snow Leopard on a virtual machine and I've got some problems. The host system is a Dell Laptop. I've bought it last month. It's an Dell Inspirion N5110, Intel i7-2630QM, 6GB ram and two video cards, the Intel HD Graphics and a nVidia GT525M. The guest machine has only 4GB and 4 cores out of 8. (actually the processor has just 4 cores, but the OS thinks it has 8, so I offer half of them to the guest).

First and, in my opinion, the most important, the resolution. My laptop's display is widescreen. Maximum resolution(which I'm using in the host OS) is 1366x768. The problemn is Mac is using the 1024x768 resolution, which is the only one I can choose from "System preferences". I've been looking for a fix for this problem for a while, I found some, but none of them worked for me. (some settings like "CustomVideoMode1" in the configuration file of the virtual boxes or the "com.apple.Boot.plist" fix)

The second problem. Screenshot utility isn't working. It just shows a blank image instead of the one which should be displayed. Also, it's not saving on desktop(not even the blank screenshot). I've found some settings which should have fixed my problem like disabling "Shadow in window captures" or deleting a file (I can't remember it's name), but they didn't.

Third problem. Whenever I choose the "About this Mac" option, my screen turns blue for two or three seconds and it returns to it's state. It's not an important problem, I can live with it, but, just to have a perfect Hackintosh.

Thank you for reading and I hope someone will have patience to read everything I wrote and, of course, to help him.