Didn't even know there were 1.6++ distros out there. Oh well. retail is the solution!