Page 1 of 2 12 LastLast
Results 1 to 10 of 15
Discuss Install Retail on MBR? at the Installation - Hackint0sh.org; After months of messing around with this, I finally can get into the installer (This ...
  1. #1
    Advanced Array

    Join Date
    Mar 2010
    Posts
    43
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Exclamation Install Retail on MBR?

    After months of messing around with this, I finally can get into the installer (This helped me do it tonymacx86 Forum • View topic - Succesfuly Installed on Dell Studio 1749). The problem I'm having now is that I can't install because my hard drive is MBR not GUID. I'm not reformatting my hard drive. I've tried multiple times to install modified versions of OSInstall.mpkg. One of them located here: myHack Downloads. Every time I try again, it keeps telling me to format in GUID. Does anyone have any ideas or suggestions?
    Specs:
    Dell Studio 1749
    Intel i3-330M
    Intel HM55 Chipset
    Intel HD Graphics
    6 gigs RAM
    Intel Centrino Advanced-N 6200
    I will specify any other specs if needed



  2. #2
    Moderator Array ratvn's Avatar

    Join Date
    Mar 2010
    Location
    Washington, United States
    Posts
    2,701
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    140

    Default

    Quote Originally Posted by dookiechew View Post
    After months of messing around with this, I finally can get into the installer (This helped me do it tonymacx86 Forum • View topic - Succesfuly Installed on Dell Studio 1749). The problem I'm having now is that I can't install because my hard drive is MBR not GUID. I'm not reformatting my hard drive. I've tried multiple times to install modified versions of OSInstall.mpkg. One of them located here: myHack Downloads. Every time I try again, it keeps telling me to format in GUID. Does anyone have any ideas or suggestions?
    You don't need to reformat HDD to GUID, as there should be a way to install with MBR.
    The OSInstall.mpkg for MBR needed to be replaced in the install DVD. If you can not inject it in then maybe image the SL DVD to USB stick, and then replace the file.

  3. #3
    Advanced Array

    Join Date
    Mar 2010
    Posts
    43
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Ratvn, I was wondering how long it would be until you replied. Basically, here's the problem. I've copied the install DVD through an older hackintosh that I have. I use Disk Utility to copy the image and then I replace the OSInstall.mpkg with a modified one. Every time I use the new retail disk, it always says to reformat in GUID. I'm not sure if I need to change something else or if I'm putting it together wrong or if I'm using the wrong modified OSInstall.mpkg. It seems like some people have no problems doing this while, for others, it doesn't seem to work at all. I was never able to get the USB method to work and I don't want to waste another dual-layer DVD unless I'm sure it's going to work. Has anyone found any OSInstall.mpkg's or tutorials on this that work?
    Specs:
    Dell Studio 1749
    Intel i3-330M
    Intel HM55 Chipset
    Intel HD Graphics
    6 gigs RAM
    Intel Centrino Advanced-N 6200
    I will specify any other specs if needed

  4. #4
    Moderator Array ratvn's Avatar

    Join Date
    Mar 2010
    Location
    Washington, United States
    Posts
    2,701
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    140

    Default

    Quote Originally Posted by dookiechew View Post
    I've copied the install DVD through an older hackintosh that I have. I use Disk Utility to copy the image and then I replace the OSInstall.mpkg with a modified one. Every time I use the new retail disk, it always says to reformat in GUID. I'm not sure if I need to change something else or if I'm putting it together wrong or if I'm using the wrong modified OSInstall.mpkg. the USB method to work and I don't want to waste another dual-layer DVD unless I'm sure it's going to work. Has anyone found any OSInstall.mpkg's or tutorials on this that work?
    I wouldn't want to waste my precious dual layer DVD either.
    1. As for the file, there are more than one for the OSintaller/related files. Usually that is the only one people need to replace, but to be complete for less trouble then at least a couple of them needed to be changed.
    2. I could get you a link for tutorial where they do have the correct OSInstaller file. May not be right away though.
    3. USB would be the easier method as replace those files in DVD would not guaranty working solution/wasting DVD disc.
    3. If all else failed, you can try distro like iAtkos S3 V2 10.6.3 for your hardware or use your existing Leopard to install SL then copy essential OSX86 packages/files/kexts for your specific hardware, as this method also work but require more file manipulation.

    These are just a few suggestion as quick answers/ideas for you.

  5. #5
    Advanced Array

    Join Date
    Mar 2010
    Posts
    43
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    1. The OSInstall.mpkg that I swapped was found on the copied install disk at /System/Installation/Packages/OSInstall.mpkg. I also replaced and made executable the OSInstall file located at /System/Library/PrivateFrameworks/Install.framework/Frameworks/OSInstall.framework/Versions/A/OSInstall.
    2. That would be great if you can get me a working tutorial for this. Whenever you have time.
    3. I would love doing the USB method but every time I do, my computer will just boot right into Windows 7. Yes, I do have my computer set to boot from USB first. Maybe I'm not putting the USB together correctly. I was never really sure how exactly to combine the iBoot disk with the Snow Leopard disk. This could be a big part of my problem. It's definitely something that I would like to hear your ideas on.
    4. I've tried the iAtkos and haven't been able to boot into the installer at all. Plus I've already spent the $30 on the Retail disk. The existing Leopard install that I have is on an older "test" computer that I never use except for modifying install disks and the such.

    Thanks again.
    Specs:
    Dell Studio 1749
    Intel i3-330M
    Intel HM55 Chipset
    Intel HD Graphics
    6 gigs RAM
    Intel Centrino Advanced-N 6200
    I will specify any other specs if needed


  6. #6
    Advanced Array

    Join Date
    Mar 2010
    Posts
    43
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Ok, so I've successfully booted up from USB using this from tonymac. Now if I can just get the OSInstall.mpkg to work
    Specs:
    Dell Studio 1749
    Intel i3-330M
    Intel HM55 Chipset
    Intel HD Graphics
    6 gigs RAM
    Intel Centrino Advanced-N 6200
    I will specify any other specs if needed

  7. #7
    Moderator Array ratvn's Avatar

    Join Date
    Mar 2010
    Location
    Washington, United States
    Posts
    2,701
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    140

    Default

    Quote Originally Posted by dookiechew View Post
    Ok, so I've successfully booted up from USB using this from tonymac. Now if I can just get the OSInstall.mpkg to work
    That is very good. At least one step forward.
    You may need some boot options to boot the installer/reboot OSX as per your hardware configuration.

  8. #8
    Advanced Array

    Join Date
    Mar 2010
    Posts
    43
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    So I did the same thing to the USB that I did to the last dual-layer DVD and for some reason it is installing now. I don't fully understand it, but I'm not complaining. I've got about 12 minutes remaining and it doesn't look like any errors. Fingers crossed. It's too bad that I have to go to sleep shortly after it installs. I will keep you posted and if it works (I know it won't be 100%) I will be posting step by step how I did it very soon. Ratvn, I want to thank you again for having me re-try the USB method. That really broke it wide open for me. Btw, my boot options were -x busratio=16 cpus=1
    Specs:
    Dell Studio 1749
    Intel i3-330M
    Intel HM55 Chipset
    Intel HD Graphics
    6 gigs RAM
    Intel Centrino Advanced-N 6200
    I will specify any other specs if needed

  9. #9
    Moderator Array ratvn's Avatar

    Join Date
    Mar 2010
    Location
    Washington, United States
    Posts
    2,701
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    140

    Default

    Quote Originally Posted by dookiechew View Post
    So I did the same thing to the USB that I did to the last dual-layer DVD and for some reason it is installing now. I don't fully understand it, but I'm not complaining. I've got about 12 minutes remaining and it doesn't look like any errors. Fingers crossed. It's too bad that I have to go to sleep shortly after it installs. I will keep you posted and if it works (I know it won't be 100%) I will be posting step by step how I did it very soon. Ratvn, I want to thank you again for having me re-try the USB method. That really broke it wide open for me. Btw, my boot options were -x busratio=16 cpus=1
    Your boot options is correct.
    Although cpus=4 could be better, but busratio is more important as many Intel's do not need cpus flag.

  10. #10
    Advanced Array

    Join Date
    Mar 2010
    Posts
    43
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    If I'm not mistaken, once I get all the updates and have the newest Vanilla kernel (which supports Intel i3's), I should not need to use the flags. Testing that part out will be easy.
    Specs:
    Dell Studio 1749
    Intel i3-330M
    Intel HM55 Chipset
    Intel HD Graphics
    6 gigs RAM
    Intel Centrino Advanced-N 6200
    I will specify any other specs if needed


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Install SL Retail On vaio sz 483 n
    By ryan_sarchan in forum Installation
    Replies: 2
    Last Post: 04-24-2012, 12:18 PM
  2. Mac OS X Retail Install Help
    By burai135 in forum Installation
    Replies: 0
    Last Post: 06-02-2011, 02:37 AM
  3. Install Mac os 10.6.3 retail
    By macarong35 in forum Installation
    Replies: 4
    Last Post: 03-03-2011, 07:14 AM
  4. Cant install snow leo on my hp with retail 10.6?
    By whouwit in forum Installation
    Replies: 0
    Last Post: 05-05-2010, 06:50 PM
  5. Best motherboard for a retail install 10.5.4
    By gyoung1988 in forum Hardware
    Replies: 3
    Last Post: 01-03-2009, 05:22 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 09:51 PM.
twitter, follow us!