I've got a Dell Inspiron 1545 with Integrated Intel Graphics, 2GB RAM, 2GHz Pentium Dual Core Processor and Ubuntu 9.10.

I downloaded and installed SnowOSX 3.5 and placed the correct kexts for my device in /S/L/E.

When I boot with GRUB2, I get a kernel panic. I've put in the patched IOATAFamily.kext.
I've used all of the available kexts on SnowOSX.

It doesn't boot with a Chameleon boot disk, and it doesn't boot with GRUB2...
Code:
menuentry "Mac OS X (on /dev/sda7)" {
	insmod hfsplus
	set root=(hd0,7)
	search --no-floppy --fs-uuid --set b779377db31ba36e
        insmod vbe
        do_resume=0
        if [ /var/vm/sleepimage -nt10 / ]; then
           if xnu_resume /var/vm/sleepimage; then
             do_resume=1
           fi
        fi
        if [ $do_resume == 0 ]; then
           xnu_uuid b779377db31ba36e uuid
           if [ -f /Extra/DSDT.aml ]; then
              acpi -e /Extra/DSDT.aml
           fi
           xnu_kernel /mach_kernel boot-uuid=${uuid} rd=*uuid
           if [ /System/Library/Extensions.mkext -nt /System/Library/Extensions ]; then
              xnu_mkext /System/Library/Extensions.mkext
           else
              xnu_kextdir /System/Library/Extensions
           fi
           if [ -f /Extra/Extensions.mkext ]; then
              xnu_mkext /Extra/Extensions.mkext
           fi
           if [ -d /Extra/Extensions ]; then
              xnu_kextdir /Extra/Extensions
           fi
           if [ -f /Extra/devtree.txt ]; then
              xnu_devtree /Extra/devtree.txt
           fi
           if [ -f /Extra/splash.jpg ]; then
              insmod jpeg
              xnu_splash /Extra/splash.jpg
           fi
           if [ -f /Extra/splash.png ]; then
              insmod png
              xnu_splash /Extra/splash.png
           fi
           if [ -f /Extra/splash.tga ]; then
              insmod tga
              xnu_splash /Extra/splash.tga
           fi
        fi
}
I've installed it with Mac OS Extended (NOT Journaled)

When I boot with -v under the Chameleon boot disk, it freezes while loading the mach_kernel.
I don't want to give up on OSX.