Hi, guys. I was just wondering whether anyone could help with my ''Hackintosh''

Here's my laptop specifications before we crack on;

Processor - IntelŪ PentiumŪ Dual Core (P6000,1.86GHz, 3MB Cache)
Screen - 15.6" (Acer CineCrystal, 1366x768 HD, High Brightness)
Operating System - Windows 7 Home Premium Edition 64-bit
RAM - 3GB (DDR3 1066MHZ)
Hard Drive 500GB
Optical Drive - DVD Rewriter (Records DVDs 8x & CDs 24x & Dual Layer Super Multi)
Graphics - Integrated (IntelŪ GMA X4500 3D Graphics with up to 384MB Shared Memory)
Wireless LAN - Wireless (802.11b/g/n Wireless)
Network Card - 10/100/1000 Gigabit Fast Ethernet
Integrated Webcam - Integrated Webcam with Microphone
Card Reader - 5-in-1 card reader (SD/MS/MS-Pro/MMC/SDHC/)
USB Ports - 3x USB 2.0 ports
Speakers - Integrated Sound System
VGA Port - 1 External VGA Port
Kensington Lock - Kensington lock slot
Charge Time - 2.5 Hours
HDMI - 1x HDMI Port
Warranty - 12 Months Acer Collect & Return
Battery Life - 3-4 Hours (up to 4 hours with power management)
Weight - 2-3 Kg (This Model 2.5 Kg)
Finger Print Reader - No

I've managed to dual boot Windows 7 with Mac OS 10.6.6 but I've got a few problems with it. I used the Leo Hazard 10.6.6i disc, btw.
1. I haven't got any Wireless Internet connection, despite having a built in Wifi card.
2. It only boots up with the Nawcom CD.
3. It hasn't got the App Store.
4. My USB ports don't work, at all.
5. Every time I try to update, I get an error message.

If anyone could help me fix these problems, it'd be greatly appreciated. Thanks, Mark.