Okay, first off got to send a huge nod of respect to every single poster here, at infinitemac and insanelymac (where I originally posted this). Every question asked and answered took me leaps and bounds closer to getting OSX installed on my beat up machine. First off let me tell you what I'm working with:

-HP Pavillion dv2416us
-AMD Athlon 64 X2 TL-56 @ 1.80GhZ
-NVidiaGEForce GO 6150
-2GB DDR2 RAM
-Coxenant Hi-Def Audio
-Broadcom 4312 wi-fi
-120gb HDD
-I have 3 partitions: disk0s1 is for EFI, disk0s2 is OSX (HFS+Journaled) ~55GB, disk0s3 is W7 (NTFS) ~55GB. It's a hybrid GPT HDD or something like that. I found a guide somewhere on here for doing it and tricking 7 to be the third partition, did all using DiskPart.

I've had this laptop for just over 2 years now, and I've put it through hell. Basically, I've been as hard on the internals of it as you can be without spilling drinks on it. Partitioned, wiped, killed OS (Vista is nowhere to be found on it anymore for some reason, not an OSX issue though), left on for like ever, and pretty much abused all in all. I don't think this is the ideal machine for trying OSX, and that's before even getting into the fact that it's not meant to run on this hardware. But, I have got Leo4Allv4 10.5.4 up and running and it's all working great while dual-booting with Windows 7, for the most part. Here's what I chose:

-Leo4Allv4
-Kernel 9.4.0 (upgraded to 9.5 & Chameleon 2.0 using iDeneb 10.5.6)
-Broadcom network
-Azalia & AC97 Audio
-NForceTest (I think, it was the default NForce)
-Remove Firewire
-About This Mac
-Kext helper
-pacifist
-MD5
-Transmission
-Candybar
-Then the default EFI & patches *I did not select anything for no-EFI*
-Using iDeneb1.6 10.5.8 distro I installed Chameleon & Voodoo Kernel 9.5 as well as cpus-1=fix in order to get my dual-boot with Windows 7 working.
-Once booted into OSX I deleted the ACPIPlatform & APIC kexts and replaced using the dv6420 pack found in this thread.
-I also installed NVDrive, NVInject & NVidia kexts in that file as well. This may have been unnecessary to have them all in, but it's got my display working to it's full 1280x800. It also got my wi-fi working.
-I also installed NForceLAN from here and osx86Tools.

I never had any problem with keyboard or my USB mouse really. Same goes for the installed webcam on my HP, it works like a beast in iChat. Using the chameleon bootloader I have the flags "cpus-1 -v" inserted into my com.apple.boot.plist, again may be unneeded but it's working so not sure I wanna mess with it. Using the NForceLAN driver found on this site I also have my ethernet working. So, it's all good, right? Not quite...

Problems that need solving...

-I'm worried about sleep. Can I do it? What about hibernate? Does it hurt to try it? I mean, it's not gonna kill it, is it?
-Runs hot sometimes. My laptop is known for doing that, and I haven't noticed anything major in the half-day I've had the dual-boot fully working too worrisome. But, I have the iStat Nano widget for dashboard, and it says no fans noticed. It sounds like they're on, but I want OSX to see them. Any tips?
-When I choose the Windows 7 partition from chameleon, it takes me to the EasyBCD bootloader where I have to choose W7 again. Is there any way to only have chameleon?
-I installed Chameleon by booting into the iDeneb distro and just doing the patch for that and voodoo kernel. So, how do I upgrade to the latest RC for 2.0? Also, I don't have an "Extra" folder for me to put themes into, or if I do I can't find it. In fact, I can't find anything about chameleon. Is it hiding somewhere?
-Updating to 10.5.higher then 4, how? In the past I've had the 10.5.4 working and everytime I tried to update something happened and I had to start all over. With everything. Kind of a PITA. I have iAtkosv7, iDeneb1.6 & iPC10.5.6, using them can I select only the system with no kernels, patches or drivers since what I have now works? I tried the method where you terminal, put the code to disable applecpuintelkext, install update, replace don't steal with dsmos, blah blah. It didn't work, my laptop shut off maybe half way through. Is this sleep (have it completely disabled in system prefs, is sleep/hibernate anywhere else?), heat (had been pushing it those days, so maybe it decided enough was enough and wanted to shut down), or 10.5.5 (the only one I tried using getting the update combo direct from mac, not software update) not being compatible? Would love to get up to at least 10.5.7, but don't wanna have to go back to square one.
-Chameleon is giving me the "hibernate image too old..." prompt right when it starts to boot into the OS. It still goes, but is this a big deal, how do I get rid of it and/or make it not happen.
-Are there any kexts that are just not needed at all? I read somewhere that you can delete pre-installed ones that you KNOW you don't need i.e, ATI, etc. I also have some called kerberos something or other (not in OSX right now so can't be exact) that I just noticed this time around on the install, needed?
-ALF Alert, I turned on printer sharing, got ALF Alert, turned it off and ALF went away. I have an ALF.kext (may be more in the name) in my /System/extensions, would deleting that get rid of ALF Alerts and enable to share printers?
-To delete kexts do you just move them to the trash can after backing them up?
-Haven't tried this install, but on previous ones Mail would launch with with accounts I set up, but would ask for passwords every time. I added them to keychain, entered them in the prefs for the account and everything. Any way to make it remember?
-I may look into making the OSX partition using this post. However, if I create another partition in 7 it'll be partition 4, so would I type "sudo diskutil mergePartitions "Journaled HFS+" New disk0s1 disk0s4" instead of "sudo diskutil mergePartitions "Journaled HFS+" New disk1s1 disk1s2"? Can it merge partitions that are separated by another partition that's formatted separately?


Okay, I know that's a lot of info, and a lot of questions. I'll keep researching and as I resolve (or give up trying) I'll post what I've got in this thread. A preemptive thank you to anyone who comes in and has words of encouragement/advice/tips. I'm pretty sure this is the correct section, since I've got it installed and working, but if it needs to be moved go ahead and my bad. Thanks!

Oh, just to say I'm loving OSX. It runs super smooth, and the ease of changing icons using candybar is awesome. I installed FF as my default browser and love it. iChat is set to launch with my GTalk account. Any pointers/tips/must haves for OSX that don't come stock? Cheers guys!