Weird... hmm maybe bad burn, but why dont just update your installation from 10.5.4 to 10.5.5, check about how to update in the sticky