Results 1 to 3 of 3
Discuss Alienware m15x at the Installation - Hackint0sh.org; Hello, I am somewhat new to osx86. I installed iAtkos 5 on my Dell XPS ...
  1. #1
    Newbie Array

    Join Date
    Jun 2009
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Alienware m15x

    Hello, I am somewhat new to osx86. I installed iAtkos 5 on my Dell XPS m1710 and got ethernet working after a lot of tweaking. I recently got an Alienware m15x though and I can't seem to get the OS working properly. It won't even boot. I was wondering what OS distribution would work on my m15x if any. And would it work with atleast ethernet?

    Thanks!~

    Here is my system info:

    II. Configuration


    Processor(s)

    Processor 1
    Name- Intel(R) Core(TM)2 Extreme CPU X9000 @ 2.80GHz
    Manufacturer- GenuineIntel
    Caption- Intel64 Family 6 Model 23 Stepping 6
    Version- Model 7, Stepping 6
    Processor Id- BFEBFBFF00010676
    Current Clock Speed- 2800MHz
    Address Width- 64Bits
    Data Width- 64Bits
    Socket Designation- U2E1
    Verified Hardware Device against Order- CPU-2.80C2EX9000SCRD
    Verify Correct Processor Frequency

    System Memory

    Memory Module 1
    Capacity- 4096MB
    Bank Label- DIMM #1
    Mem_Type- DDR2
    Mem_Frequency- 664 MHz
    Verified Hardware Device against Order- MEM-MOBLDDR24GP53ELP
    Verify Correct Memory Size
    Verify Correct Memory Type
    Memory Module 2
    Capacity- 4096MB
    Bank Label- DIMM #2
    Mem_Type- DDR2
    Mem_Frequency- 664 MHz
    Verified Hardware Device against Order- MEM-MOBLDDR24GP53ELP
    Verify Correct Memory Size
    Verify Correct Memory Type

    BIOS Information

    Manufacturer- Quanta
    Name- PhoenixBIOS 4.0 Release 6.1
    Version- vX36 P3
    Version- ALWARE - 6040000

    Motherboard Information

    Manufacturer- Alienware
    Product- m15x
    Serial Number-
    Version- Not Applicable
    Verified Hardware Device against Order- MB-MD2WUXGASLRIPNTR1
    Verify correct motherboard
    Power settings optimized

    Video Adapter

    Caption- ATI Mobility Radeon HD 3870
    Adapter RAM- 512MB
    DriverVersion- 7.01.01.861
    Verified Hardware Device against Order- MOBL-VM88XT512MBR1
    Test Video Card

    Hard Drive(s)

    ST9320421ASG
    Model- ST9320421ASG
    Size- 320GB
    Total Heads- 255
    Total Cylinders- 38913
    Total Tracks- 9922815
    Tracks Per Cylinder- 255
    Verified Hardware Device against Order- MOBL-HD320GB72FSEAR2

    Miscellaneous

    Optiarc DVD RW AD-7561A ATA Device
    Device Name- Optiarc DVD RW AD-7561A ATA Device
    Description- CD-ROM Drive
    Class- CDROM
    Service- cdrom
    Driver Version- 6.0.6001.18000
    Driver Date- 6-21-2006
    Verified Hardware Device against Order- MOBL-NEC8XDVDRWLS
    Intel(R) Wireless WiFi Link 4965AGN
    Device Name- Intel(R) Wireless WiFi Link 4965AGN
    Description- Intel(R) Wireless WiFi Link 4965AGN
    Class- Net
    Service- NETw4v64
    Driver Version- 11.1.0.86
    Driver Date- 2-25-2007
    Vendor Id- 8086
    Device Id- 4229
    Revision- 0061
    Verified Hardware Device against Order- NIC-INTELWIREL4965

    Thanks a lot~



  2. #2
    Newbie Array

    Join Date
    Jun 2009
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    bump~...

    donwloading iatkos 7 hope it works...

  3. #3
    Senior Professional Array

    Join Date
    Jun 2009
    Posts
    232
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    16

    Default Video and wireless will be an issue

    The video and wireless will be an issue. The Optiarc might or might not get recognized by the MAC OS after installation. It's a DVD-Burner Apple i-DVD issue.

    If your latest download does not work, try iDeneb 10.5.6

    Read this all the way through - but . . . you need to Google for your answers and do some research instead of relying on and expecting a spoon fed answer. Every machine is different. Visit the link at the bottom of this post.

    After a successful install, and it does not boot all they way through then f8 at boot to the Darwin prompt, and then . . .

    You need to boot with -s. If it loads that to a command line, you've got likely kext problems. Then try -x -v so you can see where it stops, slows, issues errors or hangs. If you get in that way to a desktop you've got probably video kext problems. These can be LOTS of different problems depending on whose distribution you installed and how old it is. Get the newest one - right now which is 10.5.6. IPC has some issues with laptop keyboards not working after install - IDeneb seems to go better.

    NO ONE can help you right now. You do not say what is wrong, you do not say what you did that does not work and you offer no clues as to your level of expertise as to EXACTLY where you are stumped. You just scream "please help me". Posting that you think you got it working without understanding what you did does not help either. You might now really have it working as it should be.

    If you go to a Medical Doctor and just scream "please help me" and will give no symptoms or clues as to what is going on - even a Doctor cannot help you but begin guessing - and guess what - they get paid to do so - no one here is being paid by you, and still the doctor could end up killing you rather than saving you because you did not tell a critic piece of information - like a severe allergy or something like that which could kill you in his efforts to help you. Computers - especially the OS's of computers are NO DIFFERENT.

    You do not say what is going on. No one is a mind reader here and were not sitting in front of your machine.

    Usually a Kext is likely probably not loading or blocking something - or the kernel panics. That means dies the horrible crash like a aircraft pilot would it the pilot panic'ed in an emergency situation and did not know what to do.

    The kexts are vendor and device ID specific - so if the kext does not have the right vendor and model ID referenced in the kext file - it will fail - or pass up the device anyway. The kexts ARE the drivers - and sometimes you only need to change or add the vendor and device ID.

    You have to figure this out yourself - it is YOUR machine. They are all different as to what is in the unit from the manufacturer, and even if using common device components - the vendor and device ID may be different that what the kext might have in it.

    If you have Windows still on the same machine - and it is working - you can do kext editing from inside windows by installing some helper tools to look into the HPS drive. Use Windows Text Editor - Editpad Lite (only one that will work) and Ext2Fsd 0.46 - An open source Ext2 File System Driver for Windows - Softpedia and Catacombae - HFSExplorer (HFS Explorer) to see and get at the Mac files in Windows; OR you can BUY Macdrive. If you are having dual boot problems try installing EasyBCD from inside Windows to boot between the two. Its free.

    This above will only work if you have been smart enough to do a dual boot machine where Windows is on another partition or permanent drive in the same computer. If Windows will not boot use a Vista repair disk or the XP disk to repair the boot sector - then install EasyBCD through Windows and it will see the MAC partition to let you set it up on the boot manager. Google how to get one if you do not have them.

    You can see the vendor and device ID in Windows, and the kext will have a name and you can find the vendor and device ID in the text of the kext info.plist. You can edit this from the Windows side with the editor above - and use no other - they will not work.

    After you get in through safe mode, you can run "diskutils repairpermissions /" (without the quotes) and to fix the changes you made from the Windows side.

    You come in single user with the -s command at the prompt. Do what it says to mount the

    volume and then

    You do a "sudo -s" first (no quotes)
    cd /System/Library
    chmod -R 755 Extensions /
    touch Extensions /
    diskutil repairpermissions /

    If you had trouble with the registration looping or other things then . . . after that above of mounting the volume make a password for root by typing

    passwd root

    Then when done type

    touch /var/db/.AppleSetupDone

    reboot

    There are other ways to do this and much more from the -s boot option (single user mode) but it is really getting UNIX specific as to the commands, and if you are there and know nothing anyway - you should probably pay someone, buy a real MAC or just give up - OR get ready for a real extensive learning curve and research on the web.

    You need to do some research on how the MAC OS works. Match your kext families with the missing parts of the OS not loading - change the vendor and device ID's and one at a time - you'll get them working and the boot errors will go away.

    If you have/had IPC 10.5.6 ppf4 or ppf5 you would likely have most of the kexts - but they might not have the right vendor ID and device ID for the unit you are trying to install on.

    It works for both CPUs Intel or AMD. IDeneb 10.5.6. might go more successfully.

    Once installed, you need to boot in safe mode from the Darwin prompt with the -x option. Use -v also so you can see what it is loading and if it does stop in safe mode and where. Then you can try -v -f on another boot to see if it will make it all the way

    The MacOS is at it's core - UNIX - you cannot just lump a question in something and throw it here that is non-descriptive as to tell anyone not at your PC what is TRULY going on, even though I am a UNIX engineer.

    No one can help you if they cannot tell what is really going on - and if you are not ready to learn some UNIX - give up now.

    If you install the right kexts (Kernel EXTensionS) with the right vendor id's applicable the system will load them as it finds the hardware during the boot process. Remember the kext might be there - but have the wrong vendor and device ID - so it will get passed up.

    Read the clues of the boot process yourself and do some research as to what they mean and then if you have a specific question you cannot find on the Internet or in the forums - that someone can identify - post that.

    Of course you can always BUY a real MAC, and then holler "please help me" all you want to Apple Computer Support, and at some point they will tell you the same thing.

    If you install the right kexts (Kernel EXTensionS) with the right vendor id's applicable the system will load them as it finds the hardware during the boot process.

    Read the clues of the boot process yourself and do some research as to what they mean and then if you have a specific question you cannot find on the Internet or in the forums - that someone can identify - post that.

    Visit the Main Page - OSx86 for the best source of simple question info
    Last edited by bobburns; 06-28-2009 at 07:18 AM. Reason: forgot one thing

 

 

Similar Threads

  1. Alienware m15x Snowleopard 10.6 HELP please
    By aaron1o1 in forum Installation
    Replies: 0
    Last Post: 09-04-2011, 04:23 PM
  2. Alienware m15x 2009 r3..??
    By lust_wolf in forum Installation
    Replies: 20
    Last Post: 04-29-2011, 01:09 AM
  3. Help Installing OSX to Alienware M15x
    By RallyX in forum Installation
    Replies: 2
    Last Post: 03-21-2011, 04:42 PM
  4. SL 10.6.3/4 on Alienware M15x
    By i_max2k2 in forum Installation
    Replies: 1
    Last Post: 07-12-2010, 09:17 PM
  5. Alienware m15x
    By gmx in forum Installation
    Replies: 1
    Last Post: 02-27-2010, 12:24 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 05:28 PM.
twitter, follow us!