Okay so I tried to install Kalaway on my laptop but no go... waiting for root device...

So I downloaded leo4all, set my bios to boot cdrom first, then usb hard drive and then notebook hard drive. I enabled virtualization technology in the bios, thought it might help, although I'm sure it doesn't really do anything in this case. Popped the disk in did a reboot, the darwin screen comes up I pressed F8 and then typed "-F", the install started quite quickly, I was told to reboot and did, once back on the install started up, it asked me where to install the OS, no drives were listed so I opened the disk utility and formatted my external HDD to 'Mac Journaled' the install continued. I left for several hours... parents were on my ass about going to the store with them to help pick out a new computer and various other things... when I came back the screen was black but the computer was on. I rebooted and got a 'missing boot.plist' error. I tried using every imaginable kernel, or other option at the darwin prompt, sometimes after hitting enter I would still be at the darwin prompt just that what I had typed previously would disappear every time I hit enter. Other times I would go straight to the 'missing boot.plist' error. I cannot reformat the external hdd as windows will not read it and I do not have a Mac.

What is causing this? I figure the hardware must be compatible since it worked the first time around. The disk is fine I burned a second one at the slowest possible speed and still same problem.