Results 1 to 4 of 4
Discuss Intel ICH6R SATA Problem at the Hardware - Hackint0sh.org; Hi there guys! I have recently bought a Dell PowerEdge 750 server which has an ...
  1. #1
    Rookie Array

    Join Date
    Sep 2007
    Posts
    24
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Exclamation Intel ICH6R SATA Problem

    Hi there guys!

    I have recently bought a Dell PowerEdge 750 server which has an Intel 7210 chipset and ATI Rage XL embedded, as well as an ATI PCI-X 64bit slot which contains a Dell Adaptec CERC SATA RAID, and am trying to get Mac OS X working on it. I have managed to get loaded and booted 10.4.7, 10.4.8, 10.4.11, and 10.5.4, but with each I have a problem.

    The hardware RAID did not work, and I wasn't expecting it to, but the onboard SATA does work... to an extent. The onboard SATA is Intel ICH6R, which from reading up on it *should* work. But it doesnt.

    With any 10.4.x it seems to run fine at first, graphics okay, especially for a server, but the one thing that doesnt work properly is the Hard Drive transfers. It appears to be using the AppleGenericPCATA.kext file with a max transfer rate of about 2MB/sec. It shouldnt be using that kext right? It should be using the AppleIntelPIIXATA.kext right? Having tried all the different AppleIntelPIIXATA patches out there I have had no luck with it so far in that it does not even boot and gives me the "still waiting for root device" error.

    With 10.5.4 its a bit of a longer story, however I managed to get iDeneb booted (JaS would not even boot), and then used a boot-132 disc to load up OS X then needed to replace the IOATAFamily kext from the boot-132 disc to the OS X Install. Same 2-3MB/sec problem as it is still using the AppleGenericPCATA.kext file, and removing that and patching the AppleIntelPIIXATA.kext file gives me the same root device waiting error.

    When using the AppleGenericPCATA.kext file the system does not see the drives as SATA drives, but shows them as ATA drives.

    I really want to get this thing working, but don't understand why it won't. I'm hoping someone out here will be able to help me as I'd really like to run OS X (preferably Leopard 10.5.4) on this server.

    I'm kind-of reaching the end of this road here...

    Thanks in advance to any help given.
    Last edited by Jaffa; 09-15-2008 at 10:40 AM. Reason: Spelling



  2. #2
    Rookie Array

    Join Date
    Sep 2007
    Posts
    24
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Upon inspection of the AppleIntelPIIXATA.kext it seems that it only has support for ICH6 and ICH6-M, but not ICH6-R... Does anyone know how I could get this working in any way so that it is not limited ti 2-3MB/sec using the AppleGenericPCATA.kext file?

  3. #3
    Rookie Array

    Join Date
    Sep 2007
    Posts
    24
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    If it helps at all I have managed to get the Linux driver for this from Dell. It has piix mentions in the file names, so the AppleIntelPIIXATA.kext would logically seem like it is the one to use, but why does it give the 'waiting for root device' error when used...

    Still trying, please help.

  4. #4
    Rookie Array

    Join Date
    Sep 2007
    Posts
    24
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    In the AppleIntelPIIXATA.kext source from 10.5.4 I have found ICH6-R mentions, so I am assuming that it supports ICH6-R but for some reason its not working. Anyone have any ideas what I could try?

 

 

Similar Threads

  1. SATA Problem -_-'
    By Cheesophile in forum Installation
    Replies: 0
    Last Post: 08-28-2011, 10:27 PM
  2. Jmicron SATA Problem-Still Waiting on BD...Tried everything-Need Pro Help PLZ???
    By GreenMachine in forum Kernel / Kext (Driver) Support
    Replies: 1
    Last Post: 01-15-2010, 02:17 PM
  3. SATA HDD size detection problem
    By Allanon25 in forum Using Leopard
    Replies: 0
    Last Post: 05-07-2009, 11:20 PM
  4. Intel® 82801GH SATA RAID Controller driver
    By master_nando in forum Kernel / Kext (Driver) Support
    Replies: 0
    Last Post: 04-22-2009, 09:18 PM
  5. Does SATA Cause a problem ?
    By KM50 in forum Hardware
    Replies: 6
    Last Post: 12-23-2008, 03:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 07:19 AM.
twitter, follow us!