Hi all,

I'm sure you've been asked this time and time again but looking at the forum there seems to be lots of issues with the wrong hardware so here we go again...

I've spent the past few days working on ML in a VMWare v9, looks great, worked first time but can't get things like iMovie working due to the lack of QE etc. I understand how difficult this is so am considering going all in and removing Windows 7 all together. Before I do this I would like to get a better understanding of the potential issues involved with the hardware I have and the ongoing management (OS upgrades etc).

I currently have the following set up:

Antec 1200 Case
Asus P6T Deluxe v2
Intel i7 920 (at 3.4Ghz and water cooled)
6GB of RAM
3x SAMSUNG HD103SJ (1TB each and 2 of them currently mirrored via motherboard for system disk)
2 further external USB drives (1TB and 232GB)
nVidia GTX295 (dual pcb)
TSSTcorp CDDVDW SH-S223F
2x Monitors (24" and 23" both via DVI)

So I can find reference to the motherboard on the forum but it appeared to be complicated to get everything working (sound, ethernet..etc), I'm not that big on 'issues' and would like this to work as close to standard as possible.
Not sure about the GTX295, some seem to suggest a different card would be better...but no spare coffers to invest.

If the above is 'reasonable' and can be made to work with little (or no) effort, what can I expect performance wise (interested in running iMovie)? From a day to day perspective will Software and OS upgrades work or will these break everything and I'll spend the next few years fixing issues?

I have been in the IT industry from 20yrs so know my way around things but I'm no Unix expert (VMS was my thing, not that many of you will remember VMS).

Any help would be great,

Dz