Results 1 to 7 of 7
Discuss GX270 - Supported? at the Hardware - Hackint0sh.org; ...
  1. #1
    Advanced Array

    Join Date
    Jan 2009
    Posts
    30
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default GX270 - Supported?

    Hi,

    I fancy having a dabble with OSX so was hoping to install it on a Dell Optiplex GX270. I've downloaded two versions and not had any success yet, admittidly i don't really know whay i'm doing, so i've came here for help

    Hardware:
    Optiplex GX270
    Intel 865G chipset,
    2.6Ghz Pentium 4 HT,
    4Gb DDR Ram
    IntelŽ PRO Gigabit2 Network
    lite-on IDE DVD burner
    WD 1Tb Sata HDD

    Graphics are Integrated Intel ExtremeŽ Graphics 2 (on board). I also have an AGP 128mb Radeon 9200, would be happy to use either, but may be buying a better card soon anyway.

    So I suppose my first question is... whats my chances of getting any flavour of OSX up and running with my current setup?
    And what's the "best" release to have a go with? most compatable, and easiest to set up may be the best for me at the moment, until i get a feel for it and learn a bit more



  2. #2
    Newbie Array

    Join Date
    Mar 2009
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Any luck?? I too am trying to get osx86 to work on my dell optiplex 270.

    ALL - Does anyone know if I can use the nvidia AGP 8x 512 mb card??

    I would greatly appreciate it. I have seen that the 256 works, but can't find anything on 512.

    Thanks so much for any help.

  3. #3
    Advanced Array

    Join Date
    Jan 2009
    Posts
    30
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Well i'm really not getting very far with this...

    I've played around disabling stuff in the bios, and with/without a graphics card and it's just not having any of it, also tried both a 40gb IDE drive and a 1Tb sata.

    the best I can get is using "ToH_x86_9A581_RC2.iso" where it will run though the whole install process successfully, but on reboot I will just get a flashing cursor and nothing else

    I've also tried Leo4All, but I can't even get to the GUI of the installer with that it puts up quite a bit of text, but then just reboots and starts all over again.

    What else can I try?

  4. #4
    Hackint0sh Moderator Array icchansan's Avatar

    Join Date
    Sep 2007
    Location
    Puerto Ordaz, Venezuela, Venezuela
    Posts
    6,641
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    349

    Default

    Theres no support for this atm, sowwy.
    HP Pavilion Elite m9250f
    Snow Leopard 10.6.6, Asus IPIBL-LB MOD BIOS, Intel Quad Core Q6600, 4GB RAM (800mhz), 2x500GB, nVidia 8600GT (Works), ALC888S (Works), Wireless RT73 (Works), LAN (Works) - How to Install - Blog - Hardware Combos - FAQ by TJ2K7
    Macbook Pro 13"
    iPhone 4
    Follow meh: @icchansan

    If you just want to support hackint0sh.org with a donation click here

  5. #5
    Advanced Array

    Join Date
    Jan 2009
    Posts
    30
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by icchansan View Post
    Theres no support for this atm, sowwy.
    cheers when you say its not supported, what exactly do you mean? which part isn't supported? I've read several comments on the wiki pages saying people have got it running on a GX270.


    well the stuborn/determined bugger I am, i wasnt gonna be beaten so I carried on trying. Got a total of 5 iso's now lol. anyway, after a few installs I found a couple of things that weren't immediatly obvious to me..

    When setting up partitions and you need to choose the jouraled option, you have to make sure your using the Master Boot Record option. (which i hadn't done for the first few times.) I couldnt do this with the sata drive for some reason no matter which install I tried. I could choose the MBR with DOS format, or GUID with journaled format, but not MBR with Journaled as it errored. strange. Anyway I've got an old 40gb IDE drive kicking about so tried that and I could do what I wanted.

    Anyway I got osx installed and booting up using ToH_x86_9A581_RC2. only with default graphics. Any ideas if the radeon (asus) AH3450 (agp) is supported?

    Unfortunatly I had a more serious issue.. when you plug the network cable into the internet it came up with a message saying "You need to restart your computer. Hold Down the Power button for several seconds or press the Restart button" Any suggestions as to what this could be? before it pops up it finds my routers IP fine, so it seems to work, but then crashes like that. I am using the onboard "IntelŽ PRO Gigabit2 Network".


  6. #6
    Hackint0sh Moderator Array icchansan's Avatar

    Join Date
    Sep 2007
    Location
    Puerto Ordaz, Venezuela, Venezuela
    Posts
    6,641
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    349

    Default

    Im not sure if it got support with 10.5.7, check netkas site, but so far I know it wont work, I mean you can install but wont get QE/CI
    HP Pavilion Elite m9250f
    Snow Leopard 10.6.6, Asus IPIBL-LB MOD BIOS, Intel Quad Core Q6600, 4GB RAM (800mhz), 2x500GB, nVidia 8600GT (Works), ALC888S (Works), Wireless RT73 (Works), LAN (Works) - How to Install - Blog - Hardware Combos - FAQ by TJ2K7
    Macbook Pro 13"
    iPhone 4
    Follow meh: @icchansan

    If you just want to support hackint0sh.org with a donation click here

  7. #7
    Newbie Array

    Join Date
    Apr 2009
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Raising old thread here, but here goes...

    Optiplex GX270 running 10.5.8

    Things you will need:
    - iPC 10.5.6 DVD;
    - iDeneb 10.5.8 Combo update;
    - Supported video card (I use nVidia Quadro FX500/600 - it is a fight but works - get 6200 or better);
    - Supported NIC (I am using very old Intel 82557 dual socket card).

    BIOS:
    - Disable hyperthreading;
    - Disable onboard video;
    - Disable onboard NIC;
    - Adjust to taste for your video card.

    Install with iPC 10.5.6 with following adjustments:
    - Voodoo kernel 9.5
    - AppleLegacyIntelPIIXATA (this makes PATA disk boot)
    - Slice USB patch for hotplug USB sticks
    - OpenHaltRestart (seems to sort out some sleep issues)
    - SMBIOS by ToH (seems to fix About This Mac crashing)
    - Seatbelt kext from 10.5.5
    - Kext installer (useful)
    - OSx86Tools (required for inserting video EFI strings and enabling QuartzGL)

    With some practice, I was able to get the machine to boot with -f -v flags required to stop kernel panics.
    Lots of things say they are not happy during verbose boot, but you should get the welcome video running.

    If you have GeForce 5200 or FX500/600, you want instructions by SimKard, especially artifact fix/CoreGraphics 10.5.5 version. Adjust the kexts for your build of card (mine is 032b). With a bit of practice here, you can have working QE/CI (see below) and full resolution.

    At this stage, you may get strange results in System Profiler for machine, memory and video (mine shows empty PCI slots of which I have 4 cards installed and apparently I have no RAM modules either!)

    However, you should be able to install iDeneb combo update 10.5.8 now (do not reboot though) and the iDeneb 10.5.8 tools (choose anv kernel and continue to boot with -f -v flags).

    For those looking for video card details, here they are:
    NVIDIA Quadro FX 500/FX 600:
    Chipset Model: NVIDIA Quadro FX 500/FX 600
    Type: Display
    Bus: PCI (really AGP but it works!)
    VRAM (Total): 128 MB
    Vendor: NVIDIA (0x10de)
    Device ID: 0x032b
    Revision ID: 0x00a1
    ROM Revision: nVidia FX500/600 OpenGL Engine [EFI]
    Displays:
    Display Connector:
    Status: No Display Connected
    SyncMaster:
    Resolution: 1680 x 1050 @ 60 Hz
    Depth: 32-Bit Color
    Core Image: Hardware Accelerated
    Main Display: Yes
    Mirror: Off
    Online: Yes
    Quartz Extreme: Supported
    QuartzGL: Supported

    I hope this helps someone out there struggling with this type of machine. My recommendation is to get a hardware combination that will do vanilla install - this is trial and error to get right. Some Apple updates will overwrite CoreGraphics framework and you will need to reapply 10.5.5 CoreGraphics fix.

    Greetz

    S

 

 

Similar Threads

  1. iATKOS v7 on dell gx270
    By xtgold in forum Installation
    Replies: 1
    Last Post: 12-28-2010, 02:25 PM
  2. OS X 10.5.6 on a Dell Optiplex GX270
    By sdschramm in forum Installation
    Replies: 5
    Last Post: 08-30-2010, 10:29 PM
  3. GX270 and iAtkos
    By LittleMike in forum Installation
    Replies: 13
    Last Post: 02-16-2010, 06:04 PM
  4. Dell GX270 install help
    By feklhr in forum Installation
    Replies: 5
    Last Post: 04-17-2009, 01:24 AM
  5. ToH RC2 - Dell OptiPlex GX270
    By PolishOX in forum Archiv (Leopard)
    Replies: 2
    Last Post: 12-08-2007, 05:48 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 05:03 PM.
twitter, follow us!