Results 1 to 3 of 3
Discuss [Audio] Could this be the solution to SoundBlaster cards?? at the Hardware - Hackint0sh.org; I just started to play around with iATKOS v4, I used v1 previously which I ...
  1. #1
    Newbie Array

    Join Date
    Jan 2008
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default [Audio] Could this be the solution to SoundBlaster cards??

    I just started to play around with iATKOS v4, I used v1 previously which I had a very hard time to get working. Currently it works pretty good with cpus=1 enabled.

    My system is:

    Dell Dimension 8200
    P4, 2GHz, SSE3
    256RAM (!! amazing it works with this much mem)
    60GB MacHD, 120GB WinXP
    SB Live! 5.1 card - NOT WORKING

    I came across this thread after doing a Google search for "iatkos sb live driver"
    http://www.driverheaven.net/mac-os-x...0b3-alpha.html

    I quickly went to the site, installed the driver, but its not working for some reason. I tried both versions, neither works. I checked the HCL and I have an SB Live card that is compatible (or should be from their list).

    What gives?

    Anyone on this forum more knowledgeable about this than me care to give me a hand and try it out for themselves? Sound working on my OS X install is all that's keeping me from using it full-time over FreeBSD. More native apps available for Mac OS X.

    Thanks in advance!



  2. #2
    Newbie Array

    Join Date
    Jan 2008
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Nobody's tried it yet? This is what I can gather from doing a lot of searching. I tried to load the kernel extension manually, since kextstat | grep 'kX' doesn't return that it's loaded. I get this:


    bash-3.2# kextload kXAudioDriver.kext/
    /System/Library/Extensions/System.kext/PlugIns/IOKit.kext/IOKit: Undefined in symbol set: __ZN14IOPMrootDomain24systemPowerEventOccurredEPK8 OSSymbolP8OSObject
    /System/Library/Extensions/System.kext/PlugIns/IOKit.kext/IOKit: Undefined in symbol set: __ZN14IOPMrootDomain24systemPowerEventOccurredEPK8 OSSymbolj
    kextload: loaded version 2.4 of module com.apple.iokit.IOPCIFamily differs from requested version 2.4.1
    kextload: a link/load error occured for kernel extension kXAudioDriver.kext/
    link/load failed for extension kXAudioDriver.kext/
    (run kextload with -t for diagnostic output)


    bash-3.2# kextload -t kXAudioDriver.kext/
    extension kXAudioDriver.kext/ has potential problems:
    Warnings
    {
    "Kext has no explicit kernel dependency" = true
    }

    kextload: extension kXAudioDriver.kext/ appears to be loadable
    /System/Library/Extensions/System.kext/PlugIns/IOKit.kext/IOKit: Undefined in symbol set: __ZN14IOPMrootDomain24systemPowerEventOccurredEPK8 OSSymbolP8OSObject
    /System/Library/Extensions/System.kext/PlugIns/IOKit.kext/IOKit: Undefined in symbol set: __ZN14IOPMrootDomain24systemPowerEventOccurredEPK8 OSSymbolj
    kextload: loaded version 2.4 of module com.apple.iokit.IOPCIFamily differs from requested version 2.4.1
    kextload: a link/load error occured for kernel extension kXAudioDriver.kext/
    link/load failed for extension kXAudioDriver.kext/

    Someone a lot smarter than me has to figure this out. It appears to be working for others with Audigy/SB Live cards. I can't figure out why it's not working for me!

  3. #3
    IRC Netadmin
    Team of Hackint0sh
    Array f41qu3's Avatar

    Join Date
    Nov 2006
    Posts
    1,572
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Kext incompatible with OSX...simple...

    Need wait SoundBlaster (or someone) make new versions about this kext.
    If you just want to support hackint0sh.org with a donation click here.

    Twitter: @f41qu3 @hackint0sh @hmbt_org @iphone_dev

 

 

LinkBacks (?)

  1. 02-24-2010, 02:44 PM

Similar Threads

  1. Replies: 0
    Last Post: 11-03-2011, 06:00 PM
  2. Replies: 0
    Last Post: 10-04-2011, 08:20 PM
  3. M-Audio 2496 and Delta PCI Audio Cards
    By axel_ef in forum Hardware
    Replies: 1
    Last Post: 11-18-2008, 02:30 PM
  4. Replies: 0
    Last Post: 06-15-2008, 09:50 PM
  5. Replies: 1
    Last Post: 06-05-2008, 03:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 07:40 AM.
twitter, follow us!