Page 28 of 30 FirstFirst ... 818192021222324252627282930 LastLast
Results 271 to 280 of 295
Discuss [Video/TV Output][Effort] Building your own cable and patch IAP at the Hardware - Hackint0sh.org; Originally Posted by lolento As suondmao, already stated on his tutorial, the modded IAPD file ...
  1. #271
    Newbie Array

    Join Date
    Aug 2009
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by lolento View Post
    As suondmao, already stated on his tutorial, the modded IAPD file ONLY removes the popup message, it does NOT enable video out capability if your cable does not already support it.

    Furthermore, after my own experience since using the IAPD file from the 2.2.1 FW days, I found that this is not the best solution. The IAPD file crashes periodically after this mod. You will see this when you check your crash folder, mine had couple hundred crash logs related to this IAPD file. This is also the reason why the video or audio would either stop or pause by itself after a brief use.

    The better solution is to pay a dollar and use PopupBlocker. This does the same thing as the IAPD file and way MORE.
    So why did Shahjahan's iapd file work?


  2. #272
    Rookie Array

    Join Date
    Aug 2008
    Posts
    23
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by mlcohen View Post
    So why did Shahjahan's iapd file work?
    How do you define 'work'?

    Shahjahan's IAPD is exactly the same file as Suondmao without even giving the author credit.

    All it does is that it removes the popup about "accessory compatible", that's all. The rest is up to your cable, if it support video out or not.

    I used Shahjahan's file as well. It indeed cause the IAPD file to crash periodically.

    So I don't know know how you define 'work', but if Shahjahan's file worked for you then PopupBlocker would work even better because the popup blocking is handled through mobilesubstrate and thus the IAPD file would not crash.

  3. #273
    Newbie Array

    Join Date
    Aug 2009
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I gess you learn somthing new every day I was under the impression that his IAPD file was accomplishing more than that. Thnanks

  4. #274
    Newbie Array

    Join Date
    Oct 2009
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Ok, i changed the iapd and it works now with one of the cheap non-apple AV-cables. I do not get any 3rd party-Warning Messages anymore.

    But:
    The Play of a video comes to pause after 15 seconds and you have to press play again.
    Scrollbars and Volumebars are missing on the iphone display most of the time.

    Does the original Apple AV Cable does a better job?

    Thank You
    Alexandra

  5. #275
    Newbie Array

    Join Date
    Jul 2009
    Posts
    8
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Video out working on jailbroken original iPhone firmware 3.1.2

    I used suondmao's iapd patched for firmware 3.0, put it at /System/Library/PrivateFrameworks/IAP.framework/Support/iapd as root, chmod 755, and rebooted.
    See vortex's Oct05 post for a link.

    Youtube works, Screensplitr works, TVOut works, iPod video works.
    Sometimes Screensplitr only works if I open up YouTube first.

    Video and Audio both work.
    Sometimes a "This accessory not made for iPhone" message pops up.
    I can't figure out what triggers it, but immediately after the message, video out does not work.
    Video out does start to work again, but I can't figure out what causes it to start working again (other than a reboot).

    I have a jailbroken iPhone first generation (iPhone 2G) with firmware 3.1.2.
    I tested this with some third party cable and also with a MyVu Crystal.

    EDIT: Nevermind, it doesn't actually work with the random third party cables. *Sigh*
    Last edited by bondiblueos9; 11-14-2009 at 11:33 PM. Reason: Didn't work as perfectly as I thought at first.


  6. #276
    Newbie Array

    Join Date
    Oct 2009
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Just purchased the original Apple AV-cable set. I couldnt find a working iapd for my phone.
    Everything works fine but how do i change the volume of the videos on the iPhone?

    Thank You
    Alexandra

    iPhone 3GS 32Gb OS 3.0

  7. #277
    Newbie Array

    Join Date
    Jul 2009
    Posts
    8
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Alexandra:
    I think when an A/V cable is plugged into the dock, the iPhone expects that you are using whatever you plugged in to control the volume, so there are no controls on the iPhone itself.

  8. #278
    Newbie Array

    Join Date
    Oct 2009
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Well the iPhone is wrong. I am lying on my kingsizebed and cant reach the volume knob of my stereo!!

    So am i right there is no working iapd for iPhone 3GS OS 3.0? I can live with the original apple product. Its more expensive but works and comes with a power supply you need anyway.

    I just ordered the Logic 3 Pro Dock and the cinemizer plus. Review follows.

    Thank you
    Alexandra

    iPhone 3GS 32Gb OS 3.0
    Last edited by Alexandra; 10-18-2009 at 07:34 PM.

  9. #279
    Newbie Array

    Join Date
    Jan 2009
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Question

    what about a patch for 3.12 ?
    any news ?

  10. #280
    Newbie Array

    Join Date
    Jul 2009
    Posts
    8
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Accessory not supported -- wikee.iphwn.org

    Did anybody see or try this? From the end of Answers to random questions [iPhone Dev Team]

    Accessory not supported

    If you get popups like Twitpic - Share photos on Twitter every time you plug in your accessory or charger, try issuing this command from a login shell:

    /bin/launchctl unload -w /System/Library/LaunchDaemons/com.apple.accessoryd.plist

    If you ever want to put that daemon back in place – it's probably there for a reason :-) – do this:

    /bin/launchctl load -w /System/Library/LaunchDaemons/com.apple.accessoryd.plist
    EDIT: Nevermind, this didn't work any better for me either.
    Last edited by bondiblueos9; 11-14-2009 at 11:34 PM. Reason: Didn't actually do much for me.


 

 

LinkBacks (?)

  1. 05-14-2012, 09:45 PM
  2. 03-08-2010, 04:22 AM

Similar Threads

  1. TV Output patch on ipod touch 2g dont work
    By fedegil69 in forum Hardware
    Replies: 0
    Last Post: 04-26-2009, 04:19 PM
  2. MacNN: Scosche debuts iPhone audio/video output cable
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 01-29-2009, 05:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 01:51 PM.
twitter, follow us!