Page 12 of 30 FirstFirst ... 2345678910111213141516171819202122 ... LastLast
Results 111 to 120 of 295
Discuss [Video/TV Output][Effort] Building your own cable and patch IAP at the Hardware - Hackint0sh.org; we have reached a milestone! copy /System/Library/PrivateFrameworks/IAP.framework/Support/iapd to where ever you can to open it ...
  1. #111
    Advanced Array

    Join Date
    Jun 2008
    Posts
    31
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    we have reached a milestone!

    copy /System/Library/PrivateFrameworks/IAP.framework/Support/iapd to where ever you can to open it in a hex editor

    open a hex editor

    goto offset 6d94c

    OVERWRITE it with 00 30 a0 e3

    copy this patched iapd back

    if you dont have ldid type apt-get install ldid

    then

    ldid -S iapd

    chmod 777 iapd

    reboot

    *this will only work for 20-30 sec then you have to tap the video again - this is by no means a release im still working on it not stopping after 90 secs

    Thanks!!




    schmave out
    Last edited by iSchmave; 08-22-2008 at 11:41 AM.


  2. #112
    Rookie Array

    Join Date
    Aug 2008
    Posts
    28
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Good to see you guys are cracking at this on the video side. Now if the stupid forum would allow me to create a thread to document my work on the Motorola D650 Bluetooth adapter, then I'd be on my way.

    Our work is related, because it's basically hacking at the dock interface, but still. The rules say 3 posts, and I should be able to create a new thread, but NO.....5 posts and it still won't let me.

  3. #113
    Advanced Array

    Join Date
    Jul 2008
    Posts
    40
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    hello all. i just started reading this thread so forgive me if this is off topic.
    i just started getting the "this accessory is not made for iphone" message today. i read somewhere that at least on 1.1.4 you could delete the apd file in the framework. when i did this the iphone would boot, but was totally unresponsive and kept cycling. luckily i could ssh in and put the file back in there so it still runs. unfortunately, the message still pops up, so i was wondering if there was a fix for this, just to kill this message entirely.

    thanks a bunch

  4. #114
    Advanced Array

    Join Date
    Jun 2008
    Posts
    31
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    what cable do you have?

  5. #115
    Newbie Array

    Join Date
    Aug 2008
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    a bit of a hijack and Im sorry for this but I cant start a new thread yet.... And it is closely related.

    My question is on the iapd

    I am on FW 2.0.2 and am having issues with the " This accessory is not made to work with iPhone " nag message. ( I dropped it in water... ) Basically every time my iPhone awakes I get the nag and then I am unable to use the external speaker for audio. (the ringtones and system sounds still work though.. )

    After doing some google searches this was the only thread I could find that had any info on the iapd process.

    Basically I must have shorted out the dock connector in the iPhone somehow.

    I have read somewhere that if I just delete the iapd off of the iphone Ill be fine. I dont quite trust that post so I was hoping you guys could help after seeing some of your research on the iapd.

    I see that the iapd is responsible for turning on this nag screen and controlling info on the different accessories that could be connected to the dock.

    You guys will make a whole bunch of people happy if you could find a way to hack the iapd to turn off the nag screen in your quest for fixing the video issue.

    My iPhone works perfectly except for the nag and the resulting speaker shut off. If I could just stop the stupid nag screen...

    Anyways sorry again for the hijack and if somebody with some privileges would like to move this to the proper location that would be great.


  6. #116
    Advanced Array

    Join Date
    Jan 2008
    Posts
    40
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    keep up with your very good work ! unfortunately i'm not been able to test it. i have hexedited my file ( firmware 2.01) and replaced it in the phone but at reboot the phone hangs at slide to unlock screen. totally blocked.

    I left ssh and wifi on, so i've been able to ssh and replace the backup file, then everything came back ok.

    can you attach an edited file for firmware 2.01 or 2.02 to try it ?
    tnx!

  7. #117
    Advanced Array

    Join Date
    Jun 2008
    Posts
    31
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    soz guys, ok

    1. this (im sure) ONLY turns the "nag msg" off when a VIDEO CABLE is connected i.e (we're going back to th old system of enumeration) something that has that pull down resistor (i dont know the value).

    2. you MUST run apt-get install ldid -S iapd

    3. then you must run
    sysctl -w security.mac.proc_enforce=0 security.mac.vnode_enforce=0

    4. then you must run chmod 777 iapd

    5. then and only then can you kill the iapd process and see if it is auto respawned. if it is then you can reboot

    -> your iPhone will hang if there is a) NO iapd b) no execute bit on iapd c) no hash string written into the header OR you haven't run sysctl -w security.mac.proc_enforce=0 security.mac.vnode_enforce=0

    again this "patch" will only "allow" the cable for like 30 secs, a timer (maybe 2) are created after you start a video, and when they end so does your video - turning them off ddosent work either.

    i'm still working on a full patch but this proof of concept is halfway

  8. #118
    Advanced Array

    Join Date
    Jun 2008
    Posts
    31
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by superduca View Post
    can you attach an edited file for firmware 2.01 or 2.02 to try it ?
    nope sorry thats really illegal

  9. #119
    Newbie Array

    Join Date
    Aug 2008
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Dear iSchmave

    Please let me know what version of ipod that you worked.

    Because there are so many versions today, please post about 16 bytes of code around your patch point. Then we find it with hex editor and can replace it.

    Thanks in advance ^^

  10. #120
    Senior Professional Array

    Join Date
    Jul 2008
    Posts
    147
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    13

    Default

    not to do with video but will it ever be possible to use the old cables to charge any modifications we can do? i have a system in my car, the "ipod" function works with my stereo but the thing wont charge cos its an unspported acessory Which means its pointless as the battery gets murderd before i get out the car lol


 

 

LinkBacks (?)

  1. 05-14-2012, 09:45 PM
  2. 03-08-2010, 04:22 AM

Similar Threads

  1. TV Output patch on ipod touch 2g dont work
    By fedegil69 in forum Hardware
    Replies: 0
    Last Post: 04-26-2009, 04:19 PM
  2. MacNN: Scosche debuts iPhone audio/video output cable
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 01-29-2009, 05:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 02:11 AM.
twitter, follow us!