Results 1 to 2 of 2
Discuss Suggestions - "No Service" after battery replacement (1st Gen) at the Hardware - Hackint0sh.org; Hi, Here is my story: Someone threw me in the pool during my bachelor's party ...
  1. #1
    Advanced Array bozzakwebmaster's Avatar

    Join Date
    Dec 2007
    Location
    Canada
    Posts
    42
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Smile Suggestions - "No Service" after battery replacement (1st Gen)

    Hi,

    Here is my story: Someone threw me in the pool during my bachelor's party and my Iphone was water damaged. After letting it dry for 3 weeks, everything worked except the battery. It was able to keep a charge for more than a day and would not charge up fully. So I decided to let it be and use my Razr for a while.

    Now, it's about 5-6 months since the incident, I decided to start using it again. Like before, everything works (Wi-Fi, camera, speakerphone, ipod, etc...) except the battery and the ear speaker sometimes doesn't work during calls (but works after a light tap).

    So I bought a replacement battery kit and installed it without a hitch, carefully soldering the battery to the logic board. Now the battery can hold a charge a lot longer and can charge fully.

    Where I went wrong is when I decided to remove the logic board in the Iphone to see if I could see what is going on with the ear speaker. Only to find out that I can't access the speaker from there.

    When trying to re-assemble it, the touch screen wasn't working anymore. I fixed that by making sure all 3 connectors on the logic board are connected properly. I re-assembled every thing. All the functions work, even my ear speaker, but I now get "No Service" as soon as I insert the SIM and when I switch on and off to airplane mode, it stays at searching for a long time.

    It's such a bummer, I thought I finally would have a fixed Iphone. Does anyone know what could be the problem? Could this be a fried comm board? Or is there another wire I should be looking at?

    Thanks.

    Martin



  2. #2
    Advanced Array bozzakwebmaster's Avatar

    Join Date
    Dec 2007
    Location
    Canada
    Posts
    42
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Ok well, I opened the IPhone again and it looks like I have a fried a circuit. I see some burnt circuits near the connector that connects the logic board to the comm board. I tried to clean that up to no avail.

    It's actually worst than I though, the same circuit segment is burnt on the logic and comm board!

    Now I am stuck with a glorified 8Gb Ipod Touch, but at least this one has a camera!

    Anyone have a spare working logic/comm board?
    Last edited by bozzakwebmaster; 11-28-2008 at 03:40 AM.

 

 

Similar Threads

  1. macbook showing "no batteries available" and "battery not charging"
    By KingKrusha in forum Genuine Mac Support
    Replies: 4
    Last Post: 01-18-2014, 08:49 AM
  2. 3G "no service" after battery empty
    By leskk in forum Ultrasn0w (3G(S)/iPhone 4 unlock)
    Replies: 1
    Last Post: 10-03-2011, 09:51 PM
  3. Replies: 0
    Last Post: 01-07-2009, 09:30 PM
  4. "Unlock.app" can fix "no service","no wifi","IMEI 049.."
    By max9241 in forum iPhone "2G" (Rev. 1)
    Replies: 17
    Last Post: 11-11-2007, 04:12 PM
  5. Replies: 1
    Last Post: 09-15-2007, 09:15 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 03:02 PM.
twitter, follow us!