Results 1 to 2 of 2
Discuss Opened up iPhone to clean out SIM card slot - screen is now dead at the Hardware - Hackint0sh.org; Hello, For about a wee I've had spotty and inconsistent service, with the "Searching..." or ...
  1. #1
    Newbie Array

    Join Date
    Aug 2009
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Opened up iPhone to clean out SIM card slot - screen is now dead

    Hello,

    For about a wee I've had spotty and inconsistent service, with the "Searching..." or "No Service" message constantly up. AT&T switched my SIM card to no avail, and the guys at the Apple Store did the same (and then blew out the device with canned air) which momentarily fixed it. The problem resumed when I was home, 50 miles away.

    Since the Apple Store guy said I had water damage (the hell?) I decided to open this up and make sure the connections were fine. I ended up finding dust within the SIM card area and blew it off. My phone made a sound indicating that it had received a text message-- but now the screen doesn't work! I've secured connectors 1, 2, 3 and 4, but still nothing is happening. I can hear that the phone is "on", but nothing is on the screen. I'm waiting now for the battery to die so I can reconnect everything again and give it a shot again. Any tips?



  2. #2
    Senior Professional Array navco786's Avatar

    Join Date
    Jan 2008
    Location
    United Kingdoms
    Posts
    148
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    23

    Default

    A connection is definitely loose on it somewhere. There is a very delicate connection between the board and screen. The slightest movement can loosen it. Best thing would be to open it up again and look at the connector between the board (under the screen, near the top). Try pressing down on the screen near the top to see if something clicks back into place.


    Quote Originally Posted by brunonian View Post
    Hello,

    For about a wee I've had spotty and inconsistent service, with the "Searching..." or "No Service" message constantly up. AT&T switched my SIM card to no avail, and the guys at the Apple Store did the same (and then blew out the device with canned air) which momentarily fixed it. The problem resumed when I was home, 50 miles away.

    Since the Apple Store guy said I had water damage (the hell?) I decided to open this up and make sure the connections were fine. I ended up finding dust within the SIM card area and blew it off. My phone made a sound indicating that it had received a text message-- but now the screen doesn't work! I've secured connectors 1, 2, 3 and 4, but still nothing is happening. I can hear that the phone is "on", but nothing is on the screen. I'm waiting now for the battery to die so I can reconnect everything again and give it a shot again. Any tips?

 

 

Similar Threads

  1. Replies: 0
    Last Post: 10-13-2011, 04:00 AM
  2. Replies: 0
    Last Post: 01-15-2011, 03:40 AM
  3. Opened Iphone Gone Bad! Screen Not Working
    By blueboxer in forum Hardware
    Replies: 3
    Last Post: 01-16-2010, 05:11 AM
  4. MacNN: USBfever iPhone battery adds second SIM card slot
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 08-31-2009, 05:50 AM
  5. SIM Card Slot - Can somone confirm it?
    By sam in forum General
    Replies: 5
    Last Post: 07-04-2007, 03:21 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 07:32 PM.
twitter, follow us!