Results 1 to 6 of 6
Discuss No sound from earpiece, speaker or headphones when on calls. at the Hardware - Hackint0sh.org; Hello guys, Well this is my first post here, after reading a lot. Hopefully I'll ...
  1. #1
    CLP
    CLP is offline
    Rookie Array

    Join Date
    Dec 2008
    Posts
    10
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Unhappy No sound from earpiece, speaker or headphones when on calls.

    Hello guys,
    Well this is my first post here, after reading a lot. Hopefully I'll get a solution to my problem.

    I can't hear anything when I'm on a call, there's like a grabled sound from the earpiece, no sound on speaker, and no sound on headphones. But the speaker and headphones works fine for the other functions such as ipod, apps, etc. The only problem is that when I place/receive a call, I can't hear nothing from the earpiece, but there's no sound on speaker or headphone.

    I've tried the plug and unplug headphones hundreds of times, cleaning the headphone jack, resetting all settings, restore to original 2.2 (it's legally unlocked).

    But nothing seems to help, if I press the volume button when I'm on a call, it doesn't display headphones are connected, so this is not the typical problem of iPhone thinking headphones are connected.

    This is an iPhone 3G 16GB running fw v2.2


    Any help guys will be much appreciated.

    Thank you and happy holidays!



  2. #2
    Senior Professional Array

    Join Date
    Sep 2008
    Posts
    221
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    19

    Default

    Quote Originally Posted by CLP View Post
    Hello guys,
    Well this is my first post here, after reading a lot. Hopefully I'll get a solution to my problem.

    I can't hear anything when I'm on a call, there's like a grabled sound from the earpiece, no sound on speaker, and no sound on headphones. But the speaker and headphones works fine for the other functions such as ipod, apps, etc. The only problem is that when I place/receive a call, I can't hear nothing from the earpiece, but there's no sound on speaker or headphone.

    I've tried the plug and unplug headphones hundreds of times, cleaning the headphone jack, resetting all settings, restore to original 2.2 (it's legally unlocked).

    But nothing seems to help, if I press the volume button when I'm on a call, it doesn't display headphones are connected, so this is not the typical problem of iPhone thinking headphones are connected.

    This is an iPhone 3G 16GB running fw v2.2


    Any help guys will be much appreciated.

    Thank you and happy holidays!
    well if it's officially unlocked then why don't u get it repaired under warranty, if that is possible. Anyways just try a DFU restore and setup as a new iPhone and don't restore from the backup made by itunes. Hope this helps

    Cheers

  3. #3
    CLP
    CLP is offline
    Rookie Array

    Join Date
    Dec 2008
    Posts
    10
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Thanks for your reply.

    If I take it to the Apple Store I'm going to get a replacement for sure, but this iphone was bought in Australia, and I'm not there, and not planning to go there. That's why I can't take it to use the warranty and get a replacement.

    Any other suggestions?

    Thank you!

  4. #4
    Newbie Array

    Join Date
    Jan 2008
    Posts
    9
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    This is quite simple, I guest! While you are on a call, press on the volume at the side of the phone. If it shows headphone volume on screen, you will need to plug the headphone in and out till the switch inside releases then you can hear from earpiece. good luck.

  5. #5
    Senior Professional Array

    Join Date
    Sep 2008
    Posts
    221
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    19

    Default

    Quote Originally Posted by CLP View Post
    Thanks for your reply.

    If I take it to the Apple Store I'm going to get a replacement for sure, but this iphone was bought in Australia, and I'm not there, and not planning to go there. That's why I can't take it to use the warranty and get a replacement.

    Any other suggestions?

    Thank you!
    I don't know the policies for the warranty in USA I suppose? But i think it's worth a shot just walk in and tell them this is my problem i bought it in australia and all and if u bought it from some recognised apple shop or something over there then i think they should service ur phone, unless there are some international warranty limit or something for the iPhone. I mean i have not tried to go to the apple store or something, i bought my iPhone from a "3rd party store" if u know what i mean it's the 2G version.

    Good luck and I hope things will work out for u

    Cheers

    P.S if ur device is jailbroken then make sure to do a DFU restore before taking the device to apple, and don't even mention the word "jailbreak" over there.
    Last edited by hussain93; 12-27-2008 at 07:24 PM.


  6. #6
    CLP
    CLP is offline
    Rookie Array

    Join Date
    Dec 2008
    Posts
    10
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Well... thanks guys.

    When I'm on a call and I press the volume controls it doesn't show up as it has headphones connected. And it's weird because there's no sound coming out from the speaker or the headphones when I'm on a call...

    In the other side, Apple Limited Warranty is limited to the country of purchase, but you are right, maybe I'll give it a try and go the apple store here and ask them. I'm concern that they may take note of my serial number and deactivate my phone, as this is a legally unlocked one, that's the only reason for why I haven't take it to the store yet...

    Well if any other suggestions on how to fix it appears, I'll appreciate them, I'll keep searching for solutions and if I go to the apple store I'll let you know!

    Thanks and happy holidays!

 

 

Similar Threads

  1. Replies: 19
    Last Post: 10-11-2008, 10:19 PM
  2. [Sound] Earpiece and Speaker not working
    By gungungogo in forum Hardware
    Replies: 2
    Last Post: 06-02-2008, 01:36 AM
  3. Replies: 0
    Last Post: 01-29-2008, 07:05 PM
  4. No sound on calls unless I use speaker phone
    By upsett3r in forum General
    Replies: 9
    Last Post: 11-22-2007, 09:39 PM
  5. Replies: 1
    Last Post: 09-18-2007, 01:18 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 06:12 PM.
twitter, follow us!