Page 1 of 2 12 LastLast
Results 1 to 10 of 16
Discuss [Earspeaker] no sound (next to the sensors) at the Hardware - Hackint0sh.org; hi i've got a spare phone here, that doesnt do what it's supposed to do ...
  1. #1
    Senior Professional Array

    Join Date
    Aug 2007
    Posts
    300
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    24

    Default [Earspeaker] no sound (next to the sensors)

    hi

    i've got a spare phone here, that doesnt do what it's supposed to do ^^

    when calling, only speaker (loud from bottom left speaker of cours) and earpiece to work, but not the regular speaker next to the approx. sensor.

    when i listen to music, the iPhone correctly recognizes wheter earpieces are pluged in or not (sound from the speaker), so i dont think its the regular problem with the solution to just reinsert the earpiece plug dozense of times.

    it could be that the cable for that speaker is broken.
    i testet the approximility sensor, which worked, as well as the light sensor, which works as well.


    does anybody know, if and how i can test the earspeaker?



  2. #2
    Supporter Array

    Join Date
    Sep 2007
    Posts
    232
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    19

    Default

    I've noticed that most of iphones that loose the earspeaker functionality belong to the first weeks of this year and on.

    In all of that cases a earspeaker replacement is needed.

  3. #3
    Newbie Array

    Join Date
    Aug 2006
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default same here!

    same here.
    broken earspeaker and i had to dismantle the phone(painful process) and replace the ear speaker with one that i bought from ebay it works after, but not as loud as before
    I think i'll sell the Iphone and wait for Iphone II

    BR

  4. #4
    Newbie Array

    Join Date
    Jun 2008
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Red face same problem

    even i am experiencing the same problem. can u tell me how much must have the earspeakers cost ?? .. help!!!

  5. #5
    Advanced Array

    Join Date
    Oct 2007
    Location
    Santiago de Chile
    Posts
    32
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    have you ever tried plugging and unplugging phones?
    it worked for me..


  6. #6
    Advanced Array

    Join Date
    Sep 2007
    Posts
    38
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    same here....my earspeaker has arrived from Hong Kong today so i'll change it this weekend...could you provide some info on how to change the ear speaker(where it's located,how does it look,etc)....BTW did you try to blow really hard into the earspeaker or where the earphones are inserted...i've found that it worked for me for about 2 minutes then it died again...so now i know that the problem is regarding the earspeaker.

  7. #7
    Advanced Array

    Join Date
    Sep 2007
    Posts
    38
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by crispain View Post
    I've noticed that most of iphones that loose the earspeaker functionality belong to the first weeks of this year and on.

    In all of that cases a earspeaker replacement is needed.
    Well mine is 1.1.1 OTB so it's from last year and i'm having this issue

  8. #8
    Newbie Array

    Join Date
    Aug 2006
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by Azeem View Post
    even i am experiencing the same problem. can u tell me how much must have the earspeakers cost ?? .. help!!!
    i think i payed 12$ for earspeaker and 15$ transport from Hong Kong

  9. #9
    Advanced Array

    Join Date
    Sep 2007
    Posts
    38
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    i've payed 8$ and 12$ shipping from Hong Kong....i've found it on ebay,but there are a lot of US sites that sell ear speakers for the Iphone but they don't tell you how to install it.Also the earspeaker it's like 1cm wide so don't get fooled by the pics in witch it looks like it's 5 cm wide.Also i think that in order to install it you need to solder it,so if you're not good at this ask somebody to help you.I'm planning of installing mine today...so if it works i'll post here!

  10. #10
    Advanced Array TheCondor's Avatar

    Join Date
    Mar 2008
    Location
    Italy - Toscana
    Posts
    35
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    i have a iphone with a trouble like your.
    For a call it works and for another no..
    so i have open it and apply on the connector of the flat cable and the mainboard the electronic oil (sorry, i don't know his name). On the cable that go up the speaker, the second flat from the left (center).
    So now it works perfectly.
    I've also clean the speaker contact with the abrasive paper.
    Iphone 1.0.2 OTB @ 1.1.4

    Macbook 2,2ghz - 4Gb Ram - 250Gb HDD


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 0
    Last Post: 04-05-2011, 08:57 PM
  2. Earspeaker defect...??
    By awear in forum Hardware
    Replies: 8
    Last Post: 08-12-2009, 07:10 AM
  3. Replies: 0
    Last Post: 01-22-2009, 07:20 PM
  4. Replies: 6
    Last Post: 05-15-2008, 04:03 AM
  5. Problem earspeaker
    By DonnieDarko48 in forum General
    Replies: 1
    Last Post: 11-29-2007, 11:31 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 12:06 AM.
twitter, follow us!