Page 1 of 2 12 LastLast
Results 1 to 10 of 14
Discuss This accessory was not made to work with iPhone ... at the Hardware - Hackint0sh.org; FOR PATCH SEE POST 13 Hey guys, I had a bit of an accident with ...
  1. #1
    Senior Professional Array

    Join Date
    Feb 2008
    Posts
    134
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Angry PARTIAL FIX - This accessory was not made to work with iPhone ...

    FOR PATCH SEE POST 13


    Hey guys, I had a bit of an accident with my iPhone ... kinda fell in some water with the phone in my pocket. The good news is that the phone is fine ... the bad news is that the message "This accessory was not made to work with iPhone" pops up a lot now. When this happens, the speaker does not work for YouTube videos or MxTube videos and the iPod portion of the phone will not play on the external speakers. However, the speaker does work for ringtones and the like. When I plug in my headphones, everything works.

    I have read a ton about people with this problem but is there a software fix? It seems that if that error message could be ignored, the phone would function correctly 100% of the time ...

    PS ... running 2.0.1 on first gen iPhone
    Last edited by ramb0; 09-11-2008 at 08:08 AM.



  2. #2
    Senior Professional Array

    Join Date
    Feb 2008
    Posts
    134
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    Anyone? ....

  3. #3
    Rookie Array

    Join Date
    Aug 2008
    Posts
    28
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Your dock connector must have something jammed in it that is connecting pin 11 to a ground. Get in there with a toothpick and *carefully!* make sure that nothing is coming into contact with pin 11.

  4. #4
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    114
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default Help needed

    Quote Originally Posted by Numbski View Post
    Your dock connector must have something jammed in it that is connecting pin 11 to a ground. Get in there with a toothpick and *carefully!* make sure that nothing is coming into contact with pin 11.
    How do we locate Pin 11 ?

    Also, I have this same problem PLUS iPhone will not charge from USB cable, but will charge from old FireWire cable, and will not sync (ie computer can not 'see' iPhone is connected).

    This iPhone was dropped (no water involved) with only a small 'ding' on the edge near the volume and silent mode switches.

    Thanks for any help/advice.

  5. #5
    Rookie Array

    Join Date
    Aug 2008
    Posts
    28
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Looking at the dock connector with the screen facing up, pin 1 is on your left, 30 is on your right. Pin 11 will be about 1/3 of the way across. Looks about right to me - if pin 11 is shorted, of course usb won't work. Pin 11 is serial ground - if it's somehow tied to usb ground, then that would explain both of your symptoms. If it's dinged on the outside, something on the inside might be touching pin 11's trace...


  6. #6
    Senior Professional Array

    Join Date
    Feb 2008
    Posts
    134
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    Still no dice ... anyone have a software fix?

  7. #7
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    132
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    17

    Default

    This sounds like a hardware issue to me. I don't think there will be an adequate software fix. I think you may need to purchase a replacement part.



    It's about $8 on ebay.

  8. #8
    Senior Professional Array

    Join Date
    Apr 2008
    Location
    Kathmandu
    Posts
    148
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    I have the same problem. But mine is due to a rusty cable. Changing the cable worked for me.

  9. #9
    Senior Professional Array

    Join Date
    Jul 2008
    Posts
    147
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    13

    Default

    maybe turning it off and putting it in a cupboard to dry it out for a few days will help.
    had a similar problem with my old phone turning onto headset mode after some water damage but drying it out properly fixed the problem. Failing that as flash says a software fix is highly likely going to be out of the question yourl have to replace the port.
    Last edited by bigfishman; 09-05-2008 at 05:58 PM.

  10. #10
    Professional Array

    Join Date
    Oct 2007
    Posts
    65
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    The last glimpse of hope is from this thread where a guy named funnysuresh has found a way to fix it by deleting a specific file called iapd

    http://forums.macrumors.com/showthre...=350765&page=2

    Apparently it works for <1.1.4 but not 2.x

    I really hope one of you genius hackers can find a way to fix this it's really frustrating seeing this error box pop up !


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. This Accessory Is Not Made To Work With Iphone
    By subbetica in forum General
    Replies: 12
    Last Post: 10-07-2009, 03:30 AM
  2. Replies: 10
    Last Post: 04-30-2008, 06:39 AM
  3. Replies: 4
    Last Post: 04-28-2008, 04:01 PM
  4. This accessory is nnot made to work with iphone???
    By Bigweezy911 in forum General
    Replies: 15
    Last Post: 02-08-2008, 04:21 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 10:12 AM.
twitter, follow us!