Results 1 to 4 of 4
Discuss G4 Serious problem at the Genuine Mac Support - Hackint0sh.org; Hi Guys, i wanted to ask if You could help me with this problem. My ...
  1. #1
    Newbie Array

    Join Date
    Jan 2009
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Exclamation G4 Serious problem

    Hi Guys,

    i wanted to ask if You could help me with this problem.
    My Mac powerbook G4 has lost all visiblity on the scree, it stays completely white, so i have since connected an external monitor screen to work with it which isnt a problem, since everything is still functioning minus the screen.

    However, after i asked someone to take a look at it, they returned it to me, and when i start it up it asks for the administrator password, which after i proceed to put in, still wont give me access.

    i want to try the tip which may allow me to create a new password.

    Command- S on restart and then,

    /sbin/fsck -y [Enter]
    /sbin/mount -uaw [Enter]
    rm /var/db/.applesetupdone [Enter]
    reboot [Enter]

    BUT, because the screen is white i cant see anything on the laptop, and nothing shows up on the external monitor either after putting in the command-s on restart,

    Is there any way of being able to see it on the external monitor so i can put in the /sbin/fsck -y [Enter]
    /sbin/mount -uaw [Enter]
    rm /var/db/.applesetupdone [Enter]
    reboot [Enter]


    Thanks guys,
    appreciate it



  2. #2
    Newbie Array

    Join Date
    Jan 2009
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    FIRST. I do not recommend using this tip to create a new password and am not responsible for the information I give.

    When it prompts you for a password is that on the laptop screen or your external screen? Do you have the original discs that came with the computer?

  3. #3
    Newbie Array

    Join Date
    Jan 2009
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hi Andy,

    Thanks for the reply.

    it asks for the password on the external monitor.

    When ever i try and a coomand on boot like pressing C, nothing shows up on either screen.

    yeah i have the discs that came with the powerbook

    Thanks, any help is appreciated

  4. #4
    Senior Professional Array

    Join Date
    Dec 2007
    Location
    Earth
    Posts
    275
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    23

    Exclamation

    dasilva... quite a fix you're getting yourself in....

    First, andyboutte's solution. aka Apple's official solution. pop the disk in before startup, then choose your language; when the installer screen pops up, choose Reset Password from the Installer menu (or Utilities menu in Mac OS X 10.4 Tiger). Select your volume and change your password...

    Mac OS X: Changing or resetting an account password


    The problem, though, is this.
    rm /var/db/.applesetupdone
    First, I would never, ever, delete anything that's kept away from the user without a backup...
    The correct way next time, should you try it again, is
    mv /var/db/.applesetupdone .applesetupdonebackup
    That way you can always reverse it if you encounter any problems.

    Now I must ask you if you have made a backup of your volume? (i.e. with time machine or a clone of your hard drive?)
    If so, restore it from there. If not, copy that file from someone else's computer and cross your fingers (never tried it.).

    Last tip: Never. Ever. Mess with terminal if you don't know what it'll do...
    iMac 20' Intel Core 2 duo 2.16GHz, 4GB DDR2-667 SDRAM, Mac OS X 10.5.1 "Leopard"
    Hackintosh Q6600 4GB DDR2-667 SDRAM, 9800GT, Mac OS X 10.5.6 "Leopard" (EFI-X)
    Macbook 13' Intel Core 2 duo 2.2GHz, 4GB DDR2-667 SDRAM, Mac OS X 10.5.6 "Leopard"
    iPhone 2G (8GB) 2.2 (1.1.2 OTB) Week 48 J'B'ken + Activated + Unlocked

 

 

Similar Threads

  1. I have very big problem with my hack, i think it's problem with kernel or drivers
    By HiTECNOLOGYs in forum Kernel / Kext (Driver) Support
    Replies: 0
    Last Post: 01-04-2011, 05:25 AM
  2. iDeneb problem + Boot Selector problem
    By KevinB in forum Installation
    Replies: 0
    Last Post: 04-25-2009, 09:47 PM
  3. Screenshot Problem!! Photo Saving Problem!!
    By jamleezy in forum Free Toolchain Software (Cydia App's)
    Replies: 0
    Last Post: 04-09-2008, 09:33 PM
  4. Sim Card Problem/Jailbroken 1.1.2 downgraded problem
    By XcaLi in forum iPhone "2G" (Rev. 1)
    Replies: 4
    Last Post: 01-18-2008, 07:15 PM
  5. Replies: 1
    Last Post: 01-17-2008, 03:16 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 05:22 AM.
twitter, follow us!