Results 1 to 5 of 5
Discuss Anyway to get Leopard to install on G4 PPC? at the Genuine Mac Support - Hackint0sh.org; My iMac G4 PPC is at 10.4.11 and iTunes says "This iPhone cannot be used. ...
  1. #1
    Newbie Array

    Join Date
    Oct 2008
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Anyway to get Leopard to install on G4 PPC?

    My iMac G4 PPC is at 10.4.11 and iTunes says "This iPhone cannot be used. It requires MAC OS X 10.5 or higher" I put in a 10.5.4 disc and it says It cannot be installed on this system. Anyway to get it to install or to get iTunes to read and use my iPhone? I tried and older version of iTunes and it says I must use 9.1 or higher to use. I don't know if this matters but I have 4.0 OS on my iPhone 3GS. If that is the cause, will that mean my iMac is usless?
    Last edited by Zehlek; 05-03-2010 at 05:35 PM.



  2. #2
    Newbie Array

    Join Date
    May 2010
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Snow leopard can't be installed on PPC, it's intel only unforunately you might be able to do something with ubuntu or similar, it supports PPC and their default media player supports syncing music to iphones and ipods.

  3. #3
    Newbie Array

    Join Date
    Jun 2010
    Posts
    1
    Post Thanks / Like
    Downloads
    1
    Uploads
    0
    Rep Power
    0

    Default Leopard on G4's below 867 Mhz

    It can be done but requires several things:
    *another mac that can run leopard
    *a firewire cable
    *Leopard installation DVD

    Boot YOUR G4 into target mode by holding down the 'T' at startup.
    When your mac displays the firewire symbol, connect it to the mac that can run leopard. Reboot the other mac from the installation DVD and specify your macs hard drive as the drive to install to. Back up your data and do a fresh install for best results.
    good luck.

  4. #4
    Newbie Array

    Join Date
    Jun 2010
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Use leopardassist it fakes out your processor during installation im maybe wondering if we could develop a program to install SL on ppc macs

  5. #5
    Rookie Array

    Join Date
    Jul 2010
    Posts
    13
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I dont think that would be possible. Apple only included the intel binaries in 10.6. It could be possible if someone wrote something like Rosetta, but it would have to emulate the whole OS, and that would most likely make it slower than it is worth. It may be practical on a G5, however.


 

 

Similar Threads

  1. Snow Leopard install AMD: Nawcom Mod CD or Leopard install?
    By ozziesironmanoffroad in forum Installation
    Replies: 0
    Last Post: 12-13-2010, 09:15 PM
  2. Replies: 1
    Last Post: 08-16-2010, 08:24 PM
  3. Replies: 0
    Last Post: 01-11-2008, 09:54 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 09:47 PM.
twitter, follow us!