Results 1 to 2 of 2
Discuss "ld" not working and "i386-rtems-gcc" not installing (MacPorts) on OS X 10.8.2 VMWare at the General - Mountain Lion 10.8.x - Hackint0sh.org; I have a fundamental problem and I know I will be told to revert to ...
  1. #1
    Newbie Array

    Join Date
    Feb 2013
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Exclamation "ld" not working and "i386-rtems-gcc" not installing (MacPorts) on OS X 10.8.2 VMWare

    I have a fundamental problem and I know I will be told to revert to an older version of Mac/VMWare or just to Linux, but I'm so close to get everything working.

    Basically, I just want to be able to do work with assembly language for the Computer Science degree I'm doing at DMU. To do this I have to have installed:
    - Kate (KDE)
    - GDB
    - Insight
    - NASM
    - LD
    I have managed to install Kate, GDB and NASM (using MacPorts) with the ability to install Insight if I can get the linker (ld) up and running.

    Now, the main error message I got was through following these commands (in the Kate terminal) - my program being "eatsyscall.asm:"
    bash-3.2$ nasm -f elf -g -F stabs eatsyscall.asm
    bash-3.2$ ld -m elf_i386 -o eatsyscall eatsyscall.o
    ld: warning: option -m is obsolete and being ignored
    ld: file not found: elf_i386

    I ran "-m elf_i386" due to the fact I am running a 64-bit OS and Jeff Duntemann says so.

    I did an "ld -v," which gave me:
    @(#)PROGRAM:ld PROJECT:ld64-136
    configured to support archs: armv6 armv7 armv7s i386 x86_64
    LTO support using: LLVM version 3.2svn, from Apple Clang 4.2 (build 425.0.24)


    Following this, I basically searched for every MacPort containing "elf_i386" and "i386" and "gcc" and installed every one apart from "i386-rtems-gcc" of which I got an error when attempting to install:
    Michaels-Mac:bin michael$ sudo port install i386-rtems-gcc
    Password:
    ---> Computing dependencies for i386-rtems-gcc
    ---> Building i386-rtems-gcc
    Error: org.macports.build for port i386-rtems-gcc returned: command execution failed
    Please see the log file for port i386-rtems-gcc for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org _release_tarballs_ports_cross_i386-rtems-gcc/i386-rtems-gcc/main.log
    To report a bug, follow the instructions in the guide:
    MacPorts Guide
    Error: Processing of port i386-rtems-gcc failed


    Have I gone about this the right way? I know it's a Mac retail version I got from a torrent and the video acceleration is not integrated as I thought it would be, but it's still a decent package and it's almost solved all of my woes following the dismissal of dual booting Ubuntu.

    P.S. I do have Xcode and XQuartz installed on this machine - command line tools are enabled.
    Also, if you need to know, I am running VMWare Workstation 9 on Windows 7 Premium (64-bit) on an 8GB RAM 750GB HDD Lenovo IdeaPad Z580.



  2. #2
    Newbie Array

    Join Date
    Feb 2013
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    -------Bump.

 

 

Similar Threads

  1. Replies: 0
    Last Post: 08-14-2012, 05:30 AM
  2. Replies: 0
    Last Post: 08-14-2009, 10:10 PM
  3. [NETWORK/PRIVACY] "UDID faker" - "Anti- Call Home" Apps
    By macfr3ak in forum iPhone Developer Exchange
    Replies: 2
    Last Post: 06-12-2009, 02:08 PM
  4. "Unlock.app" can fix "no service","no wifi","IMEI 049.."
    By max9241 in forum iPhone "2G" (Rev. 1)
    Replies: 17
    Last Post: 11-11-2007, 04:12 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 11:52 AM.
twitter, follow us!