Results 1 to 3 of 3
Discuss Mounting Windows RAID Array under OSX Lion (ICH10 Softraid/FakeRaid) at the General - Lion 10.7.x - Hackint0sh.org; Hello, I'm trying to find a way to mount my Windows RAID Array under OSX ...
  1. #1
    Professional Array ouija's Avatar

    Join Date
    Apr 2009
    Posts
    82
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    26

    Default Mounting Windows RAID Array under OSX Lion (ICH10 Softraid/FakeRaid)

    Hello,

    I'm trying to find a way to mount my Windows RAID Array under OSX Lion. The array was created using the onboard Intel RAID utility and is often referred to as a FaidRaid configuration.

    Anyways, I had no issues getting the RAID mounted under my Linux OS using mdadm.

    What I would like to figure out is a way to compile mdadm under OSX to configure it to read my array, much like it does in linux. Now, if this is even possible or not is beyond me, but you don't know if you don't try, right?

    It is also possible to mount the array under Linux using dmraid as well, and I know that NTFS-3G or MacFuse is actually built-on or uses dmraid in some manner because it has an error message where is states "Please see the 'dmraid' documentation", so that may be another area to explore.

    If anyone has any idea how to compile either dmraid or mdadm under Mac OSX, or knows a better way to mount existing RAID arrays under OSX, please share your information!

    Thanks!



  2. #2
    Newbie Array

    Join Date
    Feb 2011
    Location
    Jersey City, New Jersey, United States
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    What filesystem is the RAID using? Put in as many details as possible.

  3. #3
    Professional Array ouija's Avatar

    Join Date
    Apr 2009
    Posts
    82
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    26

    Default

    Quote Originally Posted by LazarX View Post
    What filesystem is the RAID using? Put in as many details as possible.
    It's a RAID0 (striped) Array, 128k block size, formatted as NTFS with Windows 7 Ultimate 64bit installed. The array was built using the onboard Intel ICH10 Raid controller using two Samsung 128GB SSD drives.

    I have a modified AppleAHCIPork.kext which detects the ICH10 onboard controller in RAID mode, and can see the two Samsung SSDs, but because it cannot read or mount the RAID, it asks to initialize the disks (which I subsequently ignore).

    I also have Linux Mint 13 installed on another drive, which is able to mount and read the Windows RAID by using the "mdadm" software package, which is why I was curious if it's possible to somehow port this across to OSX.

 

 

Similar Threads

  1. MacNN: Review: Weibetech RTX220-QR RAID array enclosure
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 08-02-2011, 04:00 AM
  2. Intel SASWT4I RAID Array not being seen, JBOD seen just fine
    By smirnuff in forum Kernel / Kext (Driver) Support
    Replies: 0
    Last Post: 01-25-2010, 09:40 PM
  3. MacNN: MacBook Pro user runs internal 240GB SSD RAID 0 array
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 09-29-2008, 06:10 PM
  4. [RAID Support] leo 10.5.1 and intel raid array
    By samykoka in forum Archiv (Leopard)
    Replies: 1
    Last Post: 04-15-2008, 02:12 AM
  5. Leopard n a raid-0 array
    By jebrum in forum Archiv (Leopard)
    Replies: 0
    Last Post: 11-29-2007, 12:40 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 08:19 AM.
twitter, follow us!