Page 1 of 2 12 LastLast
Results 1 to 10 of 11
Discuss YouTube Activation at the General - Hackint0sh.org; Hi, I've managed to succesfully activate my iphone, I have done this twice. Once to ...
  1. #1
    Newbie Array

    Join Date
    Dec 2007
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default YouTube Activation

    Hi, I've managed to succesfully activate my iphone, I have done this twice. Once to 1.1.2 using Independence (1.3.1), and then i virginized and activated to 1.1.1 using jailbreakme.com. Neither times have I been able to get any of the following applications to work:-

    - YouTube
    - Weather
    - Stocks
    - iTunes Store

    I have already attempted to fix iTunes using several ways including using the i.unlock.no installer.app source (and the surrealnetworks one, and the bigboss one). I have also attempted to follow the ging.co.nz method, and putting the 3 files in manually, and all attempts seem to do basically nothing.

    I have run each application using verbose output from ssh via openSSH and the terminal window just hangs until you close it and reports no output while running the applications.

    I am using anySim to unlock the phone however the applications hang before the unlock is applied. I have no extra applications installed apart from the basic installer.app, community sources, bsd and openSSH. The iPhone in question is a 4GB model from the USA, and I am trying to use it in the UK on the Orange network. I have also changed the time to the time in cupertino, in case the problem was to do with certificate signing times etc... This has also made no difference.

    This appears to be a permanent problem and not one associated with network connection as it has persisted for a long time and past a full virginize and restore. The actual error YouTube gives is "Cannot connect to youtube"....

    Any help at all would be great, I know the YouTube problem has been discussed endlessly however no-one seems to have answered this question apart from saying that the activation fix should work.

    Thanks
    Chris
    Last edited by chris27uk; 12-23-2007 at 02:47 AM.



  2. #2
    Amazingly Knowledgeable Array

    Join Date
    Oct 2007
    Posts
    790
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    54

    Default

    If YouTube is not activated then it says "Please Connect to iTunes"

    If it is saying "cannot connect..." then it is saying that the DATA CONNECTION is the problem.

    This seems to be in line with the fact that weather/stocks won't work!

    They would work on all phones even if YouTube didnt!

    Are you connected via WiFi? If you are an it isnt working then its down to your network - I would make the iphone forget the network and reconnect it and if you don't have wifi then it makes EVEN more sense! As it would seem the GPRS/EDGE settings are not right...

    For your information iTunes ONLY connects if it has WiFi and YouTube will not work unless it has WiFI or EDGE - normal GPRS won't do anything at all with it!

  3. #3
    Former Bender
    Guest

    Default

    Set the binaries permissions to 755.

  4. #4
    Newbie Array

    Join Date
    Dec 2007
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I am connected to wifi with a strong signal. XianLi, where you say set the binary's permissions to 755, which binary are you talking about? anySIM? or the 3 files uploaded (although these arn't binaries...)

    I'm very grateful for your quick responses thankyou

  5. #5
    Former Bender
    Guest

    Default

    Use Winscp on windows or Cyberduck on Mac.

    Connect to your phone using SFTP. (login/pass = root/alpine)

    Go inside every .app package that doesn't work, select its binary and set the permissions to 755.


  6. #6
    Former Bender
    Guest

    Default

    An Application on OS X is shown as an unique file (called package) but in fact it is a folder with an .app extension (the system binds a folder as a unique file when you put an extension ".app")

    So you must enter inside (using WinSCP for Win or Cyberduck for Mac) the Application package and change the permissions of its binary.

    For example:

    If i go inside my Applications Folder (the one that contains all my installed apps) i will see many files with the .app extension.

    Let's say i want to change the permission of the Weather.app

    I just need to go inside by double-clicking on it and i will see several files.

    The binary of an app has usually the same name as its package.

    For Weather.app application, its binary name is Weather located inside the .app (folder/package).

    So just select Weather binary and right click on it and select info in the contextual menu.

    Now check the permissions, should be 755, if not change it to.

    All binaries inside their own Application .app folder must be 755 (or in some cases 775).

    So try and let me know.
    Last edited by Former Bender; 12-23-2007 at 07:18 PM.

  7. #7
    Rookie Array

    Join Date
    Dec 2007
    Posts
    17
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hi, thank you for your reply, I just tried this, went to /root/applications/youtube.app and right clicked the youtube inside, properties and the original CHMOD was 0775 so I changed it to 0755 but it did not work!?

    I tried the quickfix from here http://limitededitioniphone.com/yout...-fix/#comments
    but no luck!?

  8. #8
    Former Bender
    Guest

    Default

    Seen that you've got same problem with several apps and it's not related to permissions, you should consider restoring your phone.

    Your iPhone system is probably corrupted.

  9. #9
    Newbie Array

    Join Date
    Dec 2007
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I've restored my phone to both 1.1.1 and 1.0.1 (as per original post) and done the chmod, weather now gives a specific error "Update Failed", other applications act exactly the same as before. Is there anything else I can try?

  10. #10
    Rookie Array

    Join Date
    Dec 2007
    Posts
    17
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hm, not sure why would it be corrupt? I just got the phone and I did the steps, downgrade, jailbreak, upgrade and installed a few apps that work just fine, even the iSolitare!? Is there anything else I could try before I do the restore?

    Once again, thank you.


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. [YouTube] 1.1.4 fix / activation
    By ramb0 in forum Free Toolchain Software (Cydia App's)
    Replies: 6
    Last Post: 06-22-2008, 08:07 AM
  2. [YouTube] activation - how to?
    By DigitALL in forum iPhone "2G" (Rev. 1)
    Replies: 10
    Last Post: 04-15-2008, 05:05 AM
  3. YouTube Activation
    By mauriciolopez_1 in forum iPhone "2G" (Rev. 1)
    Replies: 7
    Last Post: 11-08-2007, 05:38 PM
  4. youtube after activation?
    By al217739 in forum Free Toolchain Software (Cydia App's)
    Replies: 1
    Last Post: 10-29-2007, 07:25 AM
  5. Youtube Activation
    By atresso in forum General
    Replies: 2
    Last Post: 09-10-2007, 06:53 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 07:51 PM.
twitter, follow us!