i just bought 2 iphones. one has fw1.0.2 and the other i'm sure (unopened) has 1.1.1. Anyway i dont have service pack 2 and i cant get it so please dont ask me to. is there anyway to get winxp to recognize my iphone so i can unlock it. also i wanna downgrade the one with 1.1.1 to 1.0.2 in order to have a $400 itouch until the dev team figures out an unlock. any help appreciated.

ps - i couldnt find the driver for download anywhere.