Page 1 of 3 123 LastLast
Results 1 to 10 of 24
Discuss [Wifi] iPhone keeps rebooting when it's ON at the General - Hackint0sh.org; I have a rather strange problem with my 8GB iPhone for last few weeks, which ...
  1. #1
    Rookie Array

    Join Date
    May 2008
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Unhappy [Wifi] iPhone keeps rebooting when it's ON

    I have a rather strange problem with my 8GB iPhone for last few weeks, which was initially unlocked with ZiPhone 2.5 a while ago and worked perfectly for many weeks.

    The phone works fine when I put it in airplane mode or even normal mode with wifi set to "off". But, when I turn on wifi, it keeps searching for a while and then reboots. Not just once, I noticed, it has to try at least 4/5 times to finally boot sucessfuly.

    Occasionally it doesn't reboot, but still it never sees the wifi access point even when kept within few inches of the router with no encryption. I have tried the "fix wifi" option of ZiPhone 3.0., which fixes it for few seconds and allows me to connect to the access point when I enter the SSID manually. But soon after it starts its reboot cycle and I can hardly browse anything.

    I also have random freezing at the boot screen as well as lock screen when wifi is not set to "off" and it reboots all of sudden while in the middle of some game or a call.

    I have been trying out different things suggested here (mainly at http://www.hackint0sh.org/forum/showthread.php?t=37419) for last couple of weeks, but nothing has worked so far. I erased baseband using eZiPhoneTools, put it in DFU mode and restored to 1.1.4 with no improvement. I also tried installing 1.1.3 from DFU mode after erasing the baseband with ZiPhone 3.0, but still nothing ...

    Today I used the WinPwn tool to create a custom 1.1.4 firmware and loaded it, but still the same issue. Could it be a hardware issue? I am afraid Apple may not replace it as I used ZiPhone and the bootloader has been downgraded to 3.9.

    Do I have any other option? Any help / suggestion is highly appreciated.

    Thanks.

    Mods: I posted this question in another forum, which probably is not the right place; please remove it from there, Thanks.
    Last edited by rexian; 05-02-2008 at 02:57 PM.



  2. #2
    Professional Array

    Join Date
    Dec 2007
    Posts
    71
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    wifi instability issue is well known problem, who affected a lot of phones ( btw got same problem) the problem is connected with wrong calibration of the wifi tables, usually after using ziphone ( pls stop using this utility, for your own good...) or early HW unlocks ( my case) so far nothing helped pernamently, as it also might be HW problem... Reflashing BB helps temporarily, but the tables get corrupted again, also it's extremely risky operation, however I've done it few times and nothing happend so far... Pls for further info refer to the wifi-inevstigation thread in SW unlock section
    1.1.2 OTB-->1.1.4
    BL 4.6

    HW unlocked

    Wifi instability --> On
    Low signal issue --> On
    Solutions for issues above --> Off

    Hellbound Hackers

  3. #3
    Professional Array

    Join Date
    Dec 2007
    Posts
    71
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    I also should say that I've tried various downgrading cycles, including BB and BL reflashing and other SW methods, but nothing helps. Lastely so far it's impossible to recover the the corrupted tables, as each one is set depending on calibration of each phone.

    Moderators : Maybe It would worth it, to put some 'wifi instability is now impossible to repare' kinda sticky, to avoid numbers of this and similiar threads....
    Last edited by clone; 05-02-2008 at 03:04 PM.
    1.1.2 OTB-->1.1.4
    BL 4.6

    HW unlocked

    Wifi instability --> On
    Low signal issue --> On
    Solutions for issues above --> Off

    Hellbound Hackers

  4. #4
    boz
    boz is offline
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    159
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    Try the wifi fix from the dev team, that should fix it for ya
    'There is no I in threesome'

  5. #5
    Rookie Array

    Join Date
    May 2008
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by clone View Post
    I also should say that I've tried ....
    Thanks for your reply clone. But I must say that after using ZiPhone, I used the phone regularly with several different wifi access points for about a month without a single crash. I was using AT&T SIM at that time. Then later I switched to a different SIM, only after that I noticed this issue. I then put back the AT&T SIM, but things didn't improve. I can't really point at that T-Mo SIM as the phone is no better now even with AT&T SIM, but I never had a single issue before

    Quote Originally Posted by boz View Post
    Try the wifi fix from the dev team, that should fix it for ya
    Thanks boz. From the release notes though, it seems this fix resolves a different issue. The Wifi link isn't gray for me, it's enabled and I can turn it on. The problem is, 95% of the times when I turn it on, the phone crashes into multiple boot cycle.


  6. #6
    Rookie Array

    Join Date
    May 2008
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Also would like to add that the baseband nvram seems to be ok from iBooter. Here's the output -

    ] radio readnvram
    radio readnvram
    Read 1536 bytes from nvram in 618224 usec.
    Radio NVRAM Entries:
    Type: 0x0004 Size: 0x0014 Purpose: Build Name - "J574017HLVKTA"
    Type: 0x0007 Size: 0x0004 Purpose: Not Avaliable
    Type: 0x0001 Size: 0x01f4 Purpose: WIFI Calibration Data (crc 1489773019)
    Type: 0x0002 Size: 0x0006 Purpose: WIFI Hardware Address (00:1f:9b:52:3f:8d)

    Type: 0x0003 Size: 0x0006 Purpose: BT Hardware Address (00:1f:9b:52:3f:8c)
    Type: 0x0005 Size: 0x0006 Purpose: Ethernet Hardware Address (00:1f:9b:52:3f:8e)

    Anything else should I try? I haven't tried the restore to 1.0.2 option yet. Do you guys think it might help? Thanks.
    Last edited by rexian; 05-03-2008 at 08:28 AM.

  7. #7
    Professional Array

    Join Date
    Dec 2007
    Posts
    71
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    you can try is, but I would say that temporarily it will help but eventually your wifi tables will get corrupted and you will face same problems... Now nobody really knows why it happens, I must say I've got same experience as you do, at the beggining no problems at all, mine problems mainly started after HW unlock, which is with Ziphone possible aggrevating factors for the corruption of the tables. This issue has been lately investigated by one member of dev team, however don't know if it goes on or not...
    As i said above reflash baseband helps, so you can connect once or twice for pretty long time, but I alwas end up with iphone looping reboots and freezing all the time, until the wifi is switched off.
    I wish I could help more, but nothing to with this issue yet...
    1.1.2 OTB-->1.1.4
    BL 4.6

    HW unlocked

    Wifi instability --> On
    Low signal issue --> On
    Solutions for issues above --> Off

    Hellbound Hackers

  8. #8
    Supporter/Apple CEO
    Newsreporter
    Array secretmrx's Avatar

    Join Date
    Feb 2008
    Location
    New Zealand
    Posts
    468
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    49

    Default

    have u tried swifi at all? One of the things it does resolve is the gray wifi, but its main function is to fix corrupt wifi tables (which is what causes the gray wifi). I would download swifi and try it. It sounds like you have corrupt tables, if you do, swifi will detect it and fix it in 3 seconds

  9. #9
    Professional Array

    Join Date
    Dec 2007
    Posts
    71
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    problem with swifi is that it corrects only final checksum, but usually this is problem of individual table checksums ( this isn't absolute, I'm not so sure ), that is also why sometimes iphone behaves differently on different wifi networks

    (pls do correct me if im wrong)
    Last edited by clone; 05-03-2008 at 02:51 PM.
    1.1.2 OTB-->1.1.4
    BL 4.6

    HW unlocked

    Wifi instability --> On
    Low signal issue --> On
    Solutions for issues above --> Off

    Hellbound Hackers

  10. #10
    Rookie Array

    Join Date
    May 2008
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Thanks secretmrx. I don't have much to lose so I'd love to try swifi fix, but I don't have a Mac handy. Correct me if I am wrong but I think I can't use BootNeuter to become fakeblanked with a Vista machine and also, my iPhone is stuck with 3.9BL.

    Is there a way I could upgrade to 4.6BL? I am leaving for vacation in couple of days and thought I could enjoy wifi at the hotel, but ...

    Right now I am taking clone's advice and reflashing the baseband. Hopefully it'll allow me to install a few games ...
    Last edited by rexian; 05-03-2008 at 04:10 PM.


 

 
Page 1 of 3 123 LastLast

Similar Threads

  1. Rebooting my iPhone 3G
    By surprise me in forum iPhone 3G
    Replies: 1
    Last Post: 03-17-2011, 08:04 PM
  2. I am losing WiFi after rebooting my Jailbreak iPhone
    By Abazinho in forum Blacksn0w (3G(S) unlock)
    Replies: 21
    Last Post: 11-23-2009, 06:49 AM
  3. [Problem] wifi turns itself off when rebooting iPhone after unlock
    By 2low4snow in forum Yellowsn0w (3G unlock)
    Replies: 9
    Last Post: 02-05-2009, 08:08 PM
  4. Crisis! The iPhone just keeps rebooting
    By vincechase in forum iPhone "2G" (Rev. 1)
    Replies: 3
    Last Post: 11-18-2007, 09:08 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 09:01 AM.
twitter, follow us!