Results 1 to 3 of 3
Discuss [WiFi] AdHoc connection always fail on 1.1.3 and above at the General - Hackint0sh.org; hi.... i don't have wifi router as access point, so i create a adhoc wifi ...
  1. #1
    Senior Professional Array

    Join Date
    Oct 2007
    Posts
    106
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Unhappy [WiFi] AdHoc connection always fail on 1.1.3 and above

    hi....

    i don't have wifi router as access point, so i create a adhoc wifi connection an my laptop and turn on "internet connection sharing" for my adhoc wifi...

    when i turn on wifi on my iphone it detect the adhoc connection, when i try to join network it says "unable to join the network" but i click one more time than it suddenly accept the connection.... (i dont use WEP)

    i can use installer and safari smoothly....

    now after upgrade firmware to 1.1.3 and 1.1.4 ... after successfully connected even the warning "unable to join the network" still appear.... after a few second the wifi connection suddenly disconnected.... in safari it always ask me to choose another wifi network....

    so now i cannot use my adhoc wifi connection on my laptop to browse with safari neither using installer ....

    maybe someone can give a helpful comment on my problem here?

    on my iphone wifi properties i can see the value of my detected network :

    IP address
    Subnet Mask
    Router
    DNS

    the value of router and dns is the same



  2. #2
    Newbie Array

    Join Date
    Mar 2008
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    You need boss pref to turn off the edge in iphone. you have to be carefull that edge is turned off or not. because edge get ip address too and rises some kind of conflict with wifi ip whether its is same or not.

    now all you need is
    1)proxy ++ freeware on your laptop.
    2)laptop must reciving internet from different wireless card or network card.
    3)now setup your wifi card's property that you want to use with iphone
    create SSID iphone and set it to connect to adhoc network only.
    now go to TCP/IP prperties of that card and set your manual ip to 10.0.0.1
    and subnet to 255.0.0.0
    Close it when you are done.
    4) now go to iphone wifi. turned it on and it should see the adhoc network there.
    click blue arrow on right. now you have to setup iphone.
    5) click static on that newtwork's property and give ip 10.0.0.2 and
    subnet 255.0.0.0
    now go all way down to HTTP proxy and select manual.
    Put your laptop's wifi card ip, which is 10.0.0.1 and set port.
    for proxy ++ it is 4480. if you are using other proxy program . it could be 8080 or something like that.
    and you all set to use wifi on 1.1.3 or 1.1.4.
    But you must note that, you have to turned off edge using boss pref. if it is not turned off. your iphone wifi wont even care turnning on for ad- hoc network. I tried 2 times to turned off the edge. i succeded in 2nd chance. using boss pref. to check that edge is turned off or not. you have to go to boss pref again after turning off edge to check that there is no ip showing right next to edge key word. it should (N/A).
    this is a workaround i found spending 2 nights.
    it works 100% with 1.1.4.
    Please rep if you need more help on this.
    Last edited by bilyindian; 03-28-2008 at 04:13 PM.

  3. #3
    Senior Professional Array

    Join Date
    Oct 2007
    Posts
    106
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    where can i get proxy ++ freeware?
    nice workaround idea...... i never think of using proxy
    thanks a lot for replying

 

 

Similar Threads

  1. WiFi connection
    By tabargan in forum Tools
    Replies: 0
    Last Post: 04-05-2008, 09:23 PM
  2. [1.0.2 OTB] No WiFi connection
    By nemesisnr in forum iPhone "2G" (Rev. 1)
    Replies: 2
    Last Post: 01-27-2008, 11:39 PM
  3. OTB unlock Fail, Lost WIFI - HELP US
    By magicalism in forum iPhone "2G" (Rev. 1)
    Replies: 2
    Last Post: 01-19-2008, 06:40 PM
  4. [Help] OTB 1.1.1 AnySim 1.1 fail, NO IMEI, FIRMWARE, WIFI
    By cyleung in forum iPhone "2G" (Rev. 1)
    Replies: 0
    Last Post: 11-10-2007, 04:58 AM
  5. Replies: 3
    Last Post: 07-24-2007, 06:27 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 04:46 AM.
twitter, follow us!