I followed someone's instruction here and downloaded the apptab from nullriver, unzipped the package and put the installer.app onto my iphone. it runs fine but the version is quite old it seems 2.6?? what is yours?