i have an unlocked 1.0.2 iphone. i want to upgrade to 1.1.1 but i cannot edit sources through installer. im assuming i need a newer version of app tapp installer on my phone. i tried that once before but it appears that the version i used was meant for 1.1.1 so it caused a bunch of problems. does anyone have any tips on how to get the proper version on there?