Results 1 to 7 of 7
Discuss Terminal question!!!! at the General - Hackint0sh.org; I'm trying to SSH into my iPhone, and once I do "ssh 192.168.1.100", it connects ...
  1. #1
    Rookie Array

    Join Date
    Sep 2007
    Location
    Morgan Hill, CA
    Posts
    26
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Terminal question!!!!

    I'm trying to SSH into my iPhone, and once I do "ssh 192.168.1.100", it connects successfully, but as soon as I type ANY three characters, the connection ends.

    So, if i type "cd " it will end the connection.

    Anyone know why?




  2. #2
    Senior Professional Array

    Join Date
    Jul 2007
    Posts
    244
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    19

    Default

    Quote Originally Posted by oxeneers View Post
    I'm trying to SSH into my iPhone, and once I do "ssh 192.168.1.100", it connects successfully, but as soon as I type ANY three characters, the connection ends.

    So, if i type "cd " it will end the connection.

    Anyone know why?
    I recall this happening when me when i first jail-broke 1.0.2. I think it had something to do with the default ssh (dropbear) that came with iNdependence which was not successfully installed. I think it was resolved when i installed OpenSSH from Installer.

  3. #3
    Rookie Array

    Join Date
    Sep 2007
    Location
    Morgan Hill, CA
    Posts
    26
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hmm... in Services.app, it lists two different SSH options... is that normal?

    The bottom one was set to OFF, so I turned it ON. See, my issue is I'm trying to install the Virginiser on the phone, but I can't manually SSH into it using Terminal. Cyberduck and Fugu (the one I use) work perfectly fine.

    Any other ideas?

  4. #4
    Senior Professional Array

    Join Date
    Jul 2007
    Posts
    244
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    19

    Default

    Quote Originally Posted by oxeneers View Post
    Hmm... in Services.app, it lists two different SSH options... is that normal?

    The bottom one was set to OFF, so I turned it ON. See, my issue is I'm trying to install the Virginiser on the phone, but I can't manually SSH into it using Terminal. Cyberduck and Fugu (the one I use) work perfectly fine.

    Any other ideas?
    You have two SSH in services because one of them was installed probably by iNdependence when you activated and jail-broke your iPHone. The second one is probably Openssh installed from Installer.

    I recommend getting rid of Dropbear SSH and keep OpenSSH. Use this procedure:
    http://*****************************...RemoveDropbear

    Ooops, looks like the iPhone Elite team's website is censored. Here's the same article on this forum:
    http://hackint0sh.org/forum/showpost...68&postcount=6
    Last edited by ktula; 10-24-2007 at 04:54 AM. Reason: website address did not show up

  5. #5
    Amazingly Knowledgeable Array JSN1's Avatar

    Join Date
    Jul 2007
    Location
    localhost
    Posts
    793
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    56

    Default

    Do you have the mobile terminal installed on the iPhone?
    this happens also in mobile terminal?
    If this happens also in mobile terminal, check the permissions of the file login in the folder where the utilities of the BSD subsystem are kept.
    Or reinstall the BSD Subsystem.


  6. #6
    Senior Professional Array

    Join Date
    Jul 2007
    Posts
    244
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    19

    Default

    Quote Originally Posted by JSN1 View Post
    Do you have the mobile terminal installed on the iPhone?
    this happens also in mobile terminal?
    If this happens also in mobile terminal, check the permissions of the file login in the folder where the utilities of the BSD subsystem are kept.
    Or reinstall the BSD Subsystem.
    I believe JSN1 is right. I think when i had this problem, re-installing the BSD subsystem package from the installer resolved this issue. Sorry for my earlier misdirection.

  7. #7
    Rookie Array

    Join Date
    Sep 2007
    Location
    Morgan Hill, CA
    Posts
    26
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Perfect, it works. Instead of where it says -sh-3.2 .. it just has a #

    This is great, thanks a lot guys.

 

 

Similar Threads

  1. [Question] [2.1]Mobile Terminal question
    By lolof in forum Free Toolchain Software (Cydia App's)
    Replies: 1
    Last Post: 10-10-2008, 05:14 PM
  2. [Terminal] Fix for SuidLibFix: Main Script Execution failed (Terminal Password)
    By GuGaPires in forum Free Toolchain Software (Cydia App's)
    Replies: 1
    Last Post: 07-08-2008, 11:29 AM
  3. Replies: 3
    Last Post: 02-12-2008, 09:12 PM
  4. Stupid Question: how to open SSh terminal
    By maskwearer in forum General
    Replies: 0
    Last Post: 09-05-2007, 06:34 PM
  5. iPhoneInterface 1.0 terminal question
    By TheGuide in forum General
    Replies: 8
    Last Post: 07-06-2007, 10:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 08:22 AM.
twitter, follow us!